aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/expat
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>1999-08-26 21:45:48 +0800
committerdirk <dirk@FreeBSD.org>1999-08-26 21:45:48 +0800
commit0dc9daf067d8c965906386ef9979866c043c5062 (patch)
treeff3a30e5a83246276ff5e3edf7374c2945090fef /textproc/expat
parent32f6e8d65696ea48ce4cfabd41a5d03c6930db29 (diff)
downloadfreebsd-ports-gnome-0dc9daf067d8c965906386ef9979866c043c5062.tar.gz
freebsd-ports-gnome-0dc9daf067d8c965906386ef9979866c043c5062.tar.zst
freebsd-ports-gnome-0dc9daf067d8c965906386ef9979866c043c5062.zip
Initial import of expat, a
XML 1.0 parser written in C.
Diffstat (limited to 'textproc/expat')
-rw-r--r--textproc/expat/Makefile26
-rw-r--r--textproc/expat/distinfo1
-rw-r--r--textproc/expat/pkg-comment1
-rw-r--r--textproc/expat/pkg-descr2
-rw-r--r--textproc/expat/pkg-plist5
5 files changed, 35 insertions, 0 deletions
diff --git a/textproc/expat/Makefile b/textproc/expat/Makefile
new file mode 100644
index 000000000000..cfc66059a8bb
--- /dev/null
+++ b/textproc/expat/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: expat
+# Version required: 1.1
+# Date created: Thu Aug 26 14:38:07 CEST 1999
+# Whom: Dirk Froemberg <dirk@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= expat
+PKGNAME= expat-1.1
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.jclark.com/pub/xml/ \
+ http://www.physik.TU-Berlin.DE/~ibex/ports/distfiles/
+
+MAINTAINER= dirk@FreeBSD.org
+
+USE_ZIP= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xmlwf/xmlwf ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/include/xml
+ ${INSTALL_DATA} ${WRKSRC}/xmlparse/xmlparse.h ${PREFIX}/include/xml
+ ${INSTALL_DATA} ${WRKSRC}/xmltok/xmltok.h ${PREFIX}/include/xml
+ ${INSTALL_DATA} ${WRKSRC}/libexpat.a ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/textproc/expat/distinfo b/textproc/expat/distinfo
new file mode 100644
index 000000000000..cfa337b1a010
--- /dev/null
+++ b/textproc/expat/distinfo
@@ -0,0 +1 @@
+MD5 (expat.zip) = 9111cc7764ff900229d9e51c03f4a593
diff --git a/textproc/expat/pkg-comment b/textproc/expat/pkg-comment
new file mode 100644
index 000000000000..18273b8bec68
--- /dev/null
+++ b/textproc/expat/pkg-comment
@@ -0,0 +1 @@
+XML 1.0 parser written in C
diff --git a/textproc/expat/pkg-descr b/textproc/expat/pkg-descr
new file mode 100644
index 000000000000..7d397c0fa4a9
--- /dev/null
+++ b/textproc/expat/pkg-descr
@@ -0,0 +1,2 @@
+Expat is an XML 1.0 parser written in C. It aims to be fully
+conforming. It is currently not a validating XML processor.
diff --git a/textproc/expat/pkg-plist b/textproc/expat/pkg-plist
new file mode 100644
index 000000000000..e8658c72b36c
--- /dev/null
+++ b/textproc/expat/pkg-plist
@@ -0,0 +1,5 @@
+bin/xmlwf
+include/xml/xmlparse.h
+include/xml/xmltok.h
+lib/libexpat.a
+@dirrm include/xml