aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/fileshuffle
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-21 01:57:09 +0800
committerMartin Wilke <miwi@FreeBSD.org>2008-06-21 01:57:09 +0800
commit07d5e942dbbe5a39580a73ec1d0da4fd9aa0e8b8 (patch)
tree04c5b5c856803a31677a899385f09bb36b1cba79 /textproc/fileshuffle
parent916433b4911c893cb1ffa9ff3bdf2837806b0715 (diff)
downloadfreebsd-ports-gnome-07d5e942dbbe5a39580a73ec1d0da4fd9aa0e8b8.tar.gz
freebsd-ports-gnome-07d5e942dbbe5a39580a73ec1d0da4fd9aa0e8b8.tar.zst
freebsd-ports-gnome-07d5e942dbbe5a39580a73ec1d0da4fd9aa0e8b8.zip
shuffle, as its name implies, shuffles the lines of its input (either
standard input, or the named files) into random order. It is in a sense the very inverse of sort(1)). WWW: http://www.eskimo.com/~scs/src/#shuffle PR: ports/124100 Submitted by: Greg Larkin <glarkin at sourcehosting.net>
Diffstat (limited to 'textproc/fileshuffle')
-rw-r--r--textproc/fileshuffle/Makefile25
-rw-r--r--textproc/fileshuffle/distinfo3
-rw-r--r--textproc/fileshuffle/pkg-descr5
3 files changed, 33 insertions, 0 deletions
diff --git a/textproc/fileshuffle/Makefile b/textproc/fileshuffle/Makefile
new file mode 100644
index 000000000000..b43523f006d2
--- /dev/null
+++ b/textproc/fileshuffle/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: fileshuffle
+# Date created: 2008-05-29
+# Whom: Greg Larkin <glarkin@sourcehosting.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fileshuffle
+PORTVERSION= 0.1
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.eskimo.com/u/s/scs/src/
+DISTNAME= shuffle
+
+MAINTAINER= glarkin@sourcehosting.net
+COMMENT= A filter for shuffling lines in a text file into random order
+
+MANPAGE= shuffle.1
+
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+
+do-install:
+ @${CP} ${WRKSRC}/shuffle ${PREFIX}/bin/${PORTNAME}
+ @${CP} ${WRKSRC}/${MANPAGE} ${PREFIX}/man/man1/${PORTNAME}.1
+.include <bsd.port.mk>
diff --git a/textproc/fileshuffle/distinfo b/textproc/fileshuffle/distinfo
new file mode 100644
index 000000000000..257c986e6401
--- /dev/null
+++ b/textproc/fileshuffle/distinfo
@@ -0,0 +1,3 @@
+MD5 (shuffle.tar.gz) = 22b271c58d0abd618260a06ff45786d2
+SHA256 (shuffle.tar.gz) = f9eab7047cea96daccccfae6453dacec1696a5a25f76e1e059364239958c05ae
+SIZE (shuffle.tar.gz) = 16780
diff --git a/textproc/fileshuffle/pkg-descr b/textproc/fileshuffle/pkg-descr
new file mode 100644
index 000000000000..cd4418553e2d
--- /dev/null
+++ b/textproc/fileshuffle/pkg-descr
@@ -0,0 +1,5 @@
+shuffle, as its name implies, shuffles the lines of its input (either
+standard input, or the named files) into random order. It is in a
+sense the very inverse of sort(1)).
+
+WWW: http://www.eskimo.com/~scs/src/#shuffle