aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/gladtex
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
committerdinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
commit530706893f31269bbfa303e069f2e76cbbe2fce7 (patch)
treea8077a0d6e20d70b39e6a7fe3e57a6dafe7c7f33 /textproc/gladtex
parent9d262811a145d3e715edefd1d5d64ceac41de547 (diff)
downloadfreebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.gz
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.zst
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.zip
- update png to 1.5.10
Diffstat (limited to 'textproc/gladtex')
-rw-r--r--textproc/gladtex/Makefile6
-rw-r--r--textproc/gladtex/files/patch-eqn2img.c22
2 files changed, 23 insertions, 5 deletions
diff --git a/textproc/gladtex/Makefile b/textproc/gladtex/Makefile
index e2c89281d459..694c1d162b23 100644
--- a/textproc/gladtex/Makefile
+++ b/textproc/gladtex/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gladtex
PORTVERSION= 1.2
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= textproc math www
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,7 +18,7 @@ COMMENT= A program to replace LaTeX formulas in HTML files with images
LICENSE= GPLv2
LIB_DEPENDS= gif.5:${PORTSDIR}/graphics/giflib \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX \
dvips:${PORTSDIR}/print/dvipsk-tetex
@@ -28,7 +28,7 @@ BINPATH= ${PREFIX}/bin
INCPATH= -I${LOCALBASE}/include
LIBPATH= -L${LOCALBASE}/lib
-MAKE_ENV+= BINPATH=${BINPATH} INCPATH=${INCPATH} LIBPATH=${LIBPATH}
+MAKE_ENV+= BINPATH=${BINPATH} INCPATH="${INCPATH}" LIBPATH=${LIBPATH}
.if !defined(NO_INSTALL_MANPAGES)
MAN1= ${PORTNAME}.1
diff --git a/textproc/gladtex/files/patch-eqn2img.c b/textproc/gladtex/files/patch-eqn2img.c
index 8ce0099711e6..321948086d70 100644
--- a/textproc/gladtex/files/patch-eqn2img.c
+++ b/textproc/gladtex/files/patch-eqn2img.c
@@ -1,5 +1,23 @@
---- ./eqn2img.c.orig 2012-05-01 18:17:08.000000000 +0200
-+++ ./eqn2img.c 2012-05-01 18:18:00.000000000 +0200
+--- eqn2img.c.orig 2010-07-31 17:30:20.000000000 +0200
++++ eqn2img.c 2012-05-06 15:41:55.000000000 +0200
+@@ -367,7 +367,7 @@
+ info_ptr = png_create_info_struct(png_ptr);
+ assert(info_ptr);
+
+- if(setjmp(png_ptr->jmpbuf)) {
++ if(setjmp(png_jmpbuf(png_ptr))) {
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ fclose(fp);
+ return NULL;
+@@ -580,7 +580,7 @@
+ assert(info_ptr);
+
+ /* error handling, libpng longjmps here on any error */
+- if(setjmp(png_ptr->jmpbuf)) {
++ if(setjmp(png_jmpbuf(png_ptr))) {
+ png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
+ fclose(fp);
+ return -1;
@@ -715,7 +715,7 @@
fprintf(stderr, " -> ps");