aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/gnome-doc-utils
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-03-19 13:14:07 +0800
committermarcus <marcus@FreeBSD.org>2007-03-19 13:14:07 +0800
commite83248f2b323aa90dfea75471b86ccc444a80f88 (patch)
treef4fc2dbabf96cb67c502479d9fc13f40bf0d0108 /textproc/gnome-doc-utils
parent52dd0c5de1d6a7165dc355ecf161f52bb7dbbfda (diff)
downloadfreebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.tar.gz
freebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.tar.zst
freebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.zip
Presenting GNOME 2.18 for FreeBSD. GNOME 2.18 is a departure from recent GNOME
releases in that it focuses more on stability and functionality than on new features. Not that it doesn't have its share of new and exciting items. See http://www.gnome.org/start/2.18/ for all the goodies in this release. GNOME 2.18 for FreeBSD would not have been possible without the hard work of the FreeBSD GNOME Team and our intrepid band of testers including J. W. Ballantine, Pawel Worach, Yasuda Keisuke, Pascal Hofstee, miwi, Yoshihiro Ota, Vladimir Grebenschikov, Jukka A. Ukkonen, Phillip Neumann, Franz Klammer, and Neal Delmonico.
Diffstat (limited to 'textproc/gnome-doc-utils')
-rw-r--r--textproc/gnome-doc-utils/Makefile9
-rw-r--r--textproc/gnome-doc-utils/distinfo6
-rw-r--r--textproc/gnome-doc-utils/files/patch-xml2po__xml2po.py41
-rw-r--r--textproc/gnome-doc-utils/pkg-plist24
4 files changed, 28 insertions, 52 deletions
diff --git a/textproc/gnome-doc-utils/Makefile b/textproc/gnome-doc-utils/Makefile
index ec389ff83990..79d224523ef8 100644
--- a/textproc/gnome-doc-utils/Makefile
+++ b/textproc/gnome-doc-utils/Makefile
@@ -3,20 +3,21 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/textproc/gnome-doc-utils/Makefile,v 1.44 2007/03/13 00:37:32 mezz Exp $
#
PORTNAME= gnome-doc-utils
-PORTVERSION= 0.7.2
-PORTREVISION= 1
+PORTVERSION= 0.10.1
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-doc-utils/0.7
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= gnome-doc-utils-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME doc utils
-BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
+BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper \
+ gawk:${PORTSDIR}/lang/gawk
RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper \
${PYTHON_SITELIBDIR}/libxml2mod.so:${PORTSDIR}/textproc/py-libxml2 \
${LOCALBASE}/share/xml/docbook/4.3/catalog.xml:${PORTSDIR}/textproc/docbook-xml-430 \
diff --git a/textproc/gnome-doc-utils/distinfo b/textproc/gnome-doc-utils/distinfo
index c6b6c87e5783..202ff4a6607f 100644
--- a/textproc/gnome-doc-utils/distinfo
+++ b/textproc/gnome-doc-utils/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome-doc-utils-0.7.2.tar.bz2) = 3f3903e5a3e3b05261498d907f2471a9
-SHA256 (gnome-doc-utils-0.7.2.tar.bz2) = aa2f8fed9aa95aff9c2a7d627a85cc428cef3dfa0cccd538dcfc41446bde8b8d
-SIZE (gnome-doc-utils-0.7.2.tar.bz2) = 405767
+MD5 (gnome-doc-utils-0.10.1.tar.bz2) = 208775a4b6c6d9ea0478a84afb36701f
+SHA256 (gnome-doc-utils-0.10.1.tar.bz2) = 7cd6c5bc72cb4f9ff4f173c957dcea1b71bbea3191bb337772eca57614f6b643
+SIZE (gnome-doc-utils-0.10.1.tar.bz2) = 427716
diff --git a/textproc/gnome-doc-utils/files/patch-xml2po__xml2po.py b/textproc/gnome-doc-utils/files/patch-xml2po__xml2po.py
deleted file mode 100644
index e0620056fab5..000000000000
--- a/textproc/gnome-doc-utils/files/patch-xml2po__xml2po.py
+++ /dev/null
@@ -1,41 +0,0 @@
---- xml2po/xml2po.py.orig Sun Apr 2 03:47:17 2006
-+++ xml2po/xml2po.py Fri Oct 20 00:57:46 2006
-@@ -242,14 +242,10 @@
- text = normalizeString(text, not spacepreserve)
- if (text.strip() == ''):
- return text
-- file = open(mofile, "rb")
-- if file:
-- myfallback = NoneTranslations()
-- gt = gettext.GNUTranslations(file)
-- gt.add_fallback(myfallback)
-- if gt:
-- res = gt.ugettext(text.decode('utf-8'))
-- return res
-+ global gt
-+ if gt:
-+ res = gt.ugettext(text.decode('utf-8'))
-+ return res
-
- return text
-
-@@ -648,6 +644,7 @@
- filename = ''
- origxml = ''
- mofile = ''
-+gt = None
- ultimate = [ ]
- ignored = [ ]
- filenames = [ ]
-@@ -763,6 +760,11 @@
- if mode=='merge' and mofile=='':
- print >> sys.stderr, "Error: You must specify MO file when merging translations."
- sys.exit(3)
-+
-+file = open(mofile, "rb")
-+if file:
-+ gt = gettext.GNUTranslations(file)
-+ gt.add_fallback(NoneTranslations())
-
- ultimate_tags = read_finaltags(ultimate)
- ignored_tags = read_ignoredtags(ignored)
diff --git a/textproc/gnome-doc-utils/pkg-plist b/textproc/gnome-doc-utils/pkg-plist
index 054f92b11100..7ed23ca2d134 100644
--- a/textproc/gnome-doc-utils/pkg-plist
+++ b/textproc/gnome-doc-utils/pkg-plist
@@ -1,4 +1,5 @@
bin/gnome-doc-prepare
+bin/gnome-doc-tool
bin/xml2po
libdata/pkgconfig/gnome-doc-utils.pc
libdata/pkgconfig/xml2po.pc
@@ -34,7 +35,6 @@ share/gnome/help/gnome-doc-xslt/C/db2html-list.xml
share/gnome/help/gnome-doc-xslt/C/db2html-media.xml
share/gnome/help/gnome-doc-xslt/C/db2html-qanda.xml
share/gnome/help/gnome-doc-xslt/C/db2html-refentry.xml
-share/gnome/help/gnome-doc-xslt/C/db2html-suppressed.xml
share/gnome/help/gnome-doc-xslt/C/db2html-table.xml
share/gnome/help/gnome-doc-xslt/C/db2html-title.xml
share/gnome/help/gnome-doc-xslt/C/db2html-xref.xml
@@ -45,7 +45,6 @@ share/gnome/help/gnome-doc-xslt/C/gnome-doc-xslt.xml
share/gnome/help/gnome-doc-xslt/C/l10n-numbers.xml
share/gnome/help/gnome-doc-xslt/C/legal.xml
share/gnome/help/gnome-doc-xslt/C/translating.xml
-share/gnome/help/gnome-doc-xslt/C/xsldoc.xml
share/gnome/omf/gnome-doc-make/gnome-doc-make-C.omf
share/gnome/omf/gnome-doc-xslt/gnome-doc-xslt-C.omf
share/locale/ar/LC_MESSAGES/gnome-doc-utils.mo
@@ -63,6 +62,7 @@ share/locale/en_CA/LC_MESSAGES/gnome-doc-utils.mo
share/locale/en_GB/LC_MESSAGES/gnome-doc-utils.mo
share/locale/es/LC_MESSAGES/gnome-doc-utils.mo
share/locale/et/LC_MESSAGES/gnome-doc-utils.mo
+share/locale/eu/LC_MESSAGES/gnome-doc-utils.mo
share/locale/fi/LC_MESSAGES/gnome-doc-utils.mo
share/locale/fr/LC_MESSAGES/gnome-doc-utils.mo
share/locale/gl/LC_MESSAGES/gnome-doc-utils.mo
@@ -77,22 +77,29 @@ share/locale/ka/LC_MESSAGES/gnome-doc-utils.mo
share/locale/ko/LC_MESSAGES/gnome-doc-utils.mo
share/locale/lt/LC_MESSAGES/gnome-doc-utils.mo
share/locale/lv/LC_MESSAGES/gnome-doc-utils.mo
+share/locale/mg/LC_MESSAGES/gnome-doc-utils.mo
+share/locale/mk/LC_MESSAGES/gnome-doc-utils.mo
share/locale/ml/LC_MESSAGES/gnome-doc-utils.mo
share/locale/mn/LC_MESSAGES/gnome-doc-utils.mo
+share/locale/mr/LC_MESSAGES/gnome-doc-utils.mo
share/locale/nb/LC_MESSAGES/gnome-doc-utils.mo
share/locale/ne/LC_MESSAGES/gnome-doc-utils.mo
share/locale/nl/LC_MESSAGES/gnome-doc-utils.mo
+share/locale/or/LC_MESSAGES/gnome-doc-utils.mo
share/locale/pa/LC_MESSAGES/gnome-doc-utils.mo
+share/locale/pl/LC_MESSAGES/gnome-doc-utils.mo
share/locale/pt/LC_MESSAGES/gnome-doc-utils.mo
share/locale/pt_BR/LC_MESSAGES/gnome-doc-utils.mo
share/locale/ro/LC_MESSAGES/gnome-doc-utils.mo
share/locale/ru/LC_MESSAGES/gnome-doc-utils.mo
share/locale/rw/LC_MESSAGES/gnome-doc-utils.mo
share/locale/sk/LC_MESSAGES/gnome-doc-utils.mo
+share/locale/sl/LC_MESSAGES/gnome-doc-utils.mo
share/locale/sq/LC_MESSAGES/gnome-doc-utils.mo
share/locale/sr/LC_MESSAGES/gnome-doc-utils.mo
share/locale/sr@Latn/LC_MESSAGES/gnome-doc-utils.mo
share/locale/sv/LC_MESSAGES/gnome-doc-utils.mo
+share/locale/ta/LC_MESSAGES/gnome-doc-utils.mo
share/locale/th/LC_MESSAGES/gnome-doc-utils.mo
share/locale/tr/LC_MESSAGES/gnome-doc-utils.mo
share/locale/ug/LC_MESSAGES/gnome-doc-utils.mo
@@ -134,11 +141,11 @@ share/xml/gnome/xslt/docbook/html/db2html.xsl
share/xml/gnome/xslt/docbook/omf/db2omf.xsl
share/xml/gnome/xslt/docbook/utils/chunks.xsl
share/xml/gnome/xslt/docbook/utils/credits.xsl
+share/xml/gnome/xslt/docbook/utils/figures.xsl
share/xml/gnome/xslt/docbook/utils/ids.xsl
share/xml/gnome/xslt/gettext/gettext.xsl
share/xml/gnome/xslt/gettext/l10n-numbers.xsl
share/xml/gnome/xslt/gettext/l10n.xml
-share/xml/gnome/xslt/xsldoc/xsldoc.xsl
share/xml2po/docbook.py
share/xml2po/docbook.pyc
share/xml2po/empty.py
@@ -147,8 +154,9 @@ share/xml2po/gs.py
share/xml2po/gs.pyc
share/xml2po/ubuntu.py
share/xml2po/ubuntu.pyc
+share/xml2po/xhtml.py
+share/xml2po/xhtml.pyc
@dirrm share/xml2po
-@dirrm share/xml/gnome/xslt/xsldoc
@dirrm share/xml/gnome/xslt/gettext
@dirrm share/xml/gnome/xslt/docbook/utils
@dirrm share/xml/gnome/xslt/docbook/omf
@@ -177,6 +185,8 @@ share/xml2po/ubuntu.pyc
@dirrmtry share/locale/ug
@dirrmtry share/locale/sr/LC_MESSAGES
@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
@dirrmtry share/locale/sk/LC_MESSAGES
@dirrmtry share/locale/sk
@dirrmtry share/locale/rw/LC_MESSAGES
@@ -185,8 +195,14 @@ share/xml2po/ubuntu.pyc
@dirrmtry share/locale/ro
@dirrmtry share/locale/pt/LC_MESSAGES
@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
@dirrmtry share/locale/ne/LC_MESSAGES
@dirrmtry share/locale/ne
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
@dirrmtry share/locale/ko/LC_MESSAGES
@dirrmtry share/locale/ko
@dirrmtry share/locale/gl/LC_MESSAGES