aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/hs-xmlhtml
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2011-08-14 04:59:10 +0800
committerpgj <pgj@FreeBSD.org>2011-08-14 04:59:10 +0800
commit7e868710f76c8feaca767305da08199c11d36675 (patch)
tree2ee26e39b285a35dd0888dd079506ca2df393479 /textproc/hs-xmlhtml
parenta7635e40e7b5dc1adea35a79159534d97d0320a1 (diff)
downloadfreebsd-ports-gnome-7e868710f76c8feaca767305da08199c11d36675.tar.gz
freebsd-ports-gnome-7e868710f76c8feaca767305da08199c11d36675.tar.zst
freebsd-ports-gnome-7e868710f76c8feaca767305da08199c11d36675.zip
Contains renderers and parsers for both XML and HTML 5 document fragments,
which share data structures wo that it's easy to work with both. Document fragments are bits of documents, which are not constrained by some of the high-level structure rules (in particular, they may contain more than one root element). WWW: http://hackage.haskell.org/package/xmlhtml Obtained from: FreeBSD Haskell
Diffstat (limited to 'textproc/hs-xmlhtml')
-rw-r--r--textproc/hs-xmlhtml/Makefile21
-rw-r--r--textproc/hs-xmlhtml/distinfo2
-rw-r--r--textproc/hs-xmlhtml/pkg-descr16
3 files changed, 39 insertions, 0 deletions
diff --git a/textproc/hs-xmlhtml/Makefile b/textproc/hs-xmlhtml/Makefile
new file mode 100644
index 000000000000..52c5ceac26f7
--- /dev/null
+++ b/textproc/hs-xmlhtml/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-xmlhtml
+# Date created: March 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlhtml
+PORTVERSION= 0.1.5.2
+CATEGORIES= textproc haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= XML parser and renderer with HTML 5 quirks mode
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= blaze-builder>=0.2 blaze-html>=0.3.2 parsec>=3.0 text>=0.11
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/textproc/hs-xmlhtml/distinfo b/textproc/hs-xmlhtml/distinfo
new file mode 100644
index 000000000000..e52b17ffcc60
--- /dev/null
+++ b/textproc/hs-xmlhtml/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/xmlhtml-0.1.5.2.tar.gz) = 35a83ba09a69b429583ea4e7c583b6e4292cf85de9e5d4e6588735dff0c7a4c4
+SIZE (cabal/xmlhtml-0.1.5.2.tar.gz) = 123539
diff --git a/textproc/hs-xmlhtml/pkg-descr b/textproc/hs-xmlhtml/pkg-descr
new file mode 100644
index 000000000000..3ee582657bad
--- /dev/null
+++ b/textproc/hs-xmlhtml/pkg-descr
@@ -0,0 +1,16 @@
+Contains renderers and parsers for both XML and HTML 5 document fragments,
+which share data structures wo that it's easy to work with both. Document
+fragments are bits of documents, which are not constrained by some of the
+high-level structure rules (in particular, they may contain more than one
+root element).
+
+Note that this is not a compliant HTML 5 parser. Rather, it is a parser for
+HTML 5 compliant documents. It does not implement the HTML 5 parsing algorithm,
+and should generally be expected to perform correctly only on documents that
+you trust to conform to HTML 5. This is not a suitable library for implementing
+web crawlers or other software that will be exposed to documents from outside
+sources. The result is also not the HTML 5 node structure, but rather something
+closer to the physical structure. For example, omitted start tags are not
+inserted (and so, their corresponding end tags must also be omitted).
+
+WWW: http://hackage.haskell.org/package/xmlhtml