aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ibus-qt
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-03-29 16:12:40 +0800
committerThomas Zander <riggs@FreeBSD.org>2015-03-29 16:12:40 +0800
commitc5eed4b168c9e0f72c122127ffe255c5d9e14693 (patch)
tree214529d17af0561fc9b4144326456304d8009057 /textproc/ibus-qt
parent5bcb262755ac3c42e4a9a673aadc2cf39199e56d (diff)
downloadfreebsd-ports-gnome-c5eed4b168c9e0f72c122127ffe255c5d9e14693.tar.gz
freebsd-ports-gnome-c5eed4b168c9e0f72c122127ffe255c5d9e14693.tar.zst
freebsd-ports-gnome-c5eed4b168c9e0f72c122127ffe255c5d9e14693.zip
Update to upstream version 1.3.3
PR: 198438 Submitted by: henry.hu.sh@gmail.com (maintainer)
Diffstat (limited to 'textproc/ibus-qt')
-rw-r--r--textproc/ibus-qt/Makefile22
-rw-r--r--textproc/ibus-qt/distinfo4
-rw-r--r--textproc/ibus-qt/files/patch-CMakeLists.txt11
-rw-r--r--textproc/ibus-qt/pkg-plist6
4 files changed, 23 insertions, 20 deletions
diff --git a/textproc/ibus-qt/Makefile b/textproc/ibus-qt/Makefile
index 01cb28b540d3..ef55135b7044 100644
--- a/textproc/ibus-qt/Makefile
+++ b/textproc/ibus-qt/Makefile
@@ -2,24 +2,24 @@
# $FreeBSD$
PORTNAME= ibus-qt
-PORTVERSION= 1.3.2
-PORTREVISION= 3
+PORTVERSION= 1.3.3
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/releases/download/${PORTVERSION}/ \
+ http://github.com/${GH_ACCOUNT}/${PORTNAME}/releases/download/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-Source
MAINTAINER= henry.hu.sh@gmail.com
COMMENT= IBus input method module for Qt4
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ibus-1.0.pc:${PORTSDIR}/textproc/ibus \
- ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:${PORTSDIR}/devel/dbus \
- ${LOCALBASE}/bin/icu-config:${PORTSDIR}/devel/icu \
- doxygen:${PORTSDIR}/devel/doxygen
-RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ibus-1.0.pc:${PORTSDIR}/textproc/ibus \
- ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:${PORTSDIR}/devel/dbus \
- ${LOCALBASE}/bin/icu-config:${PORTSDIR}/devel/icu
+BUILD_DEPENDS= ibus>=1.3.7:${PORTSDIR}/textproc/ibus
+RUN_DEPENDS= ibus>=1.3.7:${PORTSDIR}/textproc/ibus
+LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
+ libicuuc.so:${PORTSDIR}/devel/icu
+
+GH_ACCOUNT= ibus
USE_QT4= gui dbus moc_build qmake_build moc_build uic_build rcc_build
USES= cmake pkgconfig
@@ -31,6 +31,4 @@ LDFLAGS+= -L${LOCALBASE}/lib
PROJECTHOST= ibus
WRKSRC= ${WRKDIR}/${DISTNAME}
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/textproc/ibus-qt/distinfo b/textproc/ibus-qt/distinfo
index d57086c616f4..b0fe0e7fdf9b 100644
--- a/textproc/ibus-qt/distinfo
+++ b/textproc/ibus-qt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ibus-qt-1.3.2-Source.tar.gz) = 070c8ef4e6c74eddf7ddf4385936aed730c2dfe2160162e5c56b5158d1061a76
-SIZE (ibus-qt-1.3.2-Source.tar.gz) = 139496
+SHA256 (ibus-qt-1.3.3-Source.tar.gz) = 2f856bb66ad175a68fb4d3b956afe8b893949c3fd10a46d53ec0b10b1f3e2fe1
+SIZE (ibus-qt-1.3.3-Source.tar.gz) = 144004
diff --git a/textproc/ibus-qt/files/patch-CMakeLists.txt b/textproc/ibus-qt/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..1740f75b1e1d
--- /dev/null
+++ b/textproc/ibus-qt/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2015-03-08 17:25:30.122453000 -0400
++++ CMakeLists.txt 2015-03-08 17:25:37.447858000 -0400
+@@ -77,7 +77,7 @@
+ pkg_check_modules(IBUS REQUIRED ibus-1.0>=1.3.7)
+
+ # check doxygen
+-find_package(Doxygen REQUIRED)
++find_package(Doxygen)
+
+ # =====
+ # Define variables
diff --git a/textproc/ibus-qt/pkg-plist b/textproc/ibus-qt/pkg-plist
index d41c2456fb4e..8a307737e2bc 100644
--- a/textproc/ibus-qt/pkg-plist
+++ b/textproc/ibus-qt/pkg-plist
@@ -26,9 +26,3 @@ lib/libibus-qt.so
lib/libibus-qt.so.1
lib/libibus-qt.so.1.3.0
lib/qt4/plugins/inputmethods/libqtim-ibus.so
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrmtry lib/qt4/plugins/inputmethods
-@dirrm include/ibus-qt