aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ispell/Makefile
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>1997-02-08 07:03:11 +0800
committerjmz <jmz@FreeBSD.org>1997-02-08 07:03:11 +0800
commit42efbb1cfe7fb5cab31928d24b8a532c31ad826f (patch)
tree12f384049208c08715ea32e2f9f2a906e21e4216 /textproc/ispell/Makefile
parent3a19230e15c4409ffd06a94f53211a4a638394c2 (diff)
downloadfreebsd-ports-gnome-42efbb1cfe7fb5cab31928d24b8a532c31ad826f.tar.gz
freebsd-ports-gnome-42efbb1cfe7fb5cab31928d24b8a532c31ad826f.tar.zst
freebsd-ports-gnome-42efbb1cfe7fb5cab31928d24b8a532c31ad826f.zip
Enable the building of the french dictionary via a target (make french)
and print an informative message announcing this feature, like for the british dict, so this possibility is not hidden in the makefile.
Diffstat (limited to 'textproc/ispell/Makefile')
-rw-r--r--textproc/ispell/Makefile26
1 files changed, 19 insertions, 7 deletions
diff --git a/textproc/ispell/Makefile b/textproc/ispell/Makefile
index aa89af29d4cd..ca8f633c3c50 100644
--- a/textproc/ispell/Makefile
+++ b/textproc/ispell/Makefile
@@ -3,7 +3,7 @@
# Date created: 6 November 1994
# Whom: jmz
#
-# $Id: Makefile,v 1.15 1996/11/18 14:06:37 asami Exp $
+# $Id: Makefile,v 1.16 1997/02/03 16:22:44 roberto Exp $
#
DISTNAME= ispell-3.1
@@ -14,17 +14,24 @@ DISTFILES= ispell-3.1.20.tar.gz
MAINTAINER= jmz@FreeBSD.org
-# French
-#EXTRA_DICT= francais-IREQ-1.4.tar.gz
-#MASTER_SITES+= ftp://ftp.robot.ireq.ca/pub/ispell/
-
-DISTFILES+= ${EXTRA_DICT}
-
MAKE_FLAGS= TMPDIR=${.CURDIR} -f
MAN1= buildhash.1 findaffix.1 ispell.1 munchlist.1 \
sq.1 tryaffix.1 unsq.1
MAN4= ispell.4 english.4
+pre-fetch:
+pre-install:
+.if !defined(ISPELL_FR)
+ @echo '******************************************************'
+ @echo '* Note that you can build a french/english version *'
+ @echo '* by typing "make french" *'
+ @echo '******************************************************'
+.else
+EXTRA_DICT= francais-IREQ-1.4.tar.gz
+MASTER_SITES+= ftp://ftp.robot.ireq.ca/pub/ispell/
+DISTFILES+= ${EXTRA_DICT}
+.endif
+
pre-extract:
.if !defined(LANG)
@echo '******************************************************'
@@ -33,6 +40,7 @@ pre-extract:
@echo '******************************************************'
.endif
+
pre-configure:
.if defined(EXTRA_DICT)
@echo ${EXTRA_DICT} > ${WRKDIR}/extra_dict
@@ -47,6 +55,10 @@ british:
@echo "Okay, making a british version of ispell...."
@${MAKE} ${.MAKEFLAGS} LANG=british all
+french:
+ @echo "Okay, making a french/english version of ispell...."
+ @${MAKE} ${.MAKEFLAGS} ISPELL_FR=yes
+
pre-install:
@${MKDIR} ${PREFIX}/bin
@${MKDIR} ${PREFIX}/lib