aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/jing
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-02-05 11:09:48 +0800
committerhq <hq@FreeBSD.org>2005-02-05 11:09:48 +0800
commitbfeb0af6acb13be9dc1a465c2568732bdd52935a (patch)
tree70b435a64e8498d26d4bbd462d6d2b75cfa46295 /textproc/jing
parent120fb1e1acdd934f7ee75d50a548923d79265a64 (diff)
downloadfreebsd-ports-gnome-bfeb0af6acb13be9dc1a465c2568732bdd52935a.tar.gz
freebsd-ports-gnome-bfeb0af6acb13be9dc1a465c2568732bdd52935a.tar.zst
freebsd-ports-gnome-bfeb0af6acb13be9dc1a465c2568732bdd52935a.zip
- Update to java.bsd.mk 2.0
- Add 'java' category - CP -> INSTALL_DATA
Diffstat (limited to 'textproc/jing')
-rw-r--r--textproc/jing/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/textproc/jing/Makefile b/textproc/jing/Makefile
index 93e4960a1b22..928f72aa265b 100644
--- a/textproc/jing/Makefile
+++ b/textproc/jing/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jing
PORTVERSION= 2003.06.19
-CATEGORIES= textproc
+CATEGORIES= textproc java
MASTER_SITES= http://www.thaiopensource.com/download/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
@@ -15,11 +15,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A RELAX NG validator in Java
USE_ZIP= yes
-USE_JAVA= 1.4+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
NO_BUILD= yes
-NO_BUILD_DEPENDS_JAVA= yes
-
.if !defined(NOPORTDOCS)
PORTDOCS= *
.endif
@@ -29,9 +28,12 @@ do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.html ${DOCSDIR}
- ${CP} -R ${WRKSRC}/doc ${DOCSDIR}
- ${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/sample/* ${EXAMPLESDIR}
+ cd ${WRKSRC}/doc \
+ && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ cd ${WRKSRC}/sample \
+ && ${FIND} . -type d -exec ${MKDIR} ${EXAMPLESDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/{} \;
.endif
.include <bsd.port.mk>