aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libtre/Makefile
diff options
context:
space:
mode:
authorjkoshy <jkoshy@FreeBSD.org>2007-07-18 21:15:15 +0800
committerjkoshy <jkoshy@FreeBSD.org>2007-07-18 21:15:15 +0800
commit71a9bddf6f866c3b9a71c218006cea7359e63316 (patch)
tree16ec1bed62220200dca6542567db941d54567fdb /textproc/libtre/Makefile
parentac8503035a2fc6917e933fa8c8b4de908e668f5e (diff)
downloadfreebsd-ports-gnome-71a9bddf6f866c3b9a71c218006cea7359e63316.tar.gz
freebsd-ports-gnome-71a9bddf6f866c3b9a71c218006cea7359e63316.tar.zst
freebsd-ports-gnome-71a9bddf6f866c3b9a71c218006cea7359e63316.zip
Upgrade to v0.7.5.
Upstream changes include: - A new swedish translation. - A '-q' option for agrep(1). - Various bug fixes. The port now uses OPTIONS for configuration. It currently supports two configuration knobs: "NLS" turns on native language support. "OPTIMIZED_CFLAGS" compiles the port with aggressive optimization. PR: ports/113441 Submitted by: bf <bf2006a at yahoo dot com>
Diffstat (limited to 'textproc/libtre/Makefile')
-rw-r--r--textproc/libtre/Makefile38
1 files changed, 16 insertions, 22 deletions
diff --git a/textproc/libtre/Makefile b/textproc/libtre/Makefile
index 13292aab9d50..b5983e3de793 100644
--- a/textproc/libtre/Makefile
+++ b/textproc/libtre/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= libtre
-PORTVERSION= 0.7.4
-PORTREVISION= 1
+PORTVERSION= 0.7.5
CATEGORIES= textproc
MASTER_SITES= http://laurikari.net/tre/ \
${MASTER_SITE_LOCAL}
@@ -22,22 +21,28 @@ CONFLICTS= glimpse-4* # agrep(1)
USE_BZIP2= yes
USE_GNOME= gnomehack gnometarget pkgconfig
-USE_GETOPT_LONG= yes
USE_AUTOTOOLS= libtool:15
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS+= --enable-static --mandir=${PREFIX}/man
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= agrep.1
+MANCOMPRESSED= no
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+OPTIONS= NLS "native language support" off \
+ OPTIMIZED_CFLAGS "append optimization flags to CFLAGS" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
.if defined(WITH_OPTIMIZED_CFLAGS)
@@ -46,17 +51,6 @@ CFLAGS+= -Wuninitialized -ffast-math -finline-functions \
-fforce-mem -fforce-addr -O3
.endif
-pre-everything::
-.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} '===>'
- @${ECHO_MSG} '===> You can enable extra optimizations by defining WITH_OPTIMIZED_CFLAGS'
- @${ECHO_MSG} "===> For example, 'make WITH_OPTIMIZED_CFLAGS=yes'"
-.endif
- @${ECHO_MSG} '===>'
-
-post-patch:
- @${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g' ${WRKSRC}/configure
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@@ -65,4 +59,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>