aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/modlogan/Makefile
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2001-09-23 07:26:36 +0800
committertobez <tobez@FreeBSD.org>2001-09-23 07:26:36 +0800
commit20b2c5a5766a74ad73a15f2667d89e5ec46b49ef (patch)
tree007ffb7a7a64feb8c285f9db5a766362593aa0f4 /textproc/modlogan/Makefile
parent7535d206186f79f5e867a86def7800eb533ac51c (diff)
downloadfreebsd-ports-gnome-20b2c5a5766a74ad73a15f2667d89e5ec46b49ef.tar.gz
freebsd-ports-gnome-20b2c5a5766a74ad73a15f2667d89e5ec46b49ef.tar.zst
freebsd-ports-gnome-20b2c5a5766a74ad73a15f2667d89e5ec46b49ef.zip
Add modlogan, a modular log file analysis program.
Submitted by: Alexander Leidinger <Alexander@Leidinger.net>
Diffstat (limited to 'textproc/modlogan/Makefile')
-rw-r--r--textproc/modlogan/Makefile74
1 files changed, 74 insertions, 0 deletions
diff --git a/textproc/modlogan/Makefile b/textproc/modlogan/Makefile
new file mode 100644
index 000000000000..32ff2b973ed9
--- /dev/null
+++ b/textproc/modlogan/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for: modlogan
+# Date created: 06.Sep.2000
+# Whom: Alexander@Leidinger.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= modlogan
+PORTVERSION= 0.7.2
+CATEGORIES= textproc www
+MASTER_SITES= http://www.kneschke.de/projekte/modlogan/download/ \
+ ${MASTER_SITE_SOURCEFORGE}
+
+MAINTAINER= Alexander@Leidinger.net
+
+LIB_DEPENDS= adns.1:${PORTSDIR}/net/adns \
+ gd.2:${PORTSDIR}/graphics/gd \
+ intl.1:${PORTSDIR}/devel/gettext \
+ pcre.0:${PORTSDIR}/devel/pcre \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ ltdl.1:${PORTSDIR}/devel/libtool
+
+.if defined(WITH_MYSQL)
+# To quote the author:
+# It is used by src/processor/telecom/... for a commercial project. The
+# project itself is opensource but not documented.
+# Therefore no testing if it works is made in the FreeBSD port.
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+.endif
+
+# Please don't remove the comments, as soon as autoconf/libtool get's
+# updated in the ports collection the comments may be removed.
+# They serve as a reminder.
+#USE_AUTOCONF= yes
+#USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+#LIBTOOLFLAGS= --disable-ltlibs --release-suffix
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--enable-ltdl-install=no --with-gd=${LOCALBASE}/include
+.if defined(WITH_MYSQL)
+CONFIGURE_ARGS+=--with-mysql
+.endif
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
+
+MAN1= modlogan.1
+DOC1= faq.txt glosar manual.txt plugin-options.txt \
+ using-plugins.txt writing-plugins.txt
+
+post-patch:
+ @${PERL} -pi -e 's:\@sysconfdir\@:${PREFIX}/etc/modlogan:g' ${WRKSRC}/doc/modlogan.conf-dist
+
+post-configure:
+ ${TOUCH} ${WRKSRC}/libltdl/config.status
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/modlogan
+.for i in ${DOC1}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${i} ${PREFIX}/share/doc/modlogan/${i}
+.endfor
+.endif
+ ${MKDIR} ${PREFIX}/share/examples/modlogan
+.for i in footer.ihtml header.ihtml convert_to_055.pl convert_to_060.pl
+ @${INSTALL_DATA} ${WRKSRC}/doc/${i} ${PREFIX}/share/examples/modlogan/${i}
+.endfor
+ @# remove .la (can't use USE_LIBTOOL)
+ -${RM} ${PREFIX}/lib/libmla_*.la
+ ${MV} ${PREFIX}/bin/${MACHINE_ARCH}--freebsd${OSREL}-modlogan ${PREFIX}/bin/modlogan
+ ${MV} ${PREFIX}/man/man1/${MACHINE_ARCH}--freebsd${OSREL}-modlogan.1 ${PREFIX}/man/man1/modlogan.1
+.for i in css conf def.conf
+ [ -f ${PREFIX}/etc/modlogan/modlogan.${i} ] || ${INSTALL_DATA} ${PREFIX}/etc/modlogan/modlogan.${i}-dist ${PREFIX}/etc/modlogan/modlogan.${i}
+.endfor
+
+.include <bsd.port.mk>