aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/msort
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-01-22 10:45:35 +0800
committerclsung <clsung@FreeBSD.org>2007-01-22 10:45:35 +0800
commite46350b009c181f31c015d72c64ad4e497bd2743 (patch)
treef7ce0b14d551a29cdffdd377e6247798d33d608e /textproc/msort
parent784317daa629d6f3babe775560b130425cfa9478 (diff)
downloadfreebsd-ports-gnome-e46350b009c181f31c015d72c64ad4e497bd2743.tar.gz
freebsd-ports-gnome-e46350b009c181f31c015d72c64ad4e497bd2743.tar.zst
freebsd-ports-gnome-e46350b009c181f31c015d72c64ad4e497bd2743.zip
- Fix broken caused by devel/libuninum upgrade.
- bump PORTREVISION
Diffstat (limited to 'textproc/msort')
-rw-r--r--textproc/msort/Makefile1
-rw-r--r--textproc/msort/files/patch-info.c10
-rw-r--r--textproc/msort/files/patch-msort.c18
-rw-r--r--textproc/msort/files/patch-unicode.h7
4 files changed, 36 insertions, 0 deletions
diff --git a/textproc/msort/Makefile b/textproc/msort/Makefile
index c5187d58de8b..5b2fba9af4f1 100644
--- a/textproc/msort/Makefile
+++ b/textproc/msort/Makefile
@@ -7,6 +7,7 @@
PORTNAME= msort
PORTVERSION= 8.35
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://billposer.org/Software/Downloads/
EXTRACT_SUFX= .tgz
diff --git a/textproc/msort/files/patch-info.c b/textproc/msort/files/patch-info.c
new file mode 100644
index 000000000000..43178afe7b2c
--- /dev/null
+++ b/textproc/msort/files/patch-info.c
@@ -0,0 +1,10 @@
+--- info.c.orig Tue Jan 9 10:35:41 2007
++++ info.c Mon Jan 22 09:39:59 2007
+@@ -21,6 +21,7 @@
+
+ #include <stdlib.h>
+ #include <stdio.h>
++#include "unicode.h"
+ #include <uninum/uninum.h>
+ #ifdef LOCALE_GETTEXT
+ #include <libintl.h>
diff --git a/textproc/msort/files/patch-msort.c b/textproc/msort/files/patch-msort.c
new file mode 100644
index 000000000000..60f369e9168a
--- /dev/null
+++ b/textproc/msort/files/patch-msort.c
@@ -0,0 +1,18 @@
+--- msort.c.orig Fri Jan 12 08:21:54 2007
++++ msort.c Mon Jan 22 10:32:56 2007
+@@ -49,6 +49,7 @@
+ #include <time.h>
+ #include <errno.h>
+ #include <uninum/nsdefs.h>
++#include "unicode.h"
+ #include <uninum/uninum.h>
+ #include <tre/regex.h>
+
+@@ -58,7 +59,6 @@
+ typedef unsigned long ULongLong;
+ #endif
+
+-#include "unicode.h"
+ #include "exitcode.h"
+ #include "retcodes.h"
+ #include "input.h"
diff --git a/textproc/msort/files/patch-unicode.h b/textproc/msort/files/patch-unicode.h
new file mode 100644
index 000000000000..7593d781a241
--- /dev/null
+++ b/textproc/msort/files/patch-unicode.h
@@ -0,0 +1,7 @@
+--- unicode.h.orig Mon Jan 8 03:33:05 2007
++++ unicode.h Mon Jan 22 09:29:08 2007
+@@ -1,3 +1,4 @@
++typedef unsigned short UTF16;
+ typedef unsigned long UTF32; /* at least 32 bits */
+ typedef unsigned char UTF8; /* 8 bits */
+ typedef unsigned char Boolean; /* 0 or 1 */