aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-MARC-XML
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2009-08-06 19:11:09 +0800
committerdemon <demon@FreeBSD.org>2009-08-06 19:11:09 +0800
commit49407efb5c48430cb0d8f4d695f5cfeec56a5cbb (patch)
tree9573047760aa642ae432638ae5597588c1263229 /textproc/p5-MARC-XML
parente8897630b895d7b7f47014e532d59e0df1f464f7 (diff)
downloadfreebsd-ports-gnome-49407efb5c48430cb0d8f4d695f5cfeec56a5cbb.tar.gz
freebsd-ports-gnome-49407efb5c48430cb0d8f4d695f5cfeec56a5cbb.tar.zst
freebsd-ports-gnome-49407efb5c48430cb0d8f4d695f5cfeec56a5cbb.zip
New port: MARC::XML.
MARC-XML is an extension to the MARC-Record distribution for working with XML data encoded using the MARC21slim XML schema from the Library of Congress. For more details see: http://www.loc.gov/standards/marcxml/
Diffstat (limited to 'textproc/p5-MARC-XML')
-rw-r--r--textproc/p5-MARC-XML/Makefile27
-rw-r--r--textproc/p5-MARC-XML/distinfo3
-rw-r--r--textproc/p5-MARC-XML/pkg-descr6
-rw-r--r--textproc/p5-MARC-XML/pkg-plist6
4 files changed, 42 insertions, 0 deletions
diff --git a/textproc/p5-MARC-XML/Makefile b/textproc/p5-MARC-XML/Makefile
new file mode 100644
index 000000000000..792ceecc36e7
--- /dev/null
+++ b/textproc/p5-MARC-XML/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-MARC-XML
+# Date created: 6 August 2009
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MARC-XML
+PORTVERSION= 0.92
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= An extension to the MARC-Record distribution for working with XML data
+
+BUILD_DEPENDS= ${SITE_PERL}/MARC/Record.pm:${PORTSDIR}/textproc/p5-MARC-Record \
+ ${SITE_PERL}/MARC/Charset.pm:${PORTSDIR}/textproc/p5-MARC-Charset \
+ ${SITE_PERL}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN1= marc2xml.1 xml2marc.1
+MAN3= MARC::File::SAX.3 MARC::File::XML.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-MARC-XML/distinfo b/textproc/p5-MARC-XML/distinfo
new file mode 100644
index 000000000000..1fb64127a9a8
--- /dev/null
+++ b/textproc/p5-MARC-XML/distinfo
@@ -0,0 +1,3 @@
+MD5 (MARC-XML-0.92.tar.gz) = cc5cb78d22c79deb54242ea13693880a
+SHA256 (MARC-XML-0.92.tar.gz) = 00a9a9e2f0752e035a54fd2df539884cd59fc81c97d5d6ceb9ac65671c2df208
+SIZE (MARC-XML-0.92.tar.gz) = 14086
diff --git a/textproc/p5-MARC-XML/pkg-descr b/textproc/p5-MARC-XML/pkg-descr
new file mode 100644
index 000000000000..3e1bb9b42a3f
--- /dev/null
+++ b/textproc/p5-MARC-XML/pkg-descr
@@ -0,0 +1,6 @@
+MARC-XML is an extension to the MARC-Record distribution for working with
+XML data encoded using the MARC21slim XML schema from the Library of Congress.
+
+For more details see: http://www.loc.gov/standards/marcxml/
+
+WWW: http://search.cpan.org/dist/MARC-Lint/
diff --git a/textproc/p5-MARC-XML/pkg-plist b/textproc/p5-MARC-XML/pkg-plist
new file mode 100644
index 000000000000..985f62e2f591
--- /dev/null
+++ b/textproc/p5-MARC-XML/pkg-plist
@@ -0,0 +1,6 @@
+bin/marc2xml
+bin/xml2marc
+%%SITE_PERL%%/MARC/File/SAX.pm
+%%SITE_PERL%%/MARC/File/XML.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MARC-XML/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MARC-XML