aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Parse-FixedLength/Makefile
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-10-27 22:21:15 +0800
committertobez <tobez@FreeBSD.org>2005-10-27 22:21:15 +0800
commitb7b40bd4455c2254e7245d8ae98951d6b6f70825 (patch)
tree5ab3268e90c2b0820553705c3699cda982e6958c /textproc/p5-Parse-FixedLength/Makefile
parente36bebdc73fceb21106992e284947ee4a078625b (diff)
downloadfreebsd-ports-gnome-b7b40bd4455c2254e7245d8ae98951d6b6f70825.tar.gz
freebsd-ports-gnome-b7b40bd4455c2254e7245d8ae98951d6b6f70825.tar.zst
freebsd-ports-gnome-b7b40bd4455c2254e7245d8ae98951d6b6f70825.zip
Add textproc/p5-Parse-FixedLength 5.35, a Perl module to parse a string
containing fixed length fields into component parts.
Diffstat (limited to 'textproc/p5-Parse-FixedLength/Makefile')
-rw-r--r--textproc/p5-Parse-FixedLength/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/p5-Parse-FixedLength/Makefile b/textproc/p5-Parse-FixedLength/Makefile
new file mode 100644
index 000000000000..68adb5e3a915
--- /dev/null
+++ b/textproc/p5-Parse-FixedLength/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: textproc/p5-Parse-FixedLength
+# Date created: 27 October 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parse-FixedLength
+PORTVERSION= 5.35
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Parse
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Parse a string containing fixed length fields into component parts
+
+PERL_CONFIGURE= yes
+
+MAN3= Parse::FixedLength.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>