aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Petal
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-26 07:16:05 +0800
committeraaron <aaron@FreeBSD.org>2006-05-26 07:16:05 +0800
commitc09a6e9f254b2573fb09cedc8b656d9e0d9f9fe8 (patch)
tree007cafd54fd83ecd18d6aa8f40f7fef8afaa279a /textproc/p5-Petal
parent170f76979947675b0ba55e456a1c87c00832d5ab (diff)
downloadfreebsd-ports-gnome-c09a6e9f254b2573fb09cedc8b656d9e0d9f9fe8.tar.gz
freebsd-ports-gnome-c09a6e9f254b2573fb09cedc8b656d9e0d9f9fe8.tar.zst
freebsd-ports-gnome-c09a6e9f254b2573fb09cedc8b656d9e0d9f9fe8.zip
Adding port textproc/p5-Petal, Perl Template Attribute Language - TAL for Perl!
Approved by: tobez (implicit)
Diffstat (limited to 'textproc/p5-Petal')
-rw-r--r--textproc/p5-Petal/Makefile37
-rw-r--r--textproc/p5-Petal/distinfo3
-rw-r--r--textproc/p5-Petal/pkg-descr14
-rw-r--r--textproc/p5-Petal/pkg-plist27
4 files changed, 81 insertions, 0 deletions
diff --git a/textproc/p5-Petal/Makefile b/textproc/p5-Petal/Makefile
new file mode 100644
index 000000000000..198948530515
--- /dev/null
+++ b/textproc/p5-Petal/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Petal
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Petal
+PORTVERSION= 2.18
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/B/BP/BPOSTLE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl Template Attribute Language - TAL for Perl!
+
+BUILD_DEPENDS= ${SITE_PERL}/MKDoc/XML.pm:${PORTSDIR}/textproc/p5-MKDoc-XML \
+ ${SITE_PERL}/Test/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Petal.3 \
+ Petal::Cookbook.3 \
+ Petal::Deprecated.3 \
+ Petal::Hash::Test.3 \
+ Petal::I18N.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Petal/distinfo b/textproc/p5-Petal/distinfo
new file mode 100644
index 000000000000..226a6cd31fbb
--- /dev/null
+++ b/textproc/p5-Petal/distinfo
@@ -0,0 +1,3 @@
+MD5 (Petal-2.18.tar.gz) = 40fc181e53122705570102695ae9240c
+SHA256 (Petal-2.18.tar.gz) = 7bce62ab8c23b754d535cac370d20edf0f8553d6e4785acb45e4b06d33c99597
+SIZE (Petal-2.18.tar.gz) = 81671
diff --git a/textproc/p5-Petal/pkg-descr b/textproc/p5-Petal/pkg-descr
new file mode 100644
index 000000000000..722ebd3ea9a6
--- /dev/null
+++ b/textproc/p5-Petal/pkg-descr
@@ -0,0 +1,14 @@
+Petal is a XML based templating engine that is able to process any kind of
+XML, XHTML and HTML.
+
+Petal borrows a lot of good ideas from the Zope Page Templates TAL
+specification, it is very well suited for the creation of WYSIWYG XHTML
+editable templates.
+
+The idea is to further enforce the separation of logic from presentation.
+With Petal, graphic designers can use their favorite WYSIWYG editor to
+easily edit templates without having to worry about the loops and ifs
+which happen behind the scene.
+
+WWW: http://search.cpan.org/dist/Petal
+Author: Fergal Daly <fergal@esatclear.ie>
diff --git a/textproc/p5-Petal/pkg-plist b/textproc/p5-Petal/pkg-plist
new file mode 100644
index 000000000000..253c02142c19
--- /dev/null
+++ b/textproc/p5-Petal/pkg-plist
@@ -0,0 +1,27 @@
+%%SITE_PERL%%/Petal.pm
+%%SITE_PERL%%/Petal/Cache/Disk.pm
+%%SITE_PERL%%/Petal/Cache/Memory.pm
+%%SITE_PERL%%/Petal/Canonicalizer/XHTML.pm
+%%SITE_PERL%%/Petal/Canonicalizer/XML.pm
+%%SITE_PERL%%/Petal/CodeGenerator.pm
+%%SITE_PERL%%/Petal/Cookbook.pod
+%%SITE_PERL%%/Petal/Deprecated.pm
+%%SITE_PERL%%/Petal/Entities.pm
+%%SITE_PERL%%/Petal/Functions.pm
+%%SITE_PERL%%/Petal/Hash.pm
+%%SITE_PERL%%/Petal/Hash/String.pm
+%%SITE_PERL%%/Petal/Hash/Test.pm
+%%SITE_PERL%%/Petal/Hash/Var.pm
+%%SITE_PERL%%/Petal/I18N.pm
+%%SITE_PERL%%/Petal/Parser.pm
+%%SITE_PERL%%/Petal/TranslationService/Gettext.pm
+%%SITE_PERL%%/Petal/TranslationService/MOFile.pm
+%%SITE_PERL%%/Petal/TranslationService/Noop.pm
+%%SITE_PERL%%/Petal/TranslationService/h4x0r.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Petal/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Petal
+@dirrm %%SITE_PERL%%/Petal/TranslationService
+@dirrm %%SITE_PERL%%/Petal/Hash
+@dirrm %%SITE_PERL%%/Petal/Canonicalizer
+@dirrm %%SITE_PERL%%/Petal/Cache
+@dirrmtry %%SITE_PERL%%/Petal