aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Pod-Stripper
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-08-05 09:10:27 +0800
committerleeym <leeym@FreeBSD.org>2004-08-05 09:10:27 +0800
commitc496e0901848f2ab002ebfa8e8b333dc100747fc (patch)
treed4b47cbe93f01e6c2e96e8e3752cebfc251776c4 /textproc/p5-Pod-Stripper
parent1eddd1c08614f8fd1c79241c6bf6546cfbb6b51f (diff)
downloadfreebsd-ports-gnome-c496e0901848f2ab002ebfa8e8b333dc100747fc.tar.gz
freebsd-ports-gnome-c496e0901848f2ab002ebfa8e8b333dc100747fc.tar.zst
freebsd-ports-gnome-c496e0901848f2ab002ebfa8e8b333dc100747fc.zip
- p5-podlators and p5-PodParser conflict with perl 5.6 or above.
They should be conditional dependency when PERL_LEVEL < 500601. - add "CONFLICTS= perl-5.6.* perl-5.8.*" in p5-podlators and p5-PodParser PR: 68086 Submitted by: leeym Approved by: maintainer timeout
Diffstat (limited to 'textproc/p5-Pod-Stripper')
-rw-r--r--textproc/p5-Pod-Stripper/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/textproc/p5-Pod-Stripper/Makefile b/textproc/p5-Pod-Stripper/Makefile
index 39e2e9844094..d684b7c8e74a 100644
--- a/textproc/p5-Pod-Stripper/Makefile
+++ b/textproc/p5-Pod-Stripper/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Pod-Stripper
PORTVERSION= 0.22
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pod
@@ -15,17 +16,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Strip all pod, and output what's left
-BUILD_DEPENDS= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
-CONFIGURE_ARGS+= INSTALLDIRS="site"
+CONFIGURE_ARGS= INSTALLDIRS="site"
MAN1= podstrip.1
MAN3= Pod::Stripper.3
-MAN1PREFIX= ${PREFIX}
post-patch:
@${FIND} ${WRKSRC} -type f|${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//;'
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS+= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+.endif
+
+.include <bsd.port.post.mk>