aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Template-Magic
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2004-08-12 00:05:50 +0800
committervanilla <vanilla@FreeBSD.org>2004-08-12 00:05:50 +0800
commit7000bc70a8024c87f56a155492782f6f6a08adba (patch)
treef557b65003755b0b1f4d3ae4ed56ebda300d5e40 /textproc/p5-Template-Magic
parent968a2572a44bc46d259df1ba4841b54b83ab57b5 (diff)
downloadfreebsd-ports-gnome-7000bc70a8024c87f56a155492782f6f6a08adba.tar.gz
freebsd-ports-gnome-7000bc70a8024c87f56a155492782f6f6a08adba.tar.zst
freebsd-ports-gnome-7000bc70a8024c87f56a155492782f6f6a08adba.zip
Add p5-Template-Magic 1.25, a Perl Module with magic merger of runtime
values with templates. PR: ports/69451 Submitted by: Cheng-Lung Sung <clsung@dragon2.net>
Diffstat (limited to 'textproc/p5-Template-Magic')
-rw-r--r--textproc/p5-Template-Magic/Makefile35
-rw-r--r--textproc/p5-Template-Magic/distinfo2
-rw-r--r--textproc/p5-Template-Magic/pkg-descr8
-rw-r--r--textproc/p5-Template-Magic/pkg-plist18
4 files changed, 63 insertions, 0 deletions
diff --git a/textproc/p5-Template-Magic/Makefile b/textproc/p5-Template-Magic/Makefile
new file mode 100644
index 000000000000..4d2b7564fb2a
--- /dev/null
+++ b/textproc/p5-Template-Magic/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Template-Magic
+# Date created: July 23 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Magic
+PORTVERSION= 1.25
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= A Perl Module with magic merger of runtime values with templates
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/Util.pm:${PORTSDIR}/devel/p5-IO-Util \
+ ${SITE_PERL}/Class/constr.pm:${PORTSDIR}/devel/p5-OOTools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Template::Magic.3 \
+ Bundle::Template::Magic.3 \
+ Template::Magic::HTML.3 \
+ Template::Magic::Zone.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.1 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Template-Magic/distinfo b/textproc/p5-Template-Magic/distinfo
new file mode 100644
index 000000000000..6036360c9bcc
--- /dev/null
+++ b/textproc/p5-Template-Magic/distinfo
@@ -0,0 +1,2 @@
+MD5 (Template-Magic-1.25.tar.gz) = 5a44e758bdfa32f7a530d16d00720480
+SIZE (Template-Magic-1.25.tar.gz) = 40091
diff --git a/textproc/p5-Template-Magic/pkg-descr b/textproc/p5-Template-Magic/pkg-descr
new file mode 100644
index 000000000000..f6b6793b9ee7
--- /dev/null
+++ b/textproc/p5-Template-Magic/pkg-descr
@@ -0,0 +1,8 @@
+Template-Magic is a "magic" interface between programming and design. It makes
+"magically" available all the runtime values - stored in your variables or
+returned by your subroutines - inside a static template file. Usually no need
+to assign values to the object.
+
+WWW: http://search.cpan.org/~domizio/Template-Magic/
+
+Author: Domizio Demichelis <dd@4pro.net>
diff --git a/textproc/p5-Template-Magic/pkg-plist b/textproc/p5-Template-Magic/pkg-plist
new file mode 100644
index 000000000000..757ae8f025ab
--- /dev/null
+++ b/textproc/p5-Template-Magic/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/Bundle/Template/Magic.pm
+%%SITE_PERL%%/Template/Magic.pm
+%%SITE_PERL%%/Template/Magic/HTML.pm
+%%SITE_PERL%%/Template/Magic/Zone.pm
+%%SITE_PERL%%/auto/Template/Magic/_EVAL_.al
+%%SITE_PERL%%/auto/Template/Magic/_EVAL_ATTRIBUTES_.al
+%%SITE_PERL%%/auto/Template/Magic/TRACE_DELETIONS.al
+%%SITE_PERL%%/auto/Template/Magic/INCLUDE_TEXT.al
+%%SITE_PERL%%/auto/Template/Magic/TableTiler.al
+%%SITE_PERL%%/auto/Template/Magic/FillInForm.al
+%%SITE_PERL%%/auto/Template/Magic/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Magic/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Magic
+@dirrm %%SITE_PERL%%/Template/Magic
+@unexec rmdir %D/%%SITE_PERL%%/Template 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Bundle/Template 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Bundle 2>/dev/null || true