aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-XML-SAX
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2001-11-21 04:07:54 +0800
committertobez <tobez@FreeBSD.org>2001-11-21 04:07:54 +0800
commitec6537120e490dcb5da16613098ff17856c34df7 (patch)
treea9ffa2cafac98c359fa4108ef71c46d42c5fbaec /textproc/p5-XML-SAX
parentd570e068645b9f5f969b150b427dc96c7fc6f352 (diff)
downloadfreebsd-ports-gnome-ec6537120e490dcb5da16613098ff17856c34df7.tar.gz
freebsd-ports-gnome-ec6537120e490dcb5da16613098ff17856c34df7.tar.zst
freebsd-ports-gnome-ec6537120e490dcb5da16613098ff17856c34df7.zip
Add p5-XML-SAX 0.02, simple API for XML.
PR: 32104 Submitted by: Sergey Skvortsov <skv@protey.ru>
Diffstat (limited to 'textproc/p5-XML-SAX')
-rw-r--r--textproc/p5-XML-SAX/Makefile27
-rw-r--r--textproc/p5-XML-SAX/distinfo1
-rw-r--r--textproc/p5-XML-SAX/pkg-comment1
-rw-r--r--textproc/p5-XML-SAX/pkg-descr8
-rw-r--r--textproc/p5-XML-SAX/pkg-plist24
5 files changed, 61 insertions, 0 deletions
diff --git a/textproc/p5-XML-SAX/Makefile b/textproc/p5-XML-SAX/Makefile
new file mode 100644
index 000000000000..99869548a518
--- /dev/null
+++ b/textproc/p5-XML-SAX/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: XML::SAX
+# Date created: 19 Nov 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-SAX
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::SAX.3 XML::SAX::Base.3 XML::SAX::ParserFactory.3 \
+ XML::SAX::PurePerl.3 XML::SAX::PurePerl::Reader.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-SAX/distinfo b/textproc/p5-XML-SAX/distinfo
new file mode 100644
index 000000000000..c7bdd21591bc
--- /dev/null
+++ b/textproc/p5-XML-SAX/distinfo
@@ -0,0 +1 @@
+MD5 (XML-SAX-0.02.tar.gz) = 153106a8014d45b91c72a59de196c0b3
diff --git a/textproc/p5-XML-SAX/pkg-comment b/textproc/p5-XML-SAX/pkg-comment
new file mode 100644
index 000000000000..a54a304accf2
--- /dev/null
+++ b/textproc/p5-XML-SAX/pkg-comment
@@ -0,0 +1 @@
+Simple API for XML
diff --git a/textproc/p5-XML-SAX/pkg-descr b/textproc/p5-XML-SAX/pkg-descr
new file mode 100644
index 000000000000..3966f8dcb45e
--- /dev/null
+++ b/textproc/p5-XML-SAX/pkg-descr
@@ -0,0 +1,8 @@
+XML::SAX consists of several framework classes for using and building
+Perl SAX2 XML parsers, filters, and drivers. It is designed around the
+need to be able to "plug in" different SAX parsers to an application
+without requiring programmer intervention. Those of you familiar with
+the DBI will be right at home. Some of the designs come from the Java
+JAXP specification (SAX part), only without the javaness.
+
+WWW: http://search.cpan.org/search?dist=XML-SAX
diff --git a/textproc/p5-XML-SAX/pkg-plist b/textproc/p5-XML-SAX/pkg-plist
new file mode 100644
index 000000000000..287e357e0da5
--- /dev/null
+++ b/textproc/p5-XML-SAX/pkg-plist
@@ -0,0 +1,24 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/SAX/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/Base.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/Exception.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/ParserDetails.ini
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/ParserFactory.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl/DTDDecls.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl/DebugHandler.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl/DocType.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl/EncodingDetect.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl/Exception.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl/Productions.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl/Reader.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl/Reader/Stream.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl/Reader/String.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl/Reader/URI.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl/XMLDecl.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl/Reader
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML/SAX/PurePerl 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML/SAX 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/SAX 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true