aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-podlators/Makefile
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2003-02-11 21:12:26 +0800
committerskv <skv@FreeBSD.org>2003-02-11 21:12:26 +0800
commit8a2a10153507f08f697d4c2c2fb813f25ce5ec4a (patch)
treecc63f6573a530eced18ffec62804d07c363895ab /textproc/p5-podlators/Makefile
parente143dddc5de25abdf3f76af5cb8874a6973471ab (diff)
downloadfreebsd-ports-gnome-8a2a10153507f08f697d4c2c2fb813f25ce5ec4a.tar.gz
freebsd-ports-gnome-8a2a10153507f08f697d4c2c2fb813f25ce5ec4a.tar.zst
freebsd-ports-gnome-8a2a10153507f08f697d4c2c2fb813f25ce5ec4a.zip
Update to 1.25, fix p5-File-Spec dependency.
PR: ports/44728
Diffstat (limited to 'textproc/p5-podlators/Makefile')
-rw-r--r--textproc/p5-podlators/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/textproc/p5-podlators/Makefile b/textproc/p5-podlators/Makefile
index 0721c67c8126..e5f0a26c530a 100644
--- a/textproc/p5-podlators/Makefile
+++ b/textproc/p5-podlators/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= podlators
-PORTVERSION= 1.21
+PORTVERSION= 1.25
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pod
@@ -14,15 +14,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= INSTALLDIRS=site
MAN1= pod2man.1 pod2text.1
MAN3= Pod::Man.3 Pod::ParseLink.3 Pod::Text.3 Pod::Text::Color.3 \
Pod::Text::Overstrike.3 Pod::Text::Termcap.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif
+
+.include <bsd.port.post.mk>