aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/pcrs/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-08-15 19:27:16 +0800
committerdanfe <danfe@FreeBSD.org>2013-08-15 19:27:16 +0800
commitbb34a080ac4284074756f50ca4acd3babc48815f (patch)
treea6e034c62e7f1e612e45628a0a466100b5f1187a /textproc/pcrs/Makefile
parentae4ef166ab393c71037f05007d60a9922ddc8884 (diff)
downloadfreebsd-ports-gnome-bb34a080ac4284074756f50ca4acd3babc48815f.tar.gz
freebsd-ports-gnome-bb34a080ac4284074756f50ca4acd3babc48815f.tar.zst
freebsd-ports-gnome-bb34a080ac4284074756f50ca4acd3babc48815f.zip
- Try to unbreak parallel builds (-jX) by adding missing dependencies
for static library target - Unbreak configure script against Clang's cpp(1): suppress harmless warning that was treated as an error (=> missing pcre.h) - While here, trim Makefile header, remove defunct mirrors from the MASTER_SITES, convert LIB_DEPENDS and USE_GMAKE, kill spaces at EOL of port description, define LICENSE (LGPL21) Reported by: marino Approved by: miwi, bapt (portmgr, implicit)
Diffstat (limited to 'textproc/pcrs/Makefile')
-rw-r--r--textproc/pcrs/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/textproc/pcrs/Makefile b/textproc/pcrs/Makefile
index c350571ca720..ad07005d3647 100644
--- a/textproc/pcrs/Makefile
+++ b/textproc/pcrs/Makefile
@@ -1,31 +1,26 @@
-# New ports collection makefile for: pcrs
-# Date created: 31 July 2005
-# Whom: Ken Wong <wongk@apt.homeunix.net>
-#
+# Created by: Ken Wong <wongk@apt.homeunix.net>
# $FreeBSD$
-#
PORTNAME= pcrs
PORTVERSION= 0.0.3
PORTREVISION= 2
CATEGORIES= textproc
-MASTER_SITES= http://distfiles.master.finkmirrors.net/\
- http://download.mirror.ac.uk/mirror/master.us.finkmirrors.net/distfiles/\
- http://mirror.phy.olemiss.edu/mirror/fink/distfiles/
+MASTER_SITES= http://distfiles.master.finkmirrors.net/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= wongk@apt.homeunix.net
-COMMENT= Perl compatible regular expression based substitutions
+COMMENT= Perl-compatible regular expression based substitutions
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
+LICENSE= LGPL21
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+USES= gmake
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-
USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
MAN3= pcrs.3
PLIST_FILES= bin/pcrsed \
lib/libpcrs.a \