aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/pdftohtml
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-08-08 21:57:07 +0800
committererwin <erwin@FreeBSD.org>2003-08-08 21:57:07 +0800
commitd788d1c8ae446d6335411a2ce7758e83ea3020f2 (patch)
tree211f02bf05a5a363eaba1e04fe539c8db088e4df /textproc/pdftohtml
parentce7989afe448ad35cb3d8a22740395bf8c72872a (diff)
downloadfreebsd-ports-gnome-d788d1c8ae446d6335411a2ce7758e83ea3020f2.tar.gz
freebsd-ports-gnome-d788d1c8ae446d6335411a2ce7758e83ea3020f2.tar.zst
freebsd-ports-gnome-d788d1c8ae446d6335411a2ce7758e83ea3020f2.zip
This patch allows the admin of the machine to choose either
print/ghostscript-gnu or print/ghostscript-afp1 PR: 54952 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'textproc/pdftohtml')
-rw-r--r--textproc/pdftohtml/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/textproc/pdftohtml/Makefile b/textproc/pdftohtml/Makefile
index d2b10cd7c469..93737c700a17 100644
--- a/textproc/pdftohtml/Makefile
+++ b/textproc/pdftohtml/Makefile
@@ -15,11 +15,25 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= erwin@FreeBSD.org
COMMENT= A command-line tool for converting pdf-files into html
-RUN_DEPENDS= ${LOCALBASE}/bin/gs:${PORTSDIR}/print/ghostscript-gnu
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
+RUN_DEPENDS= ${LOCALBASE}/bin/gs:${PORTSDIR}/${GSPORT}
WRKSRC= ${WRKDIR}/${DISTNAME}
USE_REINPLACE= yes
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
pre-patch:
.for file in goo/Makefile xpdf/Makefile
${REINPLACE_CMD} -e "s|-O2||; s|-g||" ${WRKSRC}/${file}