aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/php55-wddx
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
committerale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
commit48d5fb51023dbbe8f2a70121c289e1849e7e14eb (patch)
treefd816d2c8b34ef7db2d6bcabe7358eaa7fb2d04f /textproc/php55-wddx
parent19160cd533a64299fc9d3710c4d21307ce72df91 (diff)
downloadfreebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.gz
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.zst
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.zip
Welcome PHP 5.5!
Future steps: - rename current php5 ports to php54 - make php55 the default one after an exp-run
Diffstat (limited to 'textproc/php55-wddx')
-rw-r--r--textproc/php55-wddx/Makefile10
-rw-r--r--textproc/php55-wddx/files/patch-config.m422
-rw-r--r--textproc/php55-wddx/files/patch-wddx.c40
3 files changed, 72 insertions, 0 deletions
diff --git a/textproc/php55-wddx/Makefile b/textproc/php55-wddx/Makefile
new file mode 100644
index 000000000000..790120bcd0ce
--- /dev/null
+++ b/textproc/php55-wddx/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -wddx
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php55-wddx/files/patch-config.m4 b/textproc/php55-wddx/files/patch-config.m4
new file mode 100644
index 000000000000..08787003b8f9
--- /dev/null
+++ b/textproc/php55-wddx/files/patch-config.m4
@@ -0,0 +1,22 @@
+--- config.m4.orig Mon Jul 26 09:05:10 2004
++++ config.m4 Mon Jul 26 09:07:46 2004
+@@ -5,6 +5,9 @@
+ PHP_ARG_ENABLE(wddx,whether to enable WDDX support,
+ [ --enable-wddx Enable WDDX support.])
+
++PHP_ARG_WITH(libxml-dir, libxml2 install dir,
++[ --with-libxml-dir=<DIR> WDDX: libxml2 install prefix], no, no)
++
+ if test "$PHP_WDDX" != "no"; then
+ if test "$ext_shared" != "yes" && test "$enable_xml" = "no"; then
+ AC_MSG_WARN(Activating XML)
+@@ -12,4 +15,9 @@
+ fi
+ AC_DEFINE(HAVE_WDDX, 1, [ ])
+ PHP_NEW_EXTENSION(wddx, wddx.c, $ext_shared)
++
++ PHP_SETUP_LIBXML(WDDX_SHARED_LIBADD, [
++ ], [
++ AC_MSG_ERROR([xml2-config not found. Please check your libxml2 installation.])
++ ])
+ fi
diff --git a/textproc/php55-wddx/files/patch-wddx.c b/textproc/php55-wddx/files/patch-wddx.c
new file mode 100644
index 000000000000..a8a6a79fe47f
--- /dev/null
+++ b/textproc/php55-wddx/files/patch-wddx.c
@@ -0,0 +1,40 @@
+--- wddx.c.orig Sun Jan 1 13:50:16 2006
++++ wddx.c Mon Jan 16 12:56:21 2006
+@@ -18,6 +18,10 @@
+
+ /* $Id: wddx.c,v 1.119.2.8 2006/01/01 12:50:16 sniper Exp $ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include "php.h"
+
+ #if HAVE_WDDX
+@@ -223,7 +227,7 @@
+
+ #include "ext/session/php_session.h"
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ /* {{{ PS_SERIALIZER_ENCODE_FUNC
+ */
+ PS_SERIALIZER_ENCODE_FUNC(wddx)
+@@ -302,7 +306,7 @@
+ {
+ le_wddx = zend_register_list_destructors_ex(release_wddx_packet_rsrc, NULL, "wddx", module_number);
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_session_register_serializer("wddx",
+ PS_SERIALIZER_ENCODE_NAME(wddx),
+ PS_SERIALIZER_DECODE_NAME(wddx));
+@@ -317,7 +321,7 @@
+ PHP_MINFO_FUNCTION(wddx)
+ {
+ php_info_print_table_start();
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_info_print_table_header(2, "WDDX Support", "enabled" );
+ php_info_print_table_row(2, "WDDX Session Serializer", "enabled" );
+ #else