aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-twistedLore
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-04-15 12:54:37 +0800
committerflz <flz@FreeBSD.org>2005-04-15 12:54:37 +0800
commitb54258b7dfe93fab1cd35b4483cff9e24a3a5c9f (patch)
tree7edd0c6c0eed72f257cf8e52ffc004781f791faf /textproc/py-twistedLore
parent0283b474cc40cc58e57d1035d4bebea0000b8ec4 (diff)
downloadfreebsd-ports-gnome-b54258b7dfe93fab1cd35b4483cff9e24a3a5c9f.tar.gz
freebsd-ports-gnome-b54258b7dfe93fab1cd35b4483cff9e24a3a5c9f.tar.zst
freebsd-ports-gnome-b54258b7dfe93fab1cd35b4483cff9e24a3a5c9f.zip
- Add py-twistedFlow, Documentation generator with HTML and LaTeX support.
PR: ports/79927 Submitted by: Neal Nelson <neal@nelson.name>
Diffstat (limited to 'textproc/py-twistedLore')
-rw-r--r--textproc/py-twistedLore/Makefile29
-rw-r--r--textproc/py-twistedLore/distinfo2
-rw-r--r--textproc/py-twistedLore/pkg-descr5
-rw-r--r--textproc/py-twistedLore/pkg-plist96
4 files changed, 132 insertions, 0 deletions
diff --git a/textproc/py-twistedLore/Makefile b/textproc/py-twistedLore/Makefile
new file mode 100644
index 000000000000..5b9c0198e779
--- /dev/null
+++ b/textproc/py-twistedLore/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-twistedLore
+# Date created: 14 April 2005
+# Whom: Neal Nelson <neal@nelson.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= twistedLore
+PORTVERSION= 0.1.0
+CATEGORIES= textproc python
+MASTER_SITES= http://twistedmatrix.com/downloads/Lore/0.1/ \
+ http://tmrc.mit.edu/mirror/twisted/Lore/0.1/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= TwistedLore-${PORTVERSION}
+
+MAINTAINER= neal@nelson.name
+COMMENT= Documentation generator with HTML and LaTeX support
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/twisted:${PORTSDIR}/devel/py-twistedCore
+
+WRKSRC= ${WRKDIR}/TwistedLore-${PORTVERSION}
+
+USE_BZIP2= yes
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS= yes
+
+PLIST_SUB+= S=${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}
+
+.include <bsd.port.mk>
diff --git a/textproc/py-twistedLore/distinfo b/textproc/py-twistedLore/distinfo
new file mode 100644
index 000000000000..9b833ff1dca9
--- /dev/null
+++ b/textproc/py-twistedLore/distinfo
@@ -0,0 +1,2 @@
+MD5 (TwistedLore-0.1.0.tar.bz2) = c38eea006be598081778d79c98fc8a42
+SIZE (TwistedLore-0.1.0.tar.bz2) = 58386
diff --git a/textproc/py-twistedLore/pkg-descr b/textproc/py-twistedLore/pkg-descr
new file mode 100644
index 000000000000..d08d19f63670
--- /dev/null
+++ b/textproc/py-twistedLore/pkg-descr
@@ -0,0 +1,5 @@
+Lore is a documentation generator with HTML and LaTeX support
+
+Twisted Lore is available under the MIT Free Software licence.
+
+WWW: http://twistedmatrix.com/
diff --git a/textproc/py-twistedLore/pkg-plist b/textproc/py-twistedLore/pkg-plist
new file mode 100644
index 000000000000..e52d566e334b
--- /dev/null
+++ b/textproc/py-twistedLore/pkg-plist
@@ -0,0 +1,96 @@
+bin/bookify
+bin/lore
+%%S%%/twisted/lore/__init__.py
+%%S%%/twisted/lore/__init__.pyc
+%%S%%/twisted/lore/__init__.pyo
+%%S%%/twisted/lore/book.py
+%%S%%/twisted/lore/book.pyc
+%%S%%/twisted/lore/book.pyo
+%%S%%/twisted/lore/default.py
+%%S%%/twisted/lore/default.pyc
+%%S%%/twisted/lore/default.pyo
+%%S%%/twisted/lore/docbook.py
+%%S%%/twisted/lore/docbook.pyc
+%%S%%/twisted/lore/docbook.pyo
+%%S%%/twisted/lore/htmlbook.py
+%%S%%/twisted/lore/htmlbook.pyc
+%%S%%/twisted/lore/htmlbook.pyo
+%%S%%/twisted/lore/indexer.py
+%%S%%/twisted/lore/indexer.pyc
+%%S%%/twisted/lore/indexer.pyo
+%%S%%/twisted/lore/latex.py
+%%S%%/twisted/lore/latex.pyc
+%%S%%/twisted/lore/latex.pyo
+%%S%%/twisted/lore/lint.py
+%%S%%/twisted/lore/lint.pyc
+%%S%%/twisted/lore/lint.pyo
+%%S%%/twisted/lore/lmath.py
+%%S%%/twisted/lore/lmath.pyc
+%%S%%/twisted/lore/lmath.pyo
+%%S%%/twisted/lore/man2lore.py
+%%S%%/twisted/lore/man2lore.pyc
+%%S%%/twisted/lore/man2lore.pyo
+%%S%%/twisted/lore/nevowlore.py
+%%S%%/twisted/lore/nevowlore.pyc
+%%S%%/twisted/lore/nevowlore.pyo
+%%S%%/twisted/lore/numberer.py
+%%S%%/twisted/lore/numberer.pyc
+%%S%%/twisted/lore/numberer.pyo
+%%S%%/twisted/lore/process.py
+%%S%%/twisted/lore/process.pyc
+%%S%%/twisted/lore/process.pyo
+%%S%%/twisted/lore/scripts/__init__.py
+%%S%%/twisted/lore/scripts/__init__.pyc
+%%S%%/twisted/lore/scripts/__init__.pyo
+%%S%%/twisted/lore/scripts/bookify.py
+%%S%%/twisted/lore/scripts/bookify.pyc
+%%S%%/twisted/lore/scripts/bookify.pyo
+%%S%%/twisted/lore/scripts/lore.py
+%%S%%/twisted/lore/scripts/lore.pyc
+%%S%%/twisted/lore/scripts/lore.pyo
+%%S%%/twisted/lore/slides.py
+%%S%%/twisted/lore/slides.pyc
+%%S%%/twisted/lore/slides.pyo
+%%S%%/twisted/lore/template.mgp
+%%S%%/twisted/lore/test/__init__.py
+%%S%%/twisted/lore/test/__init__.pyc
+%%S%%/twisted/lore/test/__init__.pyo
+%%S%%/twisted/lore/test/good_internal.xhtml
+%%S%%/twisted/lore/test/good_simple.xhtml
+%%S%%/twisted/lore/test/lore_index_file_out.html
+%%S%%/twisted/lore/test/lore_index_file_out_multiple.html
+%%S%%/twisted/lore/test/lore_index_file_unnumbered_multiple_out.html
+%%S%%/twisted/lore/test/lore_index_file_unnumbered_out.html
+%%S%%/twisted/lore/test/lore_index_test.xhtml
+%%S%%/twisted/lore/test/lore_index_test2.xhtml
+%%S%%/twisted/lore/test/lore_index_test3.xhtml
+%%S%%/twisted/lore/test/lore_index_test_out.html
+%%S%%/twisted/lore/test/lore_index_test_out2.html
+%%S%%/twisted/lore/test/lore_numbering_test.xhtml
+%%S%%/twisted/lore/test/lore_numbering_test_out.html
+%%S%%/twisted/lore/test/lore_numbering_test_out2.html
+%%S%%/twisted/lore/test/simple.html
+%%S%%/twisted/lore/test/simple.xhtml
+%%S%%/twisted/lore/test/simple1.xhtml
+%%S%%/twisted/lore/test/simple2.xhtml
+%%S%%/twisted/lore/test/simple3.html
+%%S%%/twisted/lore/test/simple3.xhtml
+%%S%%/twisted/lore/test/simple4.html
+%%S%%/twisted/lore/test/simple4.xhtml
+%%S%%/twisted/lore/test/simple4foo.xhtml
+%%S%%/twisted/lore/test/template.tpl
+%%S%%/twisted/lore/test/test_lore.py
+%%S%%/twisted/lore/test/test_lore.pyc
+%%S%%/twisted/lore/test/test_lore.pyo
+%%S%%/twisted/lore/texi.py
+%%S%%/twisted/lore/texi.pyc
+%%S%%/twisted/lore/texi.pyo
+%%S%%/twisted/lore/tree.py
+%%S%%/twisted/lore/tree.pyc
+%%S%%/twisted/lore/tree.pyo
+%%S%%/twisted/plugins/twisted_lore.py
+%%S%%/twisted/plugins/twisted_lore.pyc
+%%S%%/twisted/plugins/twisted_lore.pyo
+@dirrm %%S%%/twisted/lore/test
+@dirrm %%S%%/twisted/lore/scripts
+@dirrm %%S%%/twisted/lore