aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-wicked
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committermat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
commit32512cab3e8dd90b7cd0525bb5dc98007db431e2 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /textproc/py-wicked
parentb4ddc365e88ebdb48627086b02365b74119cf189 (diff)
downloadfreebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.gz
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.zst
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'textproc/py-wicked')
-rw-r--r--textproc/py-wicked/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/textproc/py-wicked/Makefile b/textproc/py-wicked/Makefile
index afddd45c4109..1763456f1632 100644
--- a/textproc/py-wicked/Makefile
+++ b/textproc/py-wicked/Makefile
@@ -12,12 +12,12 @@ COMMENT= Compact syntax for doing wiki-like content linking and creation
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.container>=0:devel/py-zope.container \
- ${PYTHON_PKGNAMEPREFIX}zope.lifecycleevent>=0:devel/py-zope.lifecycleevent \
- ${PYTHON_PKGNAMEPREFIX}zope.schema>=0:devel/py-zope.schema \
- ${PYTHON_PKGNAMEPREFIX}zope.traversing>=0:devel/py-zope.traversing
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.container>=0:devel/py-zope.container@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.lifecycleevent>=0:devel/py-zope.lifecycleevent@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.schema>=0:devel/py-zope.schema@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.traversing>=0:devel/py-zope.traversing@${FLAVOR}
-USES= python zip
+USES= python:2.7 zip
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>