aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-xml
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2002-09-18 20:25:25 +0800
committerwjv <wjv@FreeBSD.org>2002-09-18 20:25:25 +0800
commit4cef9983dffd5fd8e77455c1d92d174feb770e2c (patch)
treea70c70bb4df7924dc5f7bf643d4a32630047cc05 /textproc/py-xml
parent94c261b8f9cfc71a72ab46074d9f32f02579a241 (diff)
downloadfreebsd-ports-gnome-4cef9983dffd5fd8e77455c1d92d174feb770e2c.tar.gz
freebsd-ports-gnome-4cef9983dffd5fd8e77455c1d92d174feb770e2c.tar.zst
freebsd-ports-gnome-4cef9983dffd5fd8e77455c1d92d174feb770e2c.zip
- Update to version 0.8.1
- Add a $PKGREQ to enforce dependency on version 2.0+ of Python
Diffstat (limited to 'textproc/py-xml')
-rw-r--r--textproc/py-xml/Makefile11
-rw-r--r--textproc/py-xml/distinfo2
-rw-r--r--textproc/py-xml/pkg-plist1
-rw-r--r--textproc/py-xml/pkg-req17
4 files changed, 25 insertions, 6 deletions
diff --git a/textproc/py-xml/Makefile b/textproc/py-xml/Makefile
index 140cbaa7bb12..59c37a2d4b6c 100644
--- a/textproc/py-xml/Makefile
+++ b/textproc/py-xml/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xml
-PORTVERSION= 0.8
+PORTVERSION= 0.8.1
CATEGORIES= textproc python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pyxml
@@ -23,11 +23,12 @@ USE_PYDISTUTILS= yes
CPIO= cpio --quiet -pdum -R
DOCSDIR= ${PREFIX}/share/doc/py-xml
EXAMPLESDIR= ${PREFIX}/share/examples/py-xml
-.if ${PYTHON_REL} < 200
-PLIST_SUB+= PACKAGE_DIR=xml
-.else
PLIST_SUB+= PACKAGE_DIR=_xmlplus
-.endif
+PYDISTUTILS_BUILDARGS+= --with-xslt
+PYDISTUTILS_INSTALLARGS+= --with-xslt
+
+pre-install:
+ @ ${SH} ${PKGREQ} INSTALL
post-install:
.if !defined(NOPORTDOCS)
diff --git a/textproc/py-xml/distinfo b/textproc/py-xml/distinfo
index 298ef0dcc979..70f6123f6f7a 100644
--- a/textproc/py-xml/distinfo
+++ b/textproc/py-xml/distinfo
@@ -1 +1 @@
-MD5 (PyXML-0.8.tar.gz) = d9407357fb2ef666612847c15cedd6a1
+MD5 (PyXML-0.8.1.tar.gz) = a89276ec01675ad57a964901687387fa
diff --git a/textproc/py-xml/pkg-plist b/textproc/py-xml/pkg-plist
index 59758e9e3816..c275cb21d5a0 100644
--- a/textproc/py-xml/pkg-plist
+++ b/textproc/py-xml/pkg-plist
@@ -252,6 +252,7 @@
%%PORTDOCS%%share/examples/py-xml/test/test_sax2_xmlproc.py
%%PORTDOCS%%share/examples/py-xml/test/test_sax_xmlproc.py
%%PORTDOCS%%share/examples/py-xml/test/test_saxdrivers.py
+%%PORTDOCS%%share/examples/py-xml/test/test_support.py
%%PORTDOCS%%share/examples/py-xml/test/test_utils.py
%%PORTDOCS%%share/examples/py-xml/test/test_xmlbuilder.py
%%PORTDOCS%%share/examples/py-xml/test/test_xmlproc.py
diff --git a/textproc/py-xml/pkg-req b/textproc/py-xml/pkg-req
new file mode 100644
index 000000000000..af2d70f92c9e
--- /dev/null
+++ b/textproc/py-xml/pkg-req
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+PATH=$PATH:/usr/local/bin
+
+if [ "x$1" = "xINSTALL" -o "x$2" = "xINSTALL" ]; then
+ PYTHON_GT=`python -c 'import string, sys; \
+ print string.split(sys.version)[0] >= "2.0"'`
+ if [ "x${PYTHON_GT}" = "x1" ]; then
+ exit 0
+ else
+ echo "-----------------------------------------------------------"
+ echo "PyXML requires Python version 2.0 or greater -"
+ echo " please update your Python installation before proceeding."
+ echo "-----------------------------------------------------------"
+ exit 1
+ fi
+fi