aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/qt4-xml
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-08-05 07:30:38 +0800
committermiwi <miwi@FreeBSD.org>2008-08-05 07:30:38 +0800
commit4c87193b0b003ef0d636a924d725f6fa020e1e60 (patch)
tree692f92f387c0c00567ee9c6c42937ae5f44cc85f /textproc/qt4-xml
parente30d8bc39c0bef0e971424513fdd8b6a0588a9cd (diff)
downloadfreebsd-ports-gnome-4c87193b0b003ef0d636a924d725f6fa020e1e60.tar.gz
freebsd-ports-gnome-4c87193b0b003ef0d636a924d725f6fa020e1e60.tar.zst
freebsd-ports-gnome-4c87193b0b003ef0d636a924d725f6fa020e1e60.zip
- Update to qt 4.4.1
Note: With this update several ports specific problems have been fixed. Qt4 headers and libraries have been moved to include/qt4 and lib/qt4. bsd.qt.mk defines QT_INCDIR and QT_LIBDIR now, which could be used in qt4-dependent ports if required. Thanks to: Max Brazhnikov Danny Pansters
Diffstat (limited to 'textproc/qt4-xml')
-rw-r--r--textproc/qt4-xml/Makefile36
-rw-r--r--textproc/qt4-xml/distinfo6
-rw-r--r--textproc/qt4-xml/pkg-plist118
3 files changed, 78 insertions, 82 deletions
diff --git a/textproc/qt4-xml/Makefile b/textproc/qt4-xml/Makefile
index 1a69d2825998..9646ca040cf6 100644
--- a/textproc/qt4-xml/Makefile
+++ b/textproc/qt4-xml/Makefile
@@ -8,7 +8,7 @@
PORTNAME= xml
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
+PORTREVISION=0
CATEGORIES?= textproc
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -24,44 +24,38 @@ QT_NONSTANDARD= yes
QT_DIST= yes
HAS_CONFIGURE= yes
-USE_LDCONFIG= yes
+USE_LDCONFIG= ${PREFIX}/lib/qt4
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
PATH=${WRKSRC}/bin:$$PATH
-EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
- --exclude '${DISTNAME}/mkspecs' --exclude '${DISTNAME}/qmake' \
- --exclude '${DISTNAME}/demos' --exclude '${DISTNAME}/examples' \
- --exclude '${DISTNAME}/src/gui' --exclude '${DISTNAME}/src/network' \
- --exclude '${DISTNAME}/src/opengl' --exclude '${DISTNAME}/src/qt3support' \
- --exclude '${DISTNAME}/src/sql' --exclude '${DISTNAME}/src/plugins' \
- --exclude '${DISTNAME}/src/3rdparty' --exclude '${DISTNAME}/src/tools/moc' \
- --exclude '${DISTNAME}/src/tools/rcc' \
- --exclude '${DISTNAME}/src/tools/uic' --exclude '${DISTNAME}/src/tools/uic3' \
- --exclude '${DISTNAME}/tools/assistant' --exclude '${DISTNAME}/tools/designer' \
- --exclude '${DISTNAME}/tools/linguist' --exclude '${DISTNAME}/tools/porting' \
- --exclude '${DISTNAME}/tools/qtconfig' --exclude '${DISTNAME}/tools/qvfb'
+
+DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
+ src/dbus src/gui src/network src/opengl src/phonon \
+ src/qt3support src/script src/sql src/svg src/testlib \
+ src/tools src/xmlpatterns src/3rdparty/clucene \
+ src/3rdparty/kdebase src/3rdparty/kdelibs src/3rdparty/webkit
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+.for dne in ${DO_NOT_EXTRACT}
+EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
+.endfor
+
WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
- ${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
- -e 's|flat_headers.path.*|flat_headers.path=${PREFIX}/include/Qt|g' \
- -e 's|targ_headers.path.*|targ_headers.path=${PREFIX}/include/$$$$TARGET|g' \
- ${WRKSRC}/${PORTNAME}.pro ${WRKSRC}/../qt_install.pri
${MKDIR} ${WRKSRC}/../../mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../bin/moc
post-configure:
- ${REINPLACE_CMD} -e 's|${PREFIX}/lib/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ ${REINPLACE_CMD} -e 's|${PREFIX}/lib/qt4/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
-e 's|.*$$(QMAKE).*||g' ${WRKSRC}/Makefile
${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
- -E -e 's|(.*Cflags:.*)-I${LOCALBASE}/include |\1|g' \
- ${WRKSRC}/../../lib/pkgconfig/*Qt*
+ ${WRKSRC}/../../lib/pkgconfig/QtXml.pc
.include <bsd.port.mk>
diff --git a/textproc/qt4-xml/distinfo b/textproc/qt4-xml/distinfo
index 9451a68b5c02..0c630f09baf6 100644
--- a/textproc/qt4-xml/distinfo
+++ b/textproc/qt4-xml/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-x11-opensource-src-4.3.4.tar.gz) = 9499101ec54eb7b0de195b3c5e3ffa93
-SHA256 (KDE/qt-x11-opensource-src-4.3.4.tar.gz) = 8864dd80f3456be70a3be60364502a0ca3f46125b2f156860ad880ff55fcabd2
-SIZE (KDE/qt-x11-opensource-src-4.3.4.tar.gz) = 43988710
+MD5 (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = b09decad252b5181f300135e3122481d
+SHA256 (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = 5aca7b784fc4de3db292666490ade84cfd1810f189c089c5c2810a710993f386
+SIZE (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = 108774120
diff --git a/textproc/qt4-xml/pkg-plist b/textproc/qt4-xml/pkg-plist
index 76cdce0b6f32..a9dc0b9296e4 100644
--- a/textproc/qt4-xml/pkg-plist
+++ b/textproc/qt4-xml/pkg-plist
@@ -1,59 +1,61 @@
-include/Qt/QtXml
-include/Qt/qdom.h
-include/Qt/qxml.h
-include/Qt/qxmlstream.h
-include/QtXml/QDomAttr
-include/QtXml/QDomCDATASection
-include/QtXml/QDomCharacterData
-include/QtXml/QDomComment
-include/QtXml/QDomDocument
-include/QtXml/QDomDocumentFragment
-include/QtXml/QDomDocumentType
-include/QtXml/QDomElement
-include/QtXml/QDomEntity
-include/QtXml/QDomEntityReference
-include/QtXml/QDomImplementation
-include/QtXml/QDomNamedNodeMap
-include/QtXml/QDomNode
-include/QtXml/QDomNodeList
-include/QtXml/QDomNotation
-include/QtXml/QDomProcessingInstruction
-include/QtXml/QDomText
-include/QtXml/QXmlAttributes
-include/QtXml/QXmlContentHandler
-include/QtXml/QXmlDTDHandler
-include/QtXml/QXmlDeclHandler
-include/QtXml/QXmlDefaultHandler
-include/QtXml/QXmlEntityResolver
-include/QtXml/QXmlErrorHandler
-include/QtXml/QXmlInputSource
-include/QtXml/QXmlLexicalHandler
-include/QtXml/QXmlLocator
-include/QtXml/QXmlNamespaceSupport
-include/QtXml/QXmlParseException
-include/QtXml/QXmlReader
-include/QtXml/QXmlSimpleReader
-include/QtXml/QXmlStreamAttribute
-include/QtXml/QXmlStreamAttributes
-include/QtXml/QXmlStreamEntityDeclaration
-include/QtXml/QXmlStreamEntityDeclarations
-include/QtXml/QXmlStreamNamespaceDeclaration
-include/QtXml/QXmlStreamNamespaceDeclarations
-include/QtXml/QXmlStreamNotationDeclaration
-include/QtXml/QXmlStreamNotationDeclarations
-include/QtXml/QXmlStreamReader
-include/QtXml/QXmlStreamStringRef
-include/QtXml/QXmlStreamWriter
-include/QtXml/QtXml
-include/QtXml/qdom.h
-include/QtXml/qxml.h
-include/QtXml/qxmlstream.h
-lib/libQtXml.la
-lib/libQtXml.prl
-lib/libQtXml.so
-lib/libQtXml.so.4
-lib/libQtXml.so.4.3
-lib/libQtXml.so.4.3.4
-%%DEBUG%%lib/libQtXml.so.4.3.4.debug
+include/qt4/Qt/QtXml
+include/qt4/Qt/qdom.h
+include/qt4/Qt/qxml.h
+include/qt4/QtXml/QDomAttr
+include/qt4/QtXml/QDomCDATASection
+include/qt4/QtXml/QDomCharacterData
+include/qt4/QtXml/QDomComment
+include/qt4/QtXml/QDomDocument
+include/qt4/QtXml/QDomDocumentFragment
+include/qt4/QtXml/QDomDocumentType
+include/qt4/QtXml/QDomElement
+include/qt4/QtXml/QDomEntity
+include/qt4/QtXml/QDomEntityReference
+include/qt4/QtXml/QDomImplementation
+include/qt4/QtXml/QDomNamedNodeMap
+include/qt4/QtXml/QDomNode
+include/qt4/QtXml/QDomNodeList
+include/qt4/QtXml/QDomNotation
+include/qt4/QtXml/QDomProcessingInstruction
+include/qt4/QtXml/QDomText
+include/qt4/QtXml/QXmlAttributes
+include/qt4/QtXml/QXmlContentHandler
+include/qt4/QtXml/QXmlDTDHandler
+include/qt4/QtXml/QXmlDeclHandler
+include/qt4/QtXml/QXmlDefaultHandler
+include/qt4/QtXml/QXmlEntityResolver
+include/qt4/QtXml/QXmlErrorHandler
+include/qt4/QtXml/QXmlInputSource
+include/qt4/QtXml/QXmlLexicalHandler
+include/qt4/QtXml/QXmlLocator
+include/qt4/QtXml/QXmlNamespaceSupport
+include/qt4/QtXml/QXmlParseException
+include/qt4/QtXml/QXmlReader
+include/qt4/QtXml/QXmlSimpleReader
+include/qt4/QtXml/QXmlStreamAttribute
+include/qt4/QtXml/QXmlStreamAttributes
+include/qt4/QtXml/QXmlStreamEntityDeclaration
+include/qt4/QtXml/QXmlStreamEntityDeclarations
+include/qt4/QtXml/QXmlStreamEntityResolver
+include/qt4/QtXml/QXmlStreamNamespaceDeclaration
+include/qt4/QtXml/QXmlStreamNamespaceDeclarations
+include/qt4/QtXml/QXmlStreamNotationDeclaration
+include/qt4/QtXml/QXmlStreamNotationDeclarations
+include/qt4/QtXml/QXmlStreamReader
+include/qt4/QtXml/QXmlStreamStringRef
+include/qt4/QtXml/QXmlStreamWriter
+include/qt4/QtXml/QtXml
+include/qt4/QtXml/qdom.h
+include/qt4/QtXml/qxml.h
+include/qt4/QtXml/qxmlstream.h
+lib/qt4/libQtXml.la
+lib/qt4/libQtXml.prl
+lib/qt4/libQtXml.so
+lib/qt4/libQtXml.so.4
+lib/qt4/libQtXml.so.4.4
+lib/qt4/libQtXml.so.4.4.1
+%%DEBUG%%lib/qt4/libQtXml.so.4.4.1.debug
libdata/pkgconfig/QtXml.pc
-@dirrm include/QtXml
+@dirrm include/qt4/QtXml
+@dirrmtry include/qt4/Qt
+@dirrmtry include/qt4