aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/rarian
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-10-25 07:37:25 +0800
committermarcus <marcus@FreeBSD.org>2007-10-25 07:37:25 +0800
commit43bd9f14d9ce11690e9538bf3b03d3462faa6dbe (patch)
treeda347910089a96d6d726b8bb080f62c773263828 /textproc/rarian
parent2e669ed08a56339ee1a8b2a0573a30147f95bd82 (diff)
downloadfreebsd-ports-gnome-43bd9f14d9ce11690e9538bf3b03d3462faa6dbe.tar.gz
freebsd-ports-gnome-43bd9f14d9ce11690e9538bf3b03d3462faa6dbe.tar.zst
freebsd-ports-gnome-43bd9f14d9ce11690e9538bf3b03d3462faa6dbe.zip
Presenting GNOME 2.20.1 and all related works for FreeBSD. The official
GNOME 2.20 release notes can be found at http://www.gnome.org/start/2.20/notes/en/ . Beyond that, this update includes the new GIMP 2.4 (courtesy of ahze). The GNOME 2.20 update also includes a huge change in the FreeBSD GNOME hierarchy. We are now using the more standard DATADIR of ${PREFIX}/share rather than ${PREFIX}/share/gnome. The result is that fewer patches and hacks are needed to port GNOME components to FreeBSD. This will mean some user changes may be required, so be sure to read /usr/ports/UPDATING for more details. This release and the things we accomplished in it would not have been possible without mezz's crazy idea to collapse DATADIR, and his persistence to make it happen successfully. Ahze and pav also deserve thanks for their work on porting modules and testing the whole ball of wax on pointyhat (respectively). The FreeBSD GNOME team would also like to thank our various testers and contributors: Yasuda Keisuke Frank Jahnke Pawel Worach Brian Gruber Franz Klammer Yuri Pankov Nick Barkas Cristian KLEIN Tony Maher Scot Hetzel Martin Matuska (mm) Benoit Dejean Martin Wilke (miwi) (And anyone else I may have missed) PRs fixed in this release: 111272, 113470, 115995, 116338
Diffstat (limited to 'textproc/rarian')
-rw-r--r--textproc/rarian/Makefile59
-rw-r--r--textproc/rarian/distinfo3
-rw-r--r--textproc/rarian/files/patch-docs_Makefile.in11
-rw-r--r--textproc/rarian/files/patch-librarian_rarian-main.c11
-rw-r--r--textproc/rarian/files/patch-util_rarian-sk-config.in11
-rw-r--r--textproc/rarian/pkg-descr9
-rw-r--r--textproc/rarian/pkg-plist53
7 files changed, 157 insertions, 0 deletions
diff --git a/textproc/rarian/Makefile b/textproc/rarian/Makefile
new file mode 100644
index 000000000000..f8d0260c8988
--- /dev/null
+++ b/textproc/rarian/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: rarian
+# Date created: 02 August 2007
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/textproc/rarian/Makefile,v 1.8 2007/10/11 04:04:18 mezz Exp $
+#
+
+PORTNAME= rarian
+PORTVERSION= 0.6.0
+PORTREVISION= 1
+CATEGORIES= textproc gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= An OMF help system based on the Freedesktop specification
+
+BUILD_DEPENDS= ${LOCALBASE}/share/xsl/docbook/xhtml/chunk.xsl:${PORTSDIR}/textproc/docbook-xsl \
+ ${LOCALBASE}/share/xml/docbook/${DOCBOOK_VERSION}/catalog.xml:${PORTSDIR}/textproc/docbook-xml \
+ ${LOCALBASE}/share/xml/docbook/4.1.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-sk \
+ bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ ${LOCALBASE}/bin/getopt:${PORTSDIR}/misc/getopt \
+ ${LOCALBASE}/share/xsl/docbook/xhtml/chunk.xsl:${PORTSDIR}/textproc/docbook-xsl \
+ ${LOCALBASE}/share/xml/docbook/${DOCBOOK_VERSION}/catalog.xml:${PORTSDIR}/textproc/docbook-xml \
+ ${LOCALBASE}/share/xml/docbook/4.1.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-sk
+
+DOCBOOK_VERSION=4.2
+
+CONFLICTS= scrollkeeper-[0-9]*
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehier gnometarget gnomehack libxslt
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --with-convert-dir=${LOCALBASE}/share/omf \
+ --datadir=${PREFIX}/share \
+ --localstatedir=/var
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/lib/rarian|/db/rarian|' \
+ ${WRKSRC}/util/Makefile.in
+ @${REINPLACE_CMD} -e 's|@localstatedir@/lib/rarian|@localstatedir@/db/rarian|g ; \
+ s|getopt|${LOCALBASE}/bin/getopt|' \
+ ${WRKSRC}/util/rarian-sk-config.in \
+ ${WRKSRC}/util/rarian-sk-extract.in \
+ ${WRKSRC}/util/rarian-sk-rebuild.in \
+ ${WRKSRC}/util/rarian-sk-update.in
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/librarian/rarian-main.c \
+ ${WRKSRC}/librarian/rarian-man.c \
+ ${WRKSRC}/librarian/rarian-info.c
+
+.include <bsd.port.mk>
diff --git a/textproc/rarian/distinfo b/textproc/rarian/distinfo
new file mode 100644
index 000000000000..c10840549f71
--- /dev/null
+++ b/textproc/rarian/distinfo
@@ -0,0 +1,3 @@
+MD5 (rarian-0.6.0.tar.bz2) = 23772a3b0f882d13c86dd9fa67bb21bf
+SHA256 (rarian-0.6.0.tar.bz2) = 2f169f3c794b2602d8590b1fd16c0aa5b7ca77e993f74b89c4f42db74c1d2029
+SIZE (rarian-0.6.0.tar.bz2) = 312258
diff --git a/textproc/rarian/files/patch-docs_Makefile.in b/textproc/rarian/files/patch-docs_Makefile.in
new file mode 100644
index 000000000000..10e4783a75b8
--- /dev/null
+++ b/textproc/rarian/files/patch-docs_Makefile.in
@@ -0,0 +1,11 @@
+--- docs/Makefile.in.orig 2007-08-02 01:37:06.000000000 -0400
++++ docs/Makefile.in 2007-08-02 01:37:22.000000000 -0400
+@@ -183,7 +183,7 @@ target_alias = @target_alias@
+ EXTRA_DIST = help-spec-0.2.xml index.xhtml rar-mdf.xhtml rar-lib.xhtml rar-skcompat.xhtml rarian.document.in
+ manualdir = $(datadir)/librarian/manual
+ manual_DATA = help-spec-0.2.xml index.xhtml rar-mdf.xhtml rar-lib.xhtml rar-skcompat.xhtml
+-metadatadir = $(datadir)/help
++metadatadir = $(datadir)/doc/rarian
+ metadata_DATA = rarian.document
+ all: all-am
+
diff --git a/textproc/rarian/files/patch-librarian_rarian-main.c b/textproc/rarian/files/patch-librarian_rarian-main.c
new file mode 100644
index 000000000000..549390150c64
--- /dev/null
+++ b/textproc/rarian/files/patch-librarian_rarian-main.c
@@ -0,0 +1,11 @@
+--- librarian/rarian-main.c.orig 2007-08-02 16:04:45.000000000 -0400
++++ librarian/rarian-main.c 2007-08-02 16:12:58.000000000 -0400
+@@ -212,7 +212,7 @@ past:
+ path = getenv ("XDG_DATA_DIRS");
+
+ if (!path || !strcmp (path, "")) {
+- path = "/usr/local/share/:/usr/share/";
++ path = "/usr/local/share/";
+ }
+ cur_path = path;
+ do {
diff --git a/textproc/rarian/files/patch-util_rarian-sk-config.in b/textproc/rarian/files/patch-util_rarian-sk-config.in
new file mode 100644
index 000000000000..c97a07c77b6c
--- /dev/null
+++ b/textproc/rarian/files/patch-util_rarian-sk-config.in
@@ -0,0 +1,11 @@
+--- util/rarian-sk-config.in.orig 2007-10-10 23:00:03.000000000 -0500
++++ util/rarian-sk-config.in 2007-10-10 23:00:30.000000000 -0500
+@@ -47,7 +47,7 @@
+ print_help
+ ;;
+ --version )
+- echo $package_version \(Rarian replacement for scrollkeeper-config\)
++ echo $package_version
+ ;;
+ --prefix )
+ echo $prefix
diff --git a/textproc/rarian/pkg-descr b/textproc/rarian/pkg-descr
new file mode 100644
index 000000000000..e60b1e98e756
--- /dev/null
+++ b/textproc/rarian/pkg-descr
@@ -0,0 +1,9 @@
+Rarian is designed to be a replacement for scrollkeeper. It is
+currently undergoing heavy development. As of writing, rarian can be
+installed in place of scrollkeeper and everything will work okay.
+
+Rarian manages documentation metadata (as specified by the Open Source
+Metadata Framework (OMF) and provides a simple API to allow help browsers
+to find, sort, and search the document catalog. It will also be able to
+communicate with catalog servers on the Net to search for documents which
+are not on the local system.
diff --git a/textproc/rarian/pkg-plist b/textproc/rarian/pkg-plist
new file mode 100644
index 000000000000..1abb978331bc
--- /dev/null
+++ b/textproc/rarian/pkg-plist
@@ -0,0 +1,53 @@
+bin/rarian-example
+bin/rarian-sk-config
+bin/rarian-sk-extract
+bin/rarian-sk-gen-uuid
+bin/rarian-sk-get-cl
+bin/rarian-sk-get-content-list
+bin/rarian-sk-get-extended-content-list
+bin/rarian-sk-get-scripts
+bin/rarian-sk-install
+bin/rarian-sk-migrate
+bin/rarian-sk-preinstall
+bin/rarian-sk-rebuild
+bin/rarian-sk-update
+bin/scrollkeeper-config
+bin/scrollkeeper-extract
+bin/scrollkeeper-gen-seriesid
+bin/scrollkeeper-get-cl
+bin/scrollkeeper-get-content-list
+bin/scrollkeeper-get-extended-content-list
+bin/scrollkeeper-get-index-from-docpath
+bin/scrollkeeper-get-toc-from-docpath
+bin/scrollkeeper-get-toc-from-id
+bin/scrollkeeper-install
+bin/scrollkeeper-preinstall
+bin/scrollkeeper-rebuilddb
+bin/scrollkeeper-uninstall
+bin/scrollkeeper-update
+include/rarian/rarian-info.h
+include/rarian/rarian-man.h
+include/rarian/rarian-reg-utils.h
+include/rarian/rarian.h
+lib/librarian.a
+lib/librarian.la
+lib/librarian.so
+lib/librarian.so.0
+libdata/pkgconfig/rarian.pc
+share/doc/rarian/rarian.document
+share/librarian/Templates/C/scrollkeeper_cl.xml
+share/librarian/manual/help-spec-0.2.xml
+share/librarian/manual/index.xhtml
+share/librarian/manual/rar-lib.xhtml
+share/librarian/manual/rar-mdf.xhtml
+share/librarian/manual/rar-skcompat.xhtml
+share/librarian/rarian-sk-cl.xml
+@dirrm share/librarian/manual
+@dirrm share/librarian/Templates/C
+@dirrm share/librarian/Templates
+@dirrm share/librarian
+@dirrm share/doc/rarian
+@dirrm include/rarian
+@unexec rm -rf /var/db/scrollkeeper 2>/dev/null || true
+@exec mkdir -p /var/db/rarian
+@exec %%PREFIX%%/bin/rarian-sk-update || true