aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/re_graph
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2005-04-22 18:32:59 +0800
committerijliao <ijliao@FreeBSD.org>2005-04-22 18:32:59 +0800
commit22475a6d3c95996f77c609991e02b58943b215f4 (patch)
tree5e4c54db2b2b1da6905c7e48dc0f2b866cf781b0 /textproc/re_graph
parent4036185a6daeb270dc1d72ba5c572e57faee1e8b (diff)
downloadfreebsd-ports-gnome-22475a6d3c95996f77c609991e02b58943b215f4.tar.gz
freebsd-ports-gnome-22475a6d3c95996f77c609991e02b58943b215f4.tar.zst
freebsd-ports-gnome-22475a6d3c95996f77c609991e02b58943b215f4.zip
add re_graph 0.2
Regular Expression Graphing Program
Diffstat (limited to 'textproc/re_graph')
-rw-r--r--textproc/re_graph/Makefile43
-rw-r--r--textproc/re_graph/distinfo2
-rw-r--r--textproc/re_graph/pkg-descr17
3 files changed, 62 insertions, 0 deletions
diff --git a/textproc/re_graph/Makefile b/textproc/re_graph/Makefile
new file mode 100644
index 000000000000..2a43249aabe0
--- /dev/null
+++ b/textproc/re_graph/Makefile
@@ -0,0 +1,43 @@
+# ex:ts=8
+# Ports collection makefile for: re_graph
+# Date created: Apr 22, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= re_graph
+PORTVERSION= 0.2
+CATEGORIES= textproc
+MASTER_SITES= http://www.oualline.com/sw/re/
+DISTNAME= ${PORTNAME:S/_/-/}_${PORTVERSION:S/.//}
+EXTRACT_SUFX= .tar
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Regular Expression Graphing Program
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
+ ${SITE_PERL}/GD/Arrow.pm:${PORTSDIR}/graphics/p5-GD-Arrow
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${TAR}
+EXTRACT_BEFORE_ARGS= -xf
+EXTRACT_AFTER_ARGS= # empty
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+PLIST_FILES= bin/re_graph
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/re_graph.pl ${PREFIX}/bin/re_graph
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/re_graph.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tut* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/re_graph/distinfo b/textproc/re_graph/distinfo
new file mode 100644
index 000000000000..79ada4c26fff
--- /dev/null
+++ b/textproc/re_graph/distinfo
@@ -0,0 +1,2 @@
+MD5 (re-graph_02.tar) = e78e3d2237f0fac5726ad0d6ad6a31f1
+SIZE (re-graph_02.tar) = 4536320
diff --git a/textproc/re_graph/pkg-descr b/textproc/re_graph/pkg-descr
new file mode 100644
index 000000000000..9b9901414afd
--- /dev/null
+++ b/textproc/re_graph/pkg-descr
@@ -0,0 +1,17 @@
+The re_graph.pl program graphs regular expressions. The guts of the regular
+expression engine is a simple state machine. The various states and operations
+in the regular expression parser can be displayed using a surprisingly simple
+diagram.
+
+A few notes on what you are looking at:
+ * The nodes Start and Stop denote the beginning and end of the regular
+ expression.
+ * The solid squares denote atoms. Lines indicate the next state. When a
+ line splits, the state machine will take the top line first. If it's
+ path is blocked it will backup and take the next lower line. This is
+ repeated until it finds a path to the end or all paths are exhausted.
+ * Brown boxes indicate a grouping operation, i.e. ().
+ * Green boxes indicate a zero with test. The state machine will perform the
+ test inside the box before moving ahead.
+
+WWW: http://www.oualline.com/sw/