aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/rman
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-11 17:53:23 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-11 17:53:23 +0800
commit1f05c941f8cc975aef233dbd62a56cfbcb83f0bc (patch)
tree0454a06c29af5c5315ab00db998211b91340482a /textproc/rman
parent548faeabe44c2fb7cc3962a1d80710593a36ff6d (diff)
downloadfreebsd-ports-gnome-1f05c941f8cc975aef233dbd62a56cfbcb83f0bc.tar.gz
freebsd-ports-gnome-1f05c941f8cc975aef233dbd62a56cfbcb83f0bc.tar.zst
freebsd-ports-gnome-1f05c941f8cc975aef233dbd62a56cfbcb83f0bc.zip
Stagify.
Diffstat (limited to 'textproc/rman')
-rw-r--r--textproc/rman/Makefile6
-rw-r--r--textproc/rman/files/patch-Makefile15
2 files changed, 17 insertions, 4 deletions
diff --git a/textproc/rman/Makefile b/textproc/rman/Makefile
index 4df0dbc1ade7..8b1ac0ca8619 100644
--- a/textproc/rman/Makefile
+++ b/textproc/rman/Makefile
@@ -12,11 +12,9 @@ COMMENT= Reverse compile man pages from formatted form
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
BINDIR="${PREFIX}/bin" MANDIR="${MAN1PREFIX}/man/man1"
-MAN1= rman.1
-PLIST_FILES= bin/rman
+PLIST_FILES= bin/rman man/man1/rman.1.gz
-NO_STAGE= yes
post-install:
- @${STRIP_CMD} ${PREFIX}/bin/rman
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/rman
.include <bsd.port.mk>
diff --git a/textproc/rman/files/patch-Makefile b/textproc/rman/files/patch-Makefile
new file mode 100644
index 000000000000..ffd3f99de58d
--- /dev/null
+++ b/textproc/rman/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile.orig 2014-06-11 17:51:49.106250664 +0800
++++ Makefile 2014-06-11 17:52:29.988257646 +0800
+@@ -113,10 +113,8 @@ prof:
+
+ install: rman
+ # $(INSTALL) -s rman $(BINDIR)
+- $(RM) -f $(BINDIR)/rman
+- $(CP) rman $(BINDIR)
+- $(RM) -f $(MANDIR)/rman.1
+- $(CP) rman.1 $(MANDIR)
++ $(CP) rman $(DESTDIR)$(BINDIR)
++ $(CP) rman.1 $(DESTDIR)$(MANDIR)
+
+ # test version includes assertions
+ # ginstall rman $(BINDIR)/`arch`