aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ruby-rdoc
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-12-26 05:24:40 +0800
committerknu <knu@FreeBSD.org>2001-12-26 05:24:40 +0800
commit8afc9898979df993675dbc345075c8f085ed2e85 (patch)
treef93160aa01c60499ad85b5c28952049a4efe09b5 /textproc/ruby-rdoc
parentc8dc43c5151d9ef0c806bb1c92af7de78f3b42ba (diff)
downloadfreebsd-ports-gnome-8afc9898979df993675dbc345075c8f085ed2e85.tar.gz
freebsd-ports-gnome-8afc9898979df993675dbc345075c8f085ed2e85.tar.zst
freebsd-ports-gnome-8afc9898979df993675dbc345075c8f085ed2e85.zip
Add ruby-rdoc, RDoc - Documentation from Ruby source files.
Diffstat (limited to 'textproc/ruby-rdoc')
-rw-r--r--textproc/ruby-rdoc/Makefile37
-rw-r--r--textproc/ruby-rdoc/distinfo1
-rw-r--r--textproc/ruby-rdoc/pkg-comment1
-rw-r--r--textproc/ruby-rdoc/pkg-descr10
-rw-r--r--textproc/ruby-rdoc/pkg-plist22
5 files changed, 71 insertions, 0 deletions
diff --git a/textproc/ruby-rdoc/Makefile b/textproc/ruby-rdoc/Makefile
new file mode 100644
index 000000000000..33714c7b5e9c
--- /dev/null
+++ b/textproc/ruby-rdoc/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: RDoc
+# Date created: 26 December 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rdoc
+PORTVERSION= 0.0.0.a4
+CATEGORIES= textproc ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION:E:S/a/alpha-/}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= ChangeLog README ToDo
+
+do-install:
+ cd ${WRKSRC}; ${RUBY} ./install.rb
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}/markup
+ ${INSTALL_DATA} ${WRKSRC}/markup/sample/sample.rb ${RUBY_EXAMPLESDIR}/${PORTNAME}/markup
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-rdoc/distinfo b/textproc/ruby-rdoc/distinfo
new file mode 100644
index 000000000000..9d7a73cec2a9
--- /dev/null
+++ b/textproc/ruby-rdoc/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/rdoc-alpha-4.tgz) = 5913b7acd2de271a5c4f7744c834b0ac
diff --git a/textproc/ruby-rdoc/pkg-comment b/textproc/ruby-rdoc/pkg-comment
new file mode 100644
index 000000000000..90058ae9e432
--- /dev/null
+++ b/textproc/ruby-rdoc/pkg-comment
@@ -0,0 +1 @@
+Documentation from Ruby source files
diff --git a/textproc/ruby-rdoc/pkg-descr b/textproc/ruby-rdoc/pkg-descr
new file mode 100644
index 000000000000..a3c782ac9b21
--- /dev/null
+++ b/textproc/ruby-rdoc/pkg-descr
@@ -0,0 +1,10 @@
+RDoc is a documentation tool for Ruby source files. It understands
+Ruby syntax, and automatically extracts class, module, method, and
+attribute definitions, building a structured set of HTML ages
+documenting your programs. It also extracts any comment block
+associated with program elements, formatting these using a natural
+markup scheme (the intent being that the source code should not have
+to have too much extra annotation when used by RDoc).
+
+Author: Dave Thomas <dave@pragmaticprogrammer.com>
+WWW: http://rdoc.sourceforge.net/
diff --git a/textproc/ruby-rdoc/pkg-plist b/textproc/ruby-rdoc/pkg-plist
new file mode 100644
index 000000000000..99e9700b3e6a
--- /dev/null
+++ b/textproc/ruby-rdoc/pkg-plist
@@ -0,0 +1,22 @@
+bin/rdoc
+%%RUBY_SITELIBDIR%%/markup/simple_markup.rb
+%%RUBY_SITELIBDIR%%/markup/simple_markup/to_html.rb
+%%RUBY_SITELIBDIR%%/markup/simple_markup/lines.rb
+%%RUBY_SITELIBDIR%%/markup/simple_markup/inline.rb
+%%RUBY_SITELIBDIR%%/markup/simple_markup/fragments.rb
+%%RUBY_SITELIBDIR%%/rdoc/code_objects.rb
+%%RUBY_SITELIBDIR%%/rdoc/html_generator.rb
+%%RUBY_SITELIBDIR%%/rdoc/html_pages.rb
+%%RUBY_SITELIBDIR%%/rdoc/options.rb
+%%RUBY_SITELIBDIR%%/rdoc/parse.rb
+%%RUBY_SITELIBDIR%%/rdoc/template.rb
+@dirrm %%RUBY_SITELIBDIR%%/markup/simple_markup
+@dirrm %%RUBY_SITELIBDIR%%/markup
+@dirrm %%RUBY_SITELIBDIR%%/rdoc
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/rdoc/markup/sample.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/rdoc/markup
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/rdoc
+%%PORTDOCS%%%%RUBY_DOCDIR%%/rdoc/ChangeLog
+%%PORTDOCS%%%%RUBY_DOCDIR%%/rdoc/README
+%%PORTDOCS%%%%RUBY_DOCDIR%%/rdoc/ToDo
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/rdoc