aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/silvercity/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-07-13 03:57:10 +0800
committerpav <pav@FreeBSD.org>2004-07-13 03:57:10 +0800
commitba99e073b62ab107e666331b853c12d93d145397 (patch)
tree23cc9854ec97eeec92b882b8f61781f96b7d2d07 /textproc/silvercity/Makefile
parent3f1bcae3b8ad4230998e910a2e76055759129d21 (diff)
downloadfreebsd-ports-gnome-ba99e073b62ab107e666331b853c12d93d145397.tar.gz
freebsd-ports-gnome-ba99e073b62ab107e666331b853c12d93d145397.tar.zst
freebsd-ports-gnome-ba99e073b62ab107e666331b853c12d93d145397.zip
- Update to 0.9.5
PR: ports/68921 Submitted by: Rui Lopes <rui@ruilopes.com>
Diffstat (limited to 'textproc/silvercity/Makefile')
-rw-r--r--textproc/silvercity/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/textproc/silvercity/Makefile b/textproc/silvercity/Makefile
index 8ff294600a09..ac8603f349f7 100644
--- a/textproc/silvercity/Makefile
+++ b/textproc/silvercity/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= silvercity
-PORTVERSION= 0.9.1
+PORTVERSION= 0.9.5
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,5 +18,12 @@ COMMENT= A lexing package for over 20 programming and markup langauges
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+USE_REINPLACE= yes
+
+# convert scripts EOL from DOS to NIX
+post-extract:
+.for i in ${WRKSRC}/PySilverCity/Scripts/*.py
+ @${REINPLACE_CMD} -e 's, $$,,' ${WRKSRC}/${i}
+.endfor
.include <bsd.port.mk>