aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/tclExpat
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-04 11:17:29 +0800
committeredwin <edwin@FreeBSD.org>2002-11-04 11:17:29 +0800
commit690d5eb77dfe38a8ae1bee0d3c26e53669d15fcd (patch)
tree2cdd4a2b9a4f727046ab669be268f18bab7f2d42 /textproc/tclExpat
parent266a6d44cdb9993738dffb2c3b706a6ca59eeb36 (diff)
downloadfreebsd-ports-gnome-690d5eb77dfe38a8ae1bee0d3c26e53669d15fcd.tar.gz
freebsd-ports-gnome-690d5eb77dfe38a8ae1bee0d3c26e53669d15fcd.tar.zst
freebsd-ports-gnome-690d5eb77dfe38a8ae1bee0d3c26e53669d15fcd.zip
PERL -> REINPLACE
and USE_PERL5 in some places Noticed by: bento
Diffstat (limited to 'textproc/tclExpat')
-rw-r--r--textproc/tclExpat/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/textproc/tclExpat/Makefile b/textproc/tclExpat/Makefile
index eed7a6e8aa85..5ceef9f244ad 100644
--- a/textproc/tclExpat/Makefile
+++ b/textproc/tclExpat/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= tcl${TCL_DVER}:${PORTSDIR}/lang/tcl${TCL_DVER} \
expat.4:${PORTSDIR}/textproc/expat2
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
TCL_VERSION= 8.3
TCL_DVER= ${TCL_VERSION:S/.//}
@@ -29,7 +30,7 @@ post-extract:
${RM} -rf ${WRKSRC}/expat
post-patch:
- ${PERL} -pi -e 's/TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION == 0/TCL_MAJOR_VERSION >= 8/;' \
+ ${REINPLACE_CMD} -e 's/TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION == 0/TCL_MAJOR_VERSION >= 8/;' \
-e 's/xmlparse.h/expat.h/;' ${WRKSRC}/tclexpat.c
test: build