aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/trang
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-29 22:11:39 +0800
committerPav Lucistnik <pav@FreeBSD.org>2004-02-29 22:11:39 +0800
commit8dbc357ecf177dd041151df4cf4795e2a1877c36 (patch)
treed1267e457ca79d7c34f6b442864c7728b9dbc2de /textproc/trang
parent189176da457b1acb98c4e900344e93d17d7f5132 (diff)
downloadfreebsd-ports-gnome-8dbc357ecf177dd041151df4cf4795e2a1877c36.tar.gz
freebsd-ports-gnome-8dbc357ecf177dd041151df4cf4795e2a1877c36.tar.zst
freebsd-ports-gnome-8dbc357ecf177dd041151df4cf4795e2a1877c36.zip
Add trang, convertor between different schema languages for XML. It
supports the following languages: * RELAX NG (XML syntax) * RELAX NG compact syntax * XML 1.0 DTDs * W3C XML Schema WWW: http://www.thaiopensource.com/relaxng/trang.html PR: ports/61706 Submitted by: Kimura Fuyuki <fuyuki@nigredo.org>
Diffstat (limited to 'textproc/trang')
-rw-r--r--textproc/trang/Makefile36
-rw-r--r--textproc/trang/distinfo1
-rw-r--r--textproc/trang/pkg-descr9
-rw-r--r--textproc/trang/pkg-plist2
4 files changed, 48 insertions, 0 deletions
diff --git a/textproc/trang/Makefile b/textproc/trang/Makefile
new file mode 100644
index 000000000000..2399e7143145
--- /dev/null
+++ b/textproc/trang/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Trang
+# Date created: 22 January 2004
+# Whom: Kimura Fuyuki <fuyuki@nigredo.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trang
+PORTVERSION= 2003.06.19
+CATEGORIES= textproc
+MASTER_SITES= http://www.thaiopensource.com/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
+
+MAINTAINER= fuyuki@nigredo.org
+COMMENT= Multi-format schema converter based on RELAX NG
+
+USE_ZIP= yes
+USE_JAVA= 1.4+
+PORTDOCS= copying.txt trang-manual.html
+
+NO_BUILD_DEPENDS_JAVA= yes
+
+do-build:
+ ${ECHO_CMD} '#/bin/sh' >${WRKSRC}/trang
+ ${ECHO_CMD} 'exec javavm -jar ${JAVAJARDIR}/trang.jar "$$@"' \
+ >>${WRKSRC}/trang
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/*.jar ${JAVAJARDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/trang ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/trang/distinfo b/textproc/trang/distinfo
new file mode 100644
index 000000000000..6d19723f68f9
--- /dev/null
+++ b/textproc/trang/distinfo
@@ -0,0 +1 @@
+MD5 (trang-20030619.zip) = 9611ea59fda0f62fecc4a5017a72984e
diff --git a/textproc/trang/pkg-descr b/textproc/trang/pkg-descr
new file mode 100644
index 000000000000..3f5aec1c901f
--- /dev/null
+++ b/textproc/trang/pkg-descr
@@ -0,0 +1,9 @@
+Trang converts between different schema languages for XML. It
+supports the following languages:
+
+ * RELAX NG (XML syntax)
+ * RELAX NG compact syntax
+ * XML 1.0 DTDs
+ * W3C XML Schema
+
+WWW: http://www.thaiopensource.com/relaxng/trang.html
diff --git a/textproc/trang/pkg-plist b/textproc/trang/pkg-plist
new file mode 100644
index 000000000000..251be9a58713
--- /dev/null
+++ b/textproc/trang/pkg-plist
@@ -0,0 +1,2 @@
+bin/trang
+share/java/classes/trang.jar