aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/uim-qt
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2006-04-21 05:55:37 +0800
committerlofi <lofi@FreeBSD.org>2006-04-21 05:55:37 +0800
commit3ca6a31c586fea7dd3bcbc2910ca80071f8c4928 (patch)
tree3631cb06d85e013becf0fa9c8291be5bc20610fa /textproc/uim-qt
parent5f79e7b1baf730aa009aa98fe193d62335f0cc0d (diff)
downloadfreebsd-ports-gnome-3ca6a31c586fea7dd3bcbc2910ca80071f8c4928.tar.gz
freebsd-ports-gnome-3ca6a31c586fea7dd3bcbc2910ca80071f8c4928.tar.zst
freebsd-ports-gnome-3ca6a31c586fea7dd3bcbc2910ca80071f8c4928.zip
Ports using Qt without setting USE_QT_VER need environment fixups.
Diffstat (limited to 'textproc/uim-qt')
-rw-r--r--textproc/uim-qt/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/textproc/uim-qt/Makefile b/textproc/uim-qt/Makefile
index b23df1126d56..0666f024eb2e 100644
--- a/textproc/uim-qt/Makefile
+++ b/textproc/uim-qt/Makefile
@@ -20,8 +20,16 @@ CONFIGURE_ENV= QTDIR=${X11BASE}/lib QTINCDIR=${X11BASE}/include \
UIM_SLAVE= yes
+# This is normally handled by defining USE_QT_VER ...
+
+.if defined(PACKAGE_BUILDING)
+TMPDIR?= /tmp
+MAKE_ENV+= TMPDIR="${TMPDIR}"
+CONFIGURE_ENV+= TMPDIR="${TMPDIR}"
+.endif
+
do-install:
- (cd ${WRKSRC}/qt && ${GMAKE} install)
- (cd ${WRKSRC}/helper && ${GMAKE} install)
+ (cd ${WRKSRC}/qt && ${SETENV} ${MAKE_ENV} ${GMAKE} install)
+ (cd ${WRKSRC}/helper && ${SETENV} ${MAKE_ENV} ${GMAKE} install)
.include "${MASTERDIR}/Makefile"