aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/uim
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2005-10-02 00:47:34 +0800
committernobutaka <nobutaka@FreeBSD.org>2005-10-02 00:47:34 +0800
commit79850525026793679a19f5572c052babb5b52f29 (patch)
tree4708a2c10090ca6fbc3c60b30d0ec857151be9b8 /textproc/uim
parent3acad6d76786535b687d7bf5cb8290a5ba9a3b62 (diff)
downloadfreebsd-ports-gnome-79850525026793679a19f5572c052babb5b52f29.tar.gz
freebsd-ports-gnome-79850525026793679a19f5572c052babb5b52f29.tar.zst
freebsd-ports-gnome-79850525026793679a19f5572c052babb5b52f29.zip
- Update to 0.9.1. This version fixes the privilege escalation vulnerability.
- Fix build error with WITH_SCIM on 4-stable. [*] Submitted by: mi <the_necronomicon@bigfoot.com> [*] Security: http://www.vuxml.org/freebsd/1e606080-3293-11da-ac91-020039488e34.html
Diffstat (limited to 'textproc/uim')
-rw-r--r--textproc/uim/Makefile3
-rw-r--r--textproc/uim/distinfo4
-rw-r--r--textproc/uim/files/patch-uim:scim.cpp11
3 files changed, 15 insertions, 3 deletions
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index 25f22430bf52..fb87fc11ea2d 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= uim
-PORTVERSION= 0.4.9
+PORTVERSION= 0.4.9.1
CATEGORIES= japanese x11
MASTER_SITES= http://uim.freedesktop.org/releases/
@@ -49,6 +49,7 @@ PLIST_SUB+= GNOME="@comment "
.endif
.if exists(${X11BASE}/bin/scim) || defined(WITH_SCIM)
+USE_GCC= 3.4
LIB_DEPENDS= scim-1.0.8:${PORTSDIR}/textproc/scim
CONFIGURE_ARGS+=--with-scim
PLIST_SUB+= SCIM=""
diff --git a/textproc/uim/distinfo b/textproc/uim/distinfo
index 142fd41b66eb..bf87071bc8d9 100644
--- a/textproc/uim/distinfo
+++ b/textproc/uim/distinfo
@@ -1,2 +1,2 @@
-MD5 (uim-0.4.9.tar.gz) = 2c3734ffc7e501d4b608eeb176298a06
-SIZE (uim-0.4.9.tar.gz) = 1603541
+MD5 (uim-0.4.9.1.tar.gz) = 0e2625cc926917d7864c4d0c341c535a
+SIZE (uim-0.4.9.1.tar.gz) = 1602849
diff --git a/textproc/uim/files/patch-uim:scim.cpp b/textproc/uim/files/patch-uim:scim.cpp
new file mode 100644
index 000000000000..863f6e36452f
--- /dev/null
+++ b/textproc/uim/files/patch-uim:scim.cpp
@@ -0,0 +1,11 @@
+--- uim/scim.cpp.orig Wed Sep 21 00:27:36 2005
++++ uim/scim.cpp Wed Sep 21 00:29:33 2005
+@@ -175,7 +175,7 @@
+ return uim_scm_f();
+ }
+
+- config = config_module->create_config("scim");
++ config = config_module->create_config();
+ if ( config.null() )
+ {
+ fprintf(stderr, "create_config failed\n");