aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/unroff
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-04-26 21:18:38 +0800
committervs <vs@FreeBSD.org>2005-04-26 21:18:38 +0800
commit6994cb685d9ed5ab3399e88d5650c236ffe63a46 (patch)
treecd9dd09468f7350a1765fd737dce3c392baad905 /textproc/unroff
parenta510e09307bf8a99e4dfb7c849a188018c3999e4 (diff)
downloadfreebsd-ports-gnome-6994cb685d9ed5ab3399e88d5650c236ffe63a46.tar.gz
freebsd-ports-gnome-6994cb685d9ed5ab3399e88d5650c236ffe63a46.tar.zst
freebsd-ports-gnome-6994cb685d9ed5ab3399e88d5650c236ffe63a46.zip
Use MAKE_ARGS instead of patch
Diffstat (limited to 'textproc/unroff')
-rw-r--r--textproc/unroff/Makefile5
-rw-r--r--textproc/unroff/files/patch-a43
2 files changed, 5 insertions, 43 deletions
diff --git a/textproc/unroff/Makefile b/textproc/unroff/Makefile
index 265d5b4f4e91..844bc2892a57 100644
--- a/textproc/unroff/Makefile
+++ b/textproc/unroff/Makefile
@@ -25,6 +25,11 @@ COMMENT= A programmable troff translator with backend for HTML
LIB_DEPENDS= elk.0:${PORTSDIR}/lang/elk
BUILD_WRKSRC= ${WRKSRC}/src
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DBSD" \
+ INCLUDE="-I${LOCALBASE}/include/elk" \
+ LIBS="-lm -lelk -L${LOCALBASE}/lib" \
+ ELKDIR="${LOCALBASE}/share/elk" \
+ DIR="${DATADIR}" ELK=""
MAN1= unroff.1 unroff-html.1 unroff-html-man.1 \
unroff-html-me.1 unroff-html-ms.1
diff --git a/textproc/unroff/files/patch-a b/textproc/unroff/files/patch-a
deleted file mode 100644
index ec6d4a526513..000000000000
--- a/textproc/unroff/files/patch-a
+++ /dev/null
@@ -1,43 +0,0 @@
---- src/Makefile.orig Wed Aug 23 21:12:48 1995
-+++ src/Makefile Thu Nov 6 22:21:29 2003
-@@ -1,24 +1,24 @@
- # $Revision: 1.12 $
-
- ### You need a C compiler that compiles ANSI C code.
--CC = gcc
--CFLAGS = -Wall -pedantic -O
-+#CC = gcc
-+CFLAGS += -DBSD
-
- ### If you need additional linker flags add them here.
- LDFLAGS =
-
- ### The directory where the Elk installation resides on your system.
--ELKDIR = /usr/elk
-+ELKDIR = ${PREFIX}/share/elk
-
- ### Additional libraries. You may want to insert the output of the
- ### shell-script $(ELKDIR)/lib/ldflags here.
--LIBS = -lm
-+LIBS = -lm -lelk -L${LOCALBASE}/lib
-
- ### The makedepend program (it's usually installed with the X11 binaries).
- MAKEDEP = makedepend
-
- ### The directory under which you will install the Scheme files.
--DIR = /usr/local/lib/unroff
-+DIR = ${PREFIX}/share/unroff
-
- ### The default output format.
- FORMAT = html
-@@ -30,8 +30,8 @@
- ### -------------------------------------------------------------------------
-
- SHELL = /bin/sh
--INCLUDE = -I$(ELKDIR)/include
--ELK = $(ELKDIR)/lib/module.o
-+INCLUDE = -I${LOCALBASE}/include/elk
-+#ELK = $(ELKDIR)/lib/module.o
- DEFS = -DDEFAULT_DIR=\"$(DIR)\" -DDEFAULT_FORMAT=\"$(FORMAT)\"
- CTAGS = ctags -t -w
-