aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xalan-c
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2013-10-21 13:59:37 +0800
committerdelphij <delphij@FreeBSD.org>2013-10-21 13:59:37 +0800
commit0d2e6c061f3ed5f004c3d58afdf1f33363dbeca8 (patch)
tree27e2ef75c8fd6f557580a69ddcedbdab25805948 /textproc/xalan-c
parent5add4981e8b1fe389615dfe1a4a3ffbce81d3d10 (diff)
downloadfreebsd-ports-gnome-0d2e6c061f3ed5f004c3d58afdf1f33363dbeca8.tar.gz
freebsd-ports-gnome-0d2e6c061f3ed5f004c3d58afdf1f33363dbeca8.tar.zst
freebsd-ports-gnome-0d2e6c061f3ed5f004c3d58afdf1f33363dbeca8.zip
Update to 1.11.
PR: ports/173998 Submitted by: Thorsten Nicolaus <freebsd ite-nic de>
Diffstat (limited to 'textproc/xalan-c')
-rw-r--r--textproc/xalan-c/Makefile75
-rw-r--r--textproc/xalan-c/Makefile.inc-sample-src2
-rw-r--r--textproc/xalan-c/distinfo8
-rw-r--r--textproc/xalan-c/files/patch-ab26
-rw-r--r--textproc/xalan-c/pkg-descr4
-rw-r--r--textproc/xalan-c/pkg-plist33
6 files changed, 33 insertions, 115 deletions
diff --git a/textproc/xalan-c/Makefile b/textproc/xalan-c/Makefile
index c0c210bd5af1..ec105376afd3 100644
--- a/textproc/xalan-c/Makefile
+++ b/textproc/xalan-c/Makefile
@@ -2,25 +2,17 @@
# $FreeBSD$
PORTNAME= xalan-c
-PORTVERSION= 1.10.0
-PORTREVISION= 1
+PORTVERSION= 1.11
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_APACHE_XML:S/$/:msax,docs/}
-MASTER_SITE_SUBDIR= ${PORTNAME}/source/:msax ${PORTNAME}/docs/:docs
-DISTNAME= Xalan-C_${PORTVERSION:S/./_/g}-src:msax
-DISTFILES+= Xalan-C_${PORTVERSION:S/./_/g}-src${EXTRACT_SUFX}:msax
+MASTER_SITES= ${MASTER_SITE_APACHE:S/$/:msax,docs/}
+MASTER_SITE_SUBDIR= xalan/${PORTNAME}/sources/:msax xalan/${PORTNAME}/docs/:docs
+DISTNAME= xalan_c-${PORTVERSION}-src:msax
+DISTFILES+= xalan_c-${PORTVERSION}-src${EXTRACT_SUFX}:msax
MAINTAINER= ports@FreeBSD.org
COMMENT= XSLT processor from the Apache XML Project
-OPTIONS_DEFINE= DEBUG DOCS EXAMPLES TRANSCODER_ICU
-OPTIONS_SINGLE= LSYS
-OPTIONS_SINGLE_LSYS= INMEMLOC ICULOC NLSLOC
-OPTIONS_DEFAULT= INMEMLOC
-INMEMLOC_DESC= Use inmem locale system
-ICULOC_DESC= Use ICU locale system
-NLSLOC_DESC= Use nls locale system
-TRANSCODER_ICU_DESC= Use ICU transcoder (if used in xerces-c2)
+OPTIONS_DEFINE= DEBUG DOCS EXAMPLES
NO_STAGE= yes
.include <bsd.port.options.mk>
@@ -32,23 +24,24 @@ PKGNAMESUFFIX+= -debug
.endif
.if ${PORT_OPTIONS:MDOCS}
DISTFILES+= ${DOCS_TARBALL}:docs
-EXTRACT_ONLY= Xalan-C_${PORTVERSION:S/./_/g}-src${EXTRACT_SUFX}
-DOCS_TARBALL= Xalan-C_${PORTVERSION:S/./_/g}-docs${EXTRACT_SUFX}
+EXTRACT_ONLY= xalan_c-${PORTVERSION}-src${EXTRACT_SUFX}
+DOCS_TARBALL= xalan_c-${PORTVERSION}-docs-html-nograf${EXTRACT_SUFX}
.endif
-# we need the _extracted_ xerces-c2 port sources to build this one
+# we need the _extracted_ xerces-c3 port sources to build this one
# (installed version of port is enough)
-XERCESC_LIB_VER?= 27
-LIB_DEPENDS+= xerces-c.${XERCESC_LIB_VER}:${PORTSDIR}/textproc/xerces-c2
+XERCESC_LIB_VER?= 3
+LIB_DEPENDS+= xerces-c.${XERCESC_LIB_VER}:${PORTSDIR}/textproc/xerces-c3
XERCESCROOT?= ${LOCALBASE}
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/xml-xalan/c
+WRKSRC= ${WRKDIR}/xalan-c-${PORTVERSION}/c
USE_GMAKE= yes
MAKE_ENV+= XALANCROOT=${WRKSRC}
MAKE_ENV+= XERCESCROOT=${XERCESCROOT}
+MAKE_JOBS_UNSAFE=
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= runConfigure
@@ -59,40 +52,7 @@ CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
CONFIGURE_ARGS+= -p freebsd -c ${CC} -x ${CXX} -l ${PTHREAD_LIBS} \
-z ${EXTRA_CFLAGS} -I${LOCALBASE}/include -C --prefix=${PREFIX}
-.if ${PORT_OPTIONS:MICULOC}
-CONFIGURE_ARGS+= -m icu
-PLIST_SUB+= LOCALSYS_INMEMLOC=""
-PLIST_SUB+= LOCALSYS_NLSLOC="@comment "
-PORT_OPTIONS+= TRANSCODER_ICU
-.endif
-
-.if ${PORT_OPTIONS:MNLSLOC}
-CONFIGURE_ARGS+= -m nls
-PLIST_SUB+= LOCALSYS_INMEMLOC="@comment "
-PLIST_SUB+= LOCALSYS_NLSLOC=""
-.endif
-
-.if ${PORT_OPTIONS:MINMEMLOC}
CONFIGURE_ARGS+= -m inmem
-PLIST_SUB+= LOCALSYS_INMEMLOC=""
-PLIST_SUB+= LOCALSYS_NLSLOC="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MTRANSCODER_ICU}
-PKGNAMESUFFIX+= -icu
-LIB_DEPENDS+= icuuc:${PORTSDIR}/devel/icu
-ICUROOT?= ${LOCALBASE}
-CONFIGURE_ENV+= XALAN_USE_ICU=1
-CONFIGURE_ENV+= ICUROOT=${ICUROOT}
-CONFIGURE_ARGS+= -t icu
-MAKE_ENV+= XALAN_USE_ICU=1
-MAKE_ENV+= ICUROOT=${ICUROOT}
-PLIST_SUB+= ICUDEP=""
-.else
-USES+= iconv
-LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
-PLIST_SUB+= ICUDEP="@comment "
-.endif
.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= -d
@@ -108,8 +68,8 @@ SAMPLES_CONFIG_ARGS+= -b 64
.endif
XALANC_LIB_VERSION= ${PORTVERSION:S/.//:R}
-XALANC_LIB= libxalan-c.so.${PORTVERSION:S/.//}
-XALANMSG_LIB= libxalanMsg.so.${PORTVERSION:S/.//}
+XALANC_LIB= libxalan-c.so.${PORTVERSION:S/.//}.0
+XALANMSG_LIB= libxalanMsg.so.${PORTVERSION:S/.//}.0
PLIST_SUB+= XALANC_LIB=${XALANC_LIB} \
XALANMSG_LIB=${XALANMSG_LIB} \
XALANC_LIB_VERSION=${XALANC_LIB_VERSION}
@@ -155,8 +115,9 @@ post-install:
cd ${DOCSDIR} && \
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${_DISTDIR}/${DOCS_TARBALL} ${EXTRACT_AFTER_ARGS} && \
- ${MV} ${DOCSDIR}/Xalan-C_${PORTVERSION:S/./_/g}-docs/* ${DOCSDIR} && \
- ${RMDIR} ${DOCSDIR}/Xalan-C_${PORTVERSION:S/./_/g}-docs
+ ${MV} ${DOCSDIR}/docs/xalan-c/* ${DOCSDIR} && \
+ ${RMDIR} ${DOCSDIR}/docs/xalan-c && \
+ ${RMDIR} ${DOCSDIR}/docs
.endif
post-clean:
diff --git a/textproc/xalan-c/Makefile.inc-sample-src b/textproc/xalan-c/Makefile.inc-sample-src
index 3a24aa83cea6..f80689e8f027 100644
--- a/textproc/xalan-c/Makefile.inc-sample-src
+++ b/textproc/xalan-c/Makefile.inc-sample-src
@@ -89,7 +89,7 @@
${MKDIR} ${EXAMPLESDIR}/UseStylesheetParam
${INSTALL_DATA} \
${WRKSRC}/samples/UseStylesheetParam/foo.xml \
- ${WRKSRC}/samples/UseStylesheetParam/foo.xsl \
+ ${WRKSRC}/samples/UseStylesheetParam/foo.xslt \
${WRKSRC}/samples/UseStylesheetParam/UseStylesheetParam.cpp \
${EXAMPLESDIR}/UseStylesheetParam/
${MKDIR} ${EXAMPLESDIR}/XalanTransform
diff --git a/textproc/xalan-c/distinfo b/textproc/xalan-c/distinfo
index 85faa5be963e..40d98032dc81 100644
--- a/textproc/xalan-c/distinfo
+++ b/textproc/xalan-c/distinfo
@@ -1,4 +1,4 @@
-SHA256 (Xalan-C_1_10_0-src.tar.gz) = 40797957fb22797894d33a2fa0e01e3b6cc509fb89bb772c0e835ae840714cfd
-SIZE (Xalan-C_1_10_0-src.tar.gz) = 1554940
-SHA256 (Xalan-C_1_10_0-docs.tar.gz) = 885b8334a651a26fdbd6f23ac99579a900f44edb4eb4a11e8154953c6b74debb
-SIZE (Xalan-C_1_10_0-docs.tar.gz) = 14722948
+SHA256 (xalan_c-1.11-src.tar.gz) = 4f5e7f75733d72e30a2165f9fdb9371831cf6ff0d1997b1fb64cdd5dc2126a28
+SIZE (xalan_c-1.11-src.tar.gz) = 1689986
+SHA256 (xalan_c-1.11-docs-html-nograf.tar.gz) = fd272adcdd161c4580d63437dcd7f11121d74dde8f793e2947cc3449a66eaa16
+SIZE (xalan_c-1.11-docs-html-nograf.tar.gz) = 5488363
diff --git a/textproc/xalan-c/files/patch-ab b/textproc/xalan-c/files/patch-ab
deleted file mode 100644
index 41f310e184fb..000000000000
--- a/textproc/xalan-c/files/patch-ab
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/xalanc/Makefile.in.orig Mon Mar 7 17:31:00 2005
-+++ src/xalanc/Makefile.in Mon Mar 7 17:31:57 2005
-@@ -259,22 +259,10 @@ endif ## OS390
- $(MKINSTALLDIRS) $(DESTDIR)/$(includedir)/xalanc
- for hdir in $(ALL_HEADERS_DIRS); do \
- $(MKINSTALLDIRS) $(DESTDIR)/$(includedir)/xalanc/$$hdir; \
-- cp $(XALANCROOT)/src/xalanc/$$hdir/*.h* \
-+ $(INSTALL_DATA) $(XALANCROOT)/src/xalanc/$$hdir/*.h* \
- $(DESTDIR)/$(includedir)/xalanc/$$hdir \
- 2> /dev/null; \
- done
--ifdef XALAN_USE_ICU
-- $(INSTALL_PROGRAM) $(ICUROOT)/lib/$(ICU_LIBI18N_LIB) \
-- $(DESTDIR)/$(libdir)
-- ifneq ($PLATFORM), OS390)
-- rm -f $(DESTIDR)/$(libdir)/$(ICU_LIBI18N_LINK_NAME) && \
-- $(LN) -fs $(ICU_LIBI18N_LIB) \
-- $(DESTDIR)/$(libdir)/$(ICU_LIBI18N_LINK_NAME)
-- rm -f $(DESTDIR)/$(libdir)/$(ICU_LIBI18N_SO_NAME) && \
-- $(LN) -fs $(ICU_LIBI18N_LIB) \
-- $(DESTDIR)/$(libdir)/$(ICU_LIBI18N_SO_NAME)
-- endif ## OS390
--endif
-
- clean: prepare doClean
-
diff --git a/textproc/xalan-c/pkg-descr b/textproc/xalan-c/pkg-descr
index a3b764429679..2a79e39dbfbc 100644
--- a/textproc/xalan-c/pkg-descr
+++ b/textproc/xalan-c/pkg-descr
@@ -1,5 +1,5 @@
Xalan-C++ is an implementation of XSL Transformations (XSLT) and
XML Path Language (XPath).
-It works hand in hand with the XML parser Xerces-C++ version 2.
+It works hand in hand with the XML parser Xerces-C++ version 3.
-WWW: http://xml.apache.org/xalan-c/index.html
+WWW: http://xalan.apache.org/xalan-c/index.html
diff --git a/textproc/xalan-c/pkg-plist b/textproc/xalan-c/pkg-plist
index e0a854c6d2da..f927f6acdf8a 100644
--- a/textproc/xalan-c/pkg-plist
+++ b/textproc/xalan-c/pkg-plist
@@ -11,14 +11,6 @@ include/xalanc/Harness/XalanDiagnosticMemoryManager.hpp
include/xalanc/Harness/XalanFileUtility.hpp
include/xalanc/Harness/XalanHarnessDefinitions.hpp
include/xalanc/Harness/XalanXMLFileReporter.hpp
-%%ICUDEP%%include/xalanc/ICUBridge/ICUBridge.hpp
-%%ICUDEP%%include/xalanc/ICUBridge/ICUBridgeCleanup.hpp
-%%ICUDEP%%include/xalanc/ICUBridge/ICUBridgeCollationCompareFunctor.hpp
-%%ICUDEP%%include/xalanc/ICUBridge/ICUBridgeCollationCompareFunctorImpl.hpp
-%%ICUDEP%%include/xalanc/ICUBridge/ICUBridgeDefinitions.hpp
-%%ICUDEP%%include/xalanc/ICUBridge/ICUFormatNumberFunctor.hpp
-%%ICUDEP%%include/xalanc/ICUBridge/ICUXalanNumberFormatFactory.hpp
-%%ICUDEP%%include/xalanc/ICUBridge/ICUXalanNumberFormatProxy.hpp
include/xalanc/Include/AIXDefinitions.hpp
include/xalanc/Include/GCCDefinitions.hpp
include/xalanc/Include/HPUXDefinitions.hpp
@@ -35,8 +27,6 @@ include/xalanc/Include/XalanDeque.hpp
include/xalanc/Include/XalanList.hpp
include/xalanc/Include/XalanMap.hpp
include/xalanc/Include/XalanMemMgrAutoPtr.hpp
-include/xalanc/Include/XalanMemMgrHelper.hpp
-include/xalanc/Include/XalanMemMngArrayAllocate.hpp
include/xalanc/Include/XalanMemoryManagement.hpp
include/xalanc/Include/XalanObjectCache.hpp
include/xalanc/Include/XalanObjectStackCache.hpp
@@ -63,7 +53,7 @@ include/xalanc/PlatformSupport/PlatformSupportDefinitions.hpp
include/xalanc/PlatformSupport/PlatformSupportInit.hpp
include/xalanc/PlatformSupport/PrefixResolver.hpp
include/xalanc/PlatformSupport/PrintWriter.hpp
-include/xalanc/PlatformSupport/Resettable.hpp
+include/xalanc/PlatformSupport/ProblemListenerBase.hpp
include/xalanc/PlatformSupport/ReusableArenaAllocator.hpp
include/xalanc/PlatformSupport/ReusableArenaBlock.hpp
include/xalanc/PlatformSupport/StdBinInputStream.hpp
@@ -104,7 +94,6 @@ include/xalanc/PlatformSupport/XalanTranscodingServices.hpp
include/xalanc/PlatformSupport/XalanUTF16Transcoder.hpp
include/xalanc/PlatformSupport/XalanUnicode.hpp
include/xalanc/PlatformSupport/XalanXMLChar.hpp
-include/xalanc/XMLSupport/FormatterToDOM.hpp
include/xalanc/XMLSupport/FormatterToHTML.hpp
include/xalanc/XMLSupport/FormatterToNull.hpp
include/xalanc/XMLSupport/FormatterToText.hpp
@@ -150,7 +139,6 @@ include/xalanc/XPath/XNodeSetBase.hpp
include/xalanc/XPath/XNodeSetNodeProxy.hpp
include/xalanc/XPath/XNodeSetNodeProxyAllocator.hpp
include/xalanc/XPath/XNodeSetResultTreeFragProxy.hpp
-include/xalanc/XPath/XNull.hpp
include/xalanc/XPath/XNumber.hpp
include/xalanc/XPath/XNumberAllocator.hpp
include/xalanc/XPath/XNumberBase.hpp
@@ -180,7 +168,6 @@ include/xalanc/XPath/XPathInit.hpp
include/xalanc/XPath/XPathParserException.hpp
include/xalanc/XPath/XPathProcessor.hpp
include/xalanc/XPath/XPathProcessorImpl.hpp
-include/xalanc/XPath/XSpan.hpp
include/xalanc/XPath/XString.hpp
include/xalanc/XPath/XStringAdapter.hpp
include/xalanc/XPath/XStringAdapterAllocator.hpp
@@ -306,6 +293,7 @@ include/xalanc/XSLT/XalanElemVariableAllocator.hpp
include/xalanc/XSLT/XalanMatchPatternData.hpp
include/xalanc/XSLT/XalanMatchPatternDataAllocator.hpp
include/xalanc/XSLT/XalanNumberingResourceBundle.hpp
+include/xalanc/XSLT/XalanParamHolder.hpp
include/xalanc/XSLT/XalanSourceTreeDocumentAllocator.hpp
include/xalanc/XSLT/XalanSourceTreeDocumentFragmentAllocator.hpp
include/xalanc/XSLT/XalanSpaceNodeTester.hpp
@@ -457,7 +445,6 @@ include/xalanc/XercesParserLiaison/XercesWrapperToXalanNodeMap.hpp
include/xalanc/XercesParserLiaison/XercesWrapperTypes.hpp
@dirrm include/xalanc/DOMSupport
@dirrm include/xalanc/Harness
-%%ICUDEP%%@dirrm include/xalanc/ICUBridge
@dirrm include/xalanc/Include
@dirrm include/xalanc/PlatformSupport
@comment @dirrm include/xalanc/TestXPath
@@ -476,15 +463,11 @@ include/xalanc/XercesParserLiaison/XercesWrapperTypes.hpp
@dirrm include/xalanc/XercesParserLiaison
@dirrm include/xalanc
bin/Xalan
-%%LOCALSYS_NLSLOC%%lib/nls/msg/en_US/XalanMsg_en_US.cat
-%%LOCALSYS_NLSLOC%%@dirrm lib/nls/msg/en_US
-%%LOCALSYS_NLSLOC%%@dirrm lib/nls/msg
-%%LOCALSYS_NLSLOC%%@dirrm lib/nls
-%%LOCALSYS_INMEMLOC%%lib/%%XALANMSG_LIB%%
-%%LOCALSYS_INMEMLOC%%@exec ln -fs %%XALANMSG_LIB%% %D/lib/libxalanMsg.so
-%%LOCALSYS_INMEMLOC%%@exec ln -fs %%XALANMSG_LIB%% %D/lib/libxalanMsg.so.%%XALANC_LIB_VERSION%%
-%%LOCALSYS_INMEMLOC%%@unexec if test -L %D/lib/libxalanMsg.so; then rm -f %D/lib/libxalanMsg.so; fi
-%%LOCALSYS_INMEMLOC%%@unexec if test -L %D/lib/libxalanMsg.so.%%XALANC_LIB_VERSION%%; then rm -f %D/lib/libxalanMsg.so.%%XALANC_LIB_VERSION%%; fi
+lib/%%XALANMSG_LIB%%
+@exec ln -fs %%XALANMSG_LIB%% %D/lib/libxalanMsg.so
+@exec ln -fs %%XALANMSG_LIB%% %D/lib/libxalanMsg.so.%%XALANC_LIB_VERSION%%
+@unexec if test -L %D/lib/libxalanMsg.so; then rm -f %D/lib/libxalanMsg.so; fi
+@unexec if test -L %D/lib/libxalanMsg.so.%%XALANC_LIB_VERSION%%; then rm -f %D/lib/libxalanMsg.so.%%XALANC_LIB_VERSION%%; fi
lib/%%XALANC_LIB%%
@exec ln -fs %%XALANC_LIB%% %D/lib/libxalan-c.so
@exec ln -fs %%XALANC_LIB%% %D/lib/libxalan-c.so.%%XALANC_LIB_VERSION%%
@@ -527,7 +510,7 @@ lib/%%XALANC_LIB%%
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/XPathWrapper/XPathWrapper.hpp
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/XPathWrapper
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/foo.xml
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/foo.xsl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/foo.xslt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/UseStylesheetParam/UseStylesheetParam.cpp
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/UseStylesheetParam
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/TransformToXercesDOM/birds.xml