aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xml-commons
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-02-13 19:27:29 +0800
committermiwi <miwi@FreeBSD.org>2010-02-13 19:27:29 +0800
commit910b175f0a2eca69887549705b9f2f3fb42551bc (patch)
treeea9b5cfb9e3a90f6fdc77599b2b0ab3af478bd79 /textproc/xml-commons
parente3c52dc7cf2fbd87fd42130b8228a2d5a0e81691 (diff)
downloadfreebsd-ports-gnome-910b175f0a2eca69887549705b9f2f3fb42551bc.tar.gz
freebsd-ports-gnome-910b175f0a2eca69887549705b9f2f3fb42551bc.tar.zst
freebsd-ports-gnome-910b175f0a2eca69887549705b9f2f3fb42551bc.zip
xml-commons is focussed on common code and guidelines for xml projects. The
first focus will be to organize and have common packaging for the various externally-defined standards code relating to XML - things like the DOM, SAX, and JAXP interfaces. As the xml-commons community forms, we also hope to serve as a holding area for other common xml-related utilities and code, and to help promulgate common packaging, testing, documentation, and other guidelines across all xml.apache.org subprojects. WWW: http://xml.apache.org/commons/ PR: ports/143863 Submitted by: Rob Farmer <rfarmer@predatorlabs.net>
Diffstat (limited to 'textproc/xml-commons')
-rw-r--r--textproc/xml-commons/Makefile30
-rw-r--r--textproc/xml-commons/distinfo3
-rw-r--r--textproc/xml-commons/pkg-descr11
3 files changed, 44 insertions, 0 deletions
diff --git a/textproc/xml-commons/Makefile b/textproc/xml-commons/Makefile
new file mode 100644
index 000000000000..bd400edb32a8
--- /dev/null
+++ b/textproc/xml-commons/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xml-commons
+# Date created: 11 February 2010
+# Whom: rfarmer@predatorlabs.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= xml-commons
+PORTVERSION= 1.4.01
+CATEGORIES= textproc java
+MASTER_SITES= APACHE/xml/commons
+DISTNAME= ${PORTNAME}-external-${PORTVERSION}
+EXTRACT_SUFX= -bin.tar.gz
+
+MAINTAINER= rfarmer@predatorlabs.net
+COMMENT= Provides common XML code for Apache projects
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+JAVA_RUN= yes
+NO_BUILD= yes
+
+PLIST_FILES= %%JAVAJARDIR%%/xml-apis-ext.jar \
+ %%JAVAJARDIR%%/xml-apis.jar
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/xml-apis-ext.jar ${JAVAJARDIR}
+ ${INSTALL_DATA} ${WRKSRC}/xml-apis.jar ${JAVAJARDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/xml-commons/distinfo b/textproc/xml-commons/distinfo
new file mode 100644
index 000000000000..43720a526a6a
--- /dev/null
+++ b/textproc/xml-commons/distinfo
@@ -0,0 +1,3 @@
+MD5 (xml-commons-external-1.4.01-bin.tar.gz) = 8bd2f6634886c9f5dc88fb3e9181d714
+SHA256 (xml-commons-external-1.4.01-bin.tar.gz) = a22c64d0a95d09c74ba322196b3eac5eab38e2896ecb95056dab7eeaff2daaaf
+SIZE (xml-commons-external-1.4.01-bin.tar.gz) = 1610345
diff --git a/textproc/xml-commons/pkg-descr b/textproc/xml-commons/pkg-descr
new file mode 100644
index 000000000000..499fd4bfb51c
--- /dev/null
+++ b/textproc/xml-commons/pkg-descr
@@ -0,0 +1,11 @@
+xml-commons is focussed on common code and guidelines for xml projects. The
+first focus will be to organize and have common packaging for the various
+externally-defined standards code relating to XML - things like the DOM,
+SAX, and JAXP interfaces.
+
+As the xml-commons community forms, we also hope to serve as a holding area
+for other common xml-related utilities and code, and to help promulgate
+common packaging, testing, documentation, and other guidelines across all
+xml.apache.org subprojects.
+
+WWW: http://xml.apache.org/commons/