aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xslint/Makefile
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-07-14 00:24:33 +0800
committervs <vs@FreeBSD.org>2004-07-14 00:24:33 +0800
commit9321a0cb9489ab8c51059b23fd87b8e83c4cecec (patch)
tree1b4e68b83c68f2469b29c1c24061b5b0c6fc4085 /textproc/xslint/Makefile
parent14cf9a4437814edf4f7148ec85ad55e85c0be70c (diff)
downloadfreebsd-ports-gnome-9321a0cb9489ab8c51059b23fd87b8e83c4cecec.tar.gz
freebsd-ports-gnome-9321a0cb9489ab8c51059b23fd87b8e83c4cecec.tar.zst
freebsd-ports-gnome-9321a0cb9489ab8c51059b23fd87b8e83c4cecec.zip
- Fix MASTER_SITE (s/xsl/xml/)
- Chase distinfo: Minor reroll - Packaging: Drop pkg-plist, use REINPLACE instead of PERL
Diffstat (limited to 'textproc/xslint/Makefile')
-rw-r--r--textproc/xslint/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/textproc/xslint/Makefile b/textproc/xslint/Makefile
index 134b3ef32b8c..b4774ca8569f 100644
--- a/textproc/xslint/Makefile
+++ b/textproc/xslint/Makefile
@@ -8,7 +8,7 @@
PORTNAME= xslint
PORTVERSION= 005
CATEGORIES= textproc perl5
-MASTER_SITES= http://nwalsh.com/xsl/xslint/
+MASTER_SITES= http://nwalsh.com/xml/xslint/
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -16,22 +16,26 @@ COMMENT= XSL(T) stylesheet checker
RUN_DEPENDS= ${SITE_PERL}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM
-USE_PERL5= yes
USE_ZIP= yes
+USE_REINPLACE= yes
+USE_PERL5_RUN= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.05
NO_BUILD= yes
+PLIST_FILES= bin/xslint
+PORTDOCS= README xslint.html xslint.xml
+
post-patch:
- ${PERL5} -pi -e 's,/usr/local/bin/perl5,${PERL},' ${WRKSRC}/${PORTNAME}.pl
+ @${REINPLACE_CMD} -e 's,/usr/bin/perl,${PERL},' ${WRKSRC}/${PORTNAME}.pl
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/xslint.html ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/xslint.xml ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+. for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+. endfor
.endif
.include <bsd.port.mk>