aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xstream/Makefile
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2014-05-13 20:40:21 +0800
committerale <ale@FreeBSD.org>2014-05-13 20:40:21 +0800
commit163f9510ce9728ab3bb68252a319a76d68f3b3e0 (patch)
tree9db24337252dd08bc8ec1e399f8d9c95208a4a9e /textproc/xstream/Makefile
parentebf1b3772affdf7955a3e28183857458ba6f6002 (diff)
downloadfreebsd-ports-gnome-163f9510ce9728ab3bb68252a319a76d68f3b3e0.tar.gz
freebsd-ports-gnome-163f9510ce9728ab3bb68252a319a76d68f3b3e0.tar.zst
freebsd-ports-gnome-163f9510ce9728ab3bb68252a319a76d68f3b3e0.zip
Stagify.
Diffstat (limited to 'textproc/xstream/Makefile')
-rw-r--r--textproc/xstream/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/textproc/xstream/Makefile b/textproc/xstream/Makefile
index 85f1c2b8a120..0e35b69bfb7f 100644
--- a/textproc/xstream/Makefile
+++ b/textproc/xstream/Makefile
@@ -10,9 +10,11 @@ DISTFILES= ${PORTNAME}-distribution-${PORTVERSION}-bin${EXTRACT_SUFX}
MAINTAINER= ale@FreeBSD.org
COMMENT= A simple library to serialize Java objects to XML
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+OPTIONS_DEFINE= DOCS
+
USES= zip
USE_JAVA= yes
NO_BUILD= yes
@@ -21,15 +23,17 @@ PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
PORTDOCS= *
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
do-install:
@${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
- @${INSTALL_DATA} ${WRKSRC}/lib/${DISTNAME}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${INSTALL_DATA} ${WRKSRC}/lib/${DISTNAME}.jar \
+ ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
@${ECHO_MSG} " [ DONE ]"
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}/
@${ECHO_MSG} " [ DONE ]"
.endif