aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/xxdiff
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2016-01-22 20:01:32 +0800
committerdanfe <danfe@FreeBSD.org>2016-01-22 20:01:32 +0800
commit47b06fa57bd7fa1468e776960feca6bce8cd76ef (patch)
tree10e8d6b7c57d7e0493fcc5334678917c030e9449 /textproc/xxdiff
parent3ec3a672fcf148e49edbb84ef41b92a467712b4f (diff)
downloadfreebsd-ports-gnome-47b06fa57bd7fa1468e776960feca6bce8cd76ef.tar.gz
freebsd-ports-gnome-47b06fa57bd7fa1468e776960feca6bce8cd76ef.tar.zst
freebsd-ports-gnome-47b06fa57bd7fa1468e776960feca6bce8cd76ef.zip
Resurrect `textproc/xxdiff' and `textproc/xxdiff-scripts' which were removed
from the tree when Qt 3.x had reached EoL. Version 4.0 adds support for Qt4 now and thus allows to revive the port(s). While here, modernize Makefiles, define LICENSE (GPLv2), clean up dependencies, and augment port description. PR: 198025
Diffstat (limited to 'textproc/xxdiff')
-rw-r--r--textproc/xxdiff/Makefile47
-rw-r--r--textproc/xxdiff/distinfo2
-rw-r--r--textproc/xxdiff/pkg-descr22
3 files changed, 71 insertions, 0 deletions
diff --git a/textproc/xxdiff/Makefile b/textproc/xxdiff/Makefile
new file mode 100644
index 000000000000..962917f3f9c9
--- /dev/null
+++ b/textproc/xxdiff/Makefile
@@ -0,0 +1,47 @@
+# Created by: Pete Fritchman <petef@databits.net>
+# $FreeBSD$
+
+PORTNAME= xxdiff
+PORTVERSION= 4.0
+CATEGORIES= textproc
+MASTER_SITES= SF
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Graphical file and directories comparator and merge tool
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= bison gmake tar:bz2
+USE_QT4= gui moc_build qmake_build uic_build
+
+BUILD_WRKSRC= ${WRKSRC}/src
+
+PLIST_FILES= bin/xxdiff
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.pre.mk>
+
+# base flex(1) v2.5.4 is not sufficient
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000033
+BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+
+post-patch:
+ @${REINPLACE_CMD} -e 's!flex!${LOCALBASE}/bin/&!' \
+ ${BUILD_WRKSRC}/xxdiff.pro
+.endif
+
+pre-build:
+ @(cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} QMAKE=${QMAKE} \
+ ${MAKE_CMD} -f Makefile.bootstrap ${MAKE_ARGS} Makefile)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/xxdiff ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "${PORTDOCS} ! -name Makefile" \
+ ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/textproc/xxdiff/distinfo b/textproc/xxdiff/distinfo
new file mode 100644
index 000000000000..b13cc70234aa
--- /dev/null
+++ b/textproc/xxdiff/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xxdiff-4.0.tar.bz2) = 91501544e82bc89983d07eeb086419645fbfa78fc906b50ff7ab6cdf39431330
+SIZE (xxdiff-4.0.tar.bz2) = 1768460
diff --git a/textproc/xxdiff/pkg-descr b/textproc/xxdiff/pkg-descr
new file mode 100644
index 000000000000..612c5c1b6376
--- /dev/null
+++ b/textproc/xxdiff/pkg-descr
@@ -0,0 +1,22 @@
+xxdiff is a graphical tool for viewing the differences between two or three
+files, or between two directories, and can produce a merged version thereof.
+
+Some of its features:
+
+ - Comparing two files, three files, or two directories (shallow and
+ recursive)
+ - Horizontal diffs highlighting
+ - Files can be merged interactively and resulting output visualized
+ and saved
+ - Has features to assist in performing merge reviews/policing
+ - Can unmerge CVS conflicts in automatically merged file and display
+ them as two files, to help resolve conflicts
+ - Uses external diff program to compute differences: works with GNU
+ diff, SGI diff and ClearCase's cleardiff, and any other diff whose
+ output is similar to those
+ - Fully customizable with a resource file
+ - Look-and-feel similar to Rudy Wortel's/SGI xdiff; it is desktop
+ agnostic (i.e. will work equally well with KDE or GNOME)
+ - Features and output that ease integration with scripts
+
+WWW: http://furius.ca/xxdiff/