aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2014-07-22 04:36:56 +0800
committerskreuzer <skreuzer@FreeBSD.org>2014-07-22 04:36:56 +0800
commitdd1d4119b52671b642b5301b2ec2d075d0e04754 (patch)
tree0ced66d678f75feb4d802a163c92b7d5d3b5f13f /textproc
parentbab244521a1e7412d82a4a639ed63f1faa35dd09 (diff)
downloadfreebsd-ports-gnome-dd1d4119b52671b642b5301b2ec2d075d0e04754.tar.gz
freebsd-ports-gnome-dd1d4119b52671b642b5301b2ec2d075d0e04754.tar.zst
freebsd-ports-gnome-dd1d4119b52671b642b5301b2ec2d075d0e04754.zip
A Python module for creating JUnit XML test result documents that can be read
by tools such as Jenkins. If you are ever working with test tool or test suite written in Python and want to take advantage of Jenkins' pretty graphs and test reporting capabilities, this module will let you generate the XML test reports. WWW: https://github.com/kyrus/python-junit-xml
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-junit-xml/Makefile19
-rw-r--r--textproc/py-junit-xml/distinfo2
-rw-r--r--textproc/py-junit-xml/pkg-descr6
4 files changed, 28 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 84fa55466946..fa441baf842a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1159,6 +1159,7 @@
SUBDIR += py-html2text
SUBDIR += py-hyperestraier-python
SUBDIR += py-jaxml
+ SUBDIR += py-junit-xml
SUBDIR += py-libtre
SUBDIR += py-libxml2
SUBDIR += py-libxslt
diff --git a/textproc/py-junit-xml/Makefile b/textproc/py-junit-xml/Makefile
new file mode 100644
index 000000000000..5d87b449d0bc
--- /dev/null
+++ b/textproc/py-junit-xml/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= junit-xml
+PORTVERSION= 1.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Creates JUnit XML documents used by tools such as Jenkins
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-junit-xml/distinfo b/textproc/py-junit-xml/distinfo
new file mode 100644
index 000000000000..b5668086dee8
--- /dev/null
+++ b/textproc/py-junit-xml/distinfo
@@ -0,0 +1,2 @@
+SHA256 (junit-xml-1.3.tar.gz) = 2f7110f3926744fe8e37d11dabe3fc47c0b0f92efec3f0a1a087e1be954bc164
+SIZE (junit-xml-1.3.tar.gz) = 7014
diff --git a/textproc/py-junit-xml/pkg-descr b/textproc/py-junit-xml/pkg-descr
new file mode 100644
index 000000000000..12a4f396ee77
--- /dev/null
+++ b/textproc/py-junit-xml/pkg-descr
@@ -0,0 +1,6 @@
+A Python module for creating JUnit XML test result documents that can be read
+by tools such as Jenkins. If you are ever working with test tool or test suite
+written in Python and want to take advantage of Jenkins' pretty graphs and test
+reporting capabilities, this module will let you generate the XML test reports.
+
+WWW: https://github.com/kyrus/python-junit-xml
gnome/commit/benchmarks?id=ed94fe54b03695cf1f549b912ee7141c7681bd14'>Mark as broken on powerpc64.linimon2018-06-181-0/+2 * benchmarks/stress-ng: Update to 0.09.30pizzamig2018-06-182-4/+4 * Regular USE_GITHUB cleanup.mat2018-06-152-4/+4 * benchmarks/perftest: update to v4.2-0.8swills2018-06-152-5/+5 * Fix build on armv6, unbreak on aarch64linimon2018-06-132-3/+16 * benchmarks/stress-ng: Update to 0.09.29pizzamig2018-06-122-4/+4 * Apparently works on aarch64.linimon2018-06-111-3/+3 * Fix port builds for architectures which remain on gcc as the default compiler.linimon2018-06-111-2/+2 * Add perftest 4.2.0.7, collection of tests for RDMA micro-benchmark.philip2018-06-085-0/+58 * Remove expired ports:rene2018-06-075-105/+0 * Update WWWsunpoet2018-05-282-2/+2 * Update to 2.0.11sunpoet2018-05-273-17/+5 * Update lang/ghc 8.4.2 and the hs-* ports the newer versionstcberner2018-05-262-9/+8 * Update to 7.0.0krion2018-05-232-4/+4 * benchmarks/stress-ng: Update to 0.9.27pizzamig2018-05-182-4/+4 * Deprecate ports broken for more than 6 monthsantoine2018-05-051-0/+2 * - Update octave to 4.4.0.stephen2018-05-041-1/+1 * benchmarks/phoronix-test-suite: update to 8.0.0.m3pizzamig2018-05-042-18/+12 * - Update to 1.1.2danilo2018-05-032-4/+4 * benchmarks/stress-ng: Update to 0.09.26pizzamig2018-04-302-4/+4 * Update to 3.6bapt2018-04-232-4/+4 * Upgrade to latest release 4.1.0.osa2018-04-202-5/+5 * benchmarks/stressng: Update to 0.09.25pizzamig2018-04-202-4/+4 * benchmarks/stress-ng: Update to 0.09.24pizzamig2018-04-132-4/+4 * Remove needless build dependency on xxd(1): unused since version 1.0.12.danfe2018-04-121-1/+0 * Update to 1.0.14sunpoet2018-04-042-4/+4 * Simplify BUILD_DEPENDS: use lightweight vim-console instead of vimsunpoet2018-04-031-1/+1 * Add benchmarks/uperfkrion2018-04-025-0/+134 * benchmarks/stress-ng: Update to 0.9.23pizzamig2018-03-292-4/+4 * benchmarks/stress-ng: Update to 0.9.22pizzamig2018-03-282-4/+4 * devel/apr1: Bump portrevisionbrnrd2018-03-221-1/+1 * devel/apr1: Fix runtime issues of dependent portbrnrd2018-03-221-1/+1 * Remove expired ports:rene2018-03-215-99/+0 * Made 14 Go ports respect MAKE_ENV. This is expected to unbreak them.yuri2018-03-181-1/+1 * benchmarks/flowgrind: Fix order of variablesdbaio2018-03-171-2/+3 * benchmarks/stress-ng: Update to 0.09.19pizzamig2018-03-132-4/+4 * benchmarks/netperfmeter: Update to 1.7.6tobik2018-03-114-8/+16 * Bump PORTREVISIONs of all users of math/mpc that we just updated togerald2018-03-119-6/+9 * Make 41 Go ports respect MAKE_ENV. This is expected to unbreak them.yuri2018-03-072-2/+2 * benchmarks/stress-ng: Update to 0.09.18pizzamig2018-03-053-15/+6 * Given that the netperf project hasn't rolled a release in quite some time,marius2018-03-057-37/+35 * Adjust code comments and add one missing linefeed.danfe2018-03-031-6/+7 * - Collect CPU and memory statistics originally missing on FreeBSDdanfe2018-03-033-2/+105 * Update to iperf-3.5.bmah2018-03-032-4/+4 * Work around the lack of definition of union semun per POSIX.brooks2018-03-031-0/+1 * apib is a tool that makes it easy to test API servers. It is supporteddanfe2018-03-024-0/+56 * - Bumping portrevistion because of update of math/octave to 4.2.1 (r462865).stephen2018-02-251-1/+1 * Update to 3.5bapt2018-02-243-4/+5 * Reset vg@'s ports after he resigned.rene2018-02-241-1/+1 * benchmarks/stress-ng: Update to 0.09.16pizzamig2018-02-213-15/+10 * Update to 1.0.13sunpoet2018-02-182-4/+4 * Deprecate ports broken for more than 6 monthsantoine2018-02-181-0/+2 * BROKEN_SSL: Add REASON for breakagebrnrd2018-02-172-0/+2 * security/openssl-devel: Mark broken category benchmarksbrnrd2018-02-162-0/+3 * Update to iperf-3.4.bmah2018-02-152-4/+4 * benchmarks/stress-ng: Fix 'make describe'pizzamig2018-02-131-2/+2 * Switch C compiler used to compile GHC to base Clang.tcberner2018-02-101-0/+1 * benchmarks/stress-ng: Update to 0.09.15pizzamig2018-02-092-4/+9 * Add benchmarks/py-throughpy: Python script to test throughput with iperf3dbaio2018-01-274-0/+29 * Add benchmarks/vegeta: HTTP load testing tool and librarydbaio2018-01-274-0/+50 * Mark broken ports that fail to build on i386 with clang 6pizzamig2018-01-271-0/+6 * benchmarks/stress-ng: Update to 0.09.13pizzamig2018-01-272-4/+4 * Lift BROKEN flags to reflect actual state of supportbapt2018-01-251-3/+2 * Do not link the program statically, there is no need for this.danfe2018-01-251-0/+9 * benchmarks/stress-ng: Update to 0.09.12pizzamig2018-01-232-4/+4 * Try to unbreak on SSE4.1-capable machines running in 32-bit mode.danfe2018-01-231-0/+13 * Options are already optional.mat2018-01-201-1/+1 * Update to 1.0.12sunpoet2018-01-183-4/+5 * Unbreak the build against Clang 6.0.0 by allowing certain warnings while I'mdanfe2018-01-151-0/+2 * - Unbreak the build with new Clang version 6.0.0danfe2018-01-151-1/+2 * Add a port of lzbench, an in-memory benchmark of open-source LZ77/LZSS/LZMAdanfe2018-01-154-0/+46 * benchmarks/stress-ng: Update to 0.09.10pizzamig2018-01-152-4/+4 * - Convert to option helper install target (add OPTIONS_DEFINE=DOCSdanfe2018-01-121-5/+6 * benchmarks/stress-ng: Update to 0.09.09pizzamig2018-01-102-4/+4 * Update to 3.3bapt2018-01-073-4/+13 * - Update to 4.11.0wen2018-01-063-22/+4 * benchmarks/stress-ng: Update to 0.09.08pizzamig2018-01-032-4/+4 * Set LLD_UNSAFE=yes that the port will continue to link with ld.bfd ifkrion2017-12-311-0/+1 * - Update to 1.1.1danilo2017-12-312-4/+4 * benchmarks/stress-ng: Update to 0.09.07pizzamig2017-12-282-5/+5 * - Update to 1.1danilo2017-12-272-4/+4 * - Add LICENSE_FILEamdmi32017-12-121-2/+6 * - Those ports fail to build with python3antoine2017-12-121-1/+1 * Update to 1.0.11sunpoet2017-12-112-4/+4 * Use the correct FLAVOR of py-naarad in py-zopkioantoine2017-12-021-1/+2 * Convert Python ports to FLAVORS.mat2017-11-302-7/+7 * For ports that are marked BROKEN on armv6, and also fail to build onlinimon2017-11-301-0/+1 * - Add LICENSEamdmi32017-11-281-9/+17 * benchmarks/stress-ng: Update to 0.09.04pizzamig2017-11-282-4/+4 * benchmarks/stress-ng: Update to 0.09.02pizzamig2017-11-142-4/+4 * benchmarks/stress-ng: Update to 0.09.01pizzamig2017-11-062-4/+4 * Update iperf3 to 3.3, a bugfix release.bmah2017-11-023-13/+14 * Fix whitespace issues (mixed tab/spaces, alignment) in a few ports.olgeni2017-10-311-1/+1 * benchmarks/stress-ng: Update to 0.09.00pizzamig2017-10-312-4/+4 * Update to 1.0.10sunpoet2017-10-282-5/+4 * benchmarks/stress-ng: Update to 0.08.18pizzamig2017-10-262-4/+4 * Remove dead links from MASTER_SITES or WWWbapt2017-10-1310-19/+4 * Mark as broken: no public distfilesbapt2017-10-131-0/+2 * Fix master_sitebapt2017-10-131-1/+1 * benchmarks/stress-ng: Update 0.08.17pizzamig2017-10-123-14/+4 * benchmarks/phoronix-test-suite: update to version 7.4.0pizzamig2017-10-062-11/+5 * Update to 3.1bapt2017-10-022-4/+4 * benchmarks/unixbench: Fix the new path in the unixbenchpizzamig2017-09-292-1/+2 * benchmarks/stress-ng: Update to version 0.08.16pizzamig2017-09-282-4/+4 * - Update devel/efl to 1.19.2 [1]gblach2017-09-211-0/+2 * benchmarks/siege: Update version 4.0.2=>4.0.4bofh2017-09-192-4/+4 * Fix license information for portgs that use "the same license as Perl".mat2017-09-151-1/+1 * benchmarks/stress-ng: updating to 0.8.14pizzamig2017-09-122-5/+4 * Bump PORTREVISION for ports depending on the canonical version of GCCgerald2017-09-116-4/+6 * benchmarks/phoronix-test-suite: update to version 7.2.1pizzamig2017-09-112-4/+4 * Update to 1.0.9sunpoet2017-09-073-4/+6 * benchmarks/unixbench: updating to version 5.1.3pizzamig2017-09-0514-185/+190 * benchmarks/stress-ng: Updating to version 0.08.13pizzamig2017-09-012-4/+4 * benchmarks/nbench: fixing master site and the homepage entrypizzamig2017-08-312-2/+2 * Change MAINTAINER email to my new FreeBSD emailpizzamig2017-08-293-3/+3 * benchmarks/flamegraph: Update to later snapshot which fixes some output bugs ...jmd2017-08-243-7/+9 * Update to 3.0bapt2017-08-213-4/+5 * Add upstream patch to fix 32 bit constantsunpoet2017-08-182-0/+12 * Explicitly build with -std=gnu++03.rakuco2017-08-181-0/+3 * Update to 2.0.10sunpoet2017-08-132-4/+4 * benchmarks/stress-ng: Update to 0.08.10dbaio2017-08-112-4/+4 * - Update The Glorious Glasgow Haskell Compiler to version 8.0.2tcberner2017-08-092-7/+10 * Fix WWWarved2017-08-021-1/+1 * benchmarks/stress-ng: Update to 0.08.09tobik2017-07-272-4/+4 * Update to 2.99bapt2017-07-142-4/+4 * Update to 1.0.8sunpoet2017-07-062-4/+4 * - Add LICENSEamdmi32017-07-051-1/+7 * - Switch to options helpersamdmi32017-07-051-2/+4 * - Add LICENSEamdmi32017-07-051-4/+9 * Update to 0.08.07olivier2017-07-042-4/+4 * Update math/gsl to 2.4tcberner2017-07-041-1/+1 * Add a port of Typometer, text/code editor typing latency analyzer.danfe2017-07-024-0/+62 * Update to iperf3-3.2.bmah2017-06-282-5/+5 * Remove Perl core modulessunpoet2017-06-271-3/+3 * Fix WWWsunpoet2017-06-251-1/+1 * - benchmarks/phoronix-test-suite: Update from 6.8.0 to 7.0.1joneum2017-06-212-9/+4 * Update to 2.21bapt2017-06-162-4/+4 * Add 'hey' an HTTP benchmarking toolbrd2017-06-164-0/+42 * Update distinfo and unbreak this portsunpoet2017-06-112-3/+4 * benchmarks/nuttcp: fix distinfospi2017-06-082-4/+7 * benchmarks/clpeak: This brings clpeak to the latest git revision. FreeBSD pat...jmd2017-06-023-38/+6 * Updating to version 0.08.02olivier2017-05-313-9/+9 * Update to 1.0.7sunpoet2017-05-266-136/+113 * Update the sysbench port to build frommatthew2017-05-246-18/+111 * Revision bump of all ports with USE_GL after consolidation of mesa-libsrezny2017-05-232-1/+2 * Update to 2.20bapt2017-05-233-4/+7 * Mark some ports failing on power64. In cases where the error messagelinimon2017-05-221-0/+2 * Mark some ports failing on power64. In cases where the error messagelinimon2017-05-212-2/+2 * - Update maintainer addressjoneum2017-05-161-1/+1 * Mark some ports failing on power64. In cases where the error messagelinimon2017-05-133-2/+4 * Updating to version 0.08.00olivier2017-05-094-9/+18 * Update my email addressdbaio2017-05-091-1/+1 * - Update to 1.0.3danilo2017-05-082-4/+4 * Remove expired ports:rene2017-05-075-45/+0 * Update math/gsl to 2.3tcberner2017-05-021-0/+1 * Fix the shebang file listolivier2017-04-271-9/+3 * Chase ffmpeg 3.3 update (ABI changes)riggs2017-04-251-1/+1 * - Fix shebangsmiwi2017-04-222-2/+6 * - Fix shebangsmiwi2017-04-221-4/+15 * Updating to version 0.07.29olivier2017-04-202-4/+4 * - Fix shebangsmiwi2017-04-191-1/+8 * Updating to version 0.07.28olivier2017-04-102-4/+4 * Update to 2.19bapt2017-04-083-17/+4 * benchmarks/gobench: mark deprecatedswills2017-04-061-0/+3 * Bump PORTREVISION.jmd2017-04-021-0/+1 * Use INSTALL_SCRIPT to mark installed files as executable.jmd2017-04-021-1/+1 * new port: benchmarks/flamegraphjmd2017-04-025-0/+85 * Bump PORTREVISIONs for ports depending on the canonical version of GCC andgerald2017-04-015-4/+5