aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-04 11:05:48 +0800
committeredwin <edwin@FreeBSD.org>2002-11-04 11:05:48 +0800
commit011f3a2a13f514a55dae8ea737db2d626983191d (patch)
treeef9e57574419ab4a95c9adca518cce23e6a78895 /textproc
parentf2bc149e9a1f30296a05f9c708c6729f700c8234 (diff)
downloadfreebsd-ports-gnome-011f3a2a13f514a55dae8ea737db2d626983191d.tar.gz
freebsd-ports-gnome-011f3a2a13f514a55dae8ea737db2d626983191d.tar.zst
freebsd-ports-gnome-011f3a2a13f514a55dae8ea737db2d626983191d.zip
PERL -> REINPLACE
and russian/mod_ssl has USE_PERL5=yes Notices on: bento
Diffstat (limited to 'textproc')
-rw-r--r--textproc/code2html/Makefile3
-rw-r--r--textproc/dsssl-docbook-cygnus/Makefile1
-rw-r--r--textproc/kdoc/Makefile3
-rw-r--r--textproc/openjade/Makefile1
-rw-r--r--textproc/rotix/Makefile3
5 files changed, 8 insertions, 3 deletions
diff --git a/textproc/code2html/Makefile b/textproc/code2html/Makefile
index 2601f45eeed3..826499bd3443 100644
--- a/textproc/code2html/Makefile
+++ b/textproc/code2html/Makefile
@@ -23,6 +23,7 @@ BZIP2BASE= /usr
.endif
NO_BUILD= yes
+USE_REINPLACE= yes
MAN1= code2html.1
@@ -32,7 +33,7 @@ do-configure:
-e 's|/bin/gzip|/usr/bin/gzip|' \
-e 's|/etc/code|${PREFIX}/etc/code|' \
< ${WRKSRC}/code2html.orig > ${WRKSRC}/code2html
- @${PERL} -pi.orig -e 's|/etc/code|${PREFIX}/etc/code|' \
+ @${REINPLACE_CMD} -e 's|/etc/code|${PREFIX}/etc/code|' \
${WRKSRC}/code2html.1
do-install:
diff --git a/textproc/dsssl-docbook-cygnus/Makefile b/textproc/dsssl-docbook-cygnus/Makefile
index 9e6a345aba25..67ed05733929 100644
--- a/textproc/dsssl-docbook-cygnus/Makefile
+++ b/textproc/dsssl-docbook-cygnus/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/sgml/docbook/dsssl/modular/frames/navbar.htm:${P
jade:${PORTSDIR}/textproc/jade
NO_BUILD= yes
+USE_PERL5= yes
WRKSRC= ${WRKDIR}/stylesheets
SCRIPTS_ENV= DB_DATA="${DB_SCRIPTS} cygnus-both.dsl"
diff --git a/textproc/kdoc/Makefile b/textproc/kdoc/Makefile
index beb2e167ab8c..8ccf4ed628a0 100644
--- a/textproc/kdoc/Makefile
+++ b/textproc/kdoc/Makefile
@@ -17,13 +17,14 @@ MAINTAINER= kde@FreeBSD.org
USE_BZIP2= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_PERL5= yes
MAN1= kdoc.1 qt2kdoc.1 makekdedoc.1
pre-configure:
- ${PERL} -pi -e "s#share/kdoc#lib/perl5/site_perl/${PERL_VER}#" \
+ ${REINPLACE_CMD} -e "s#share/kdoc#lib/perl5/site_perl/${PERL_VER}#" \
${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/textproc/openjade/Makefile b/textproc/openjade/Makefile
index 0d6fa491c698..20908f6333dc 100644
--- a/textproc/openjade/Makefile
+++ b/textproc/openjade/Makefile
@@ -17,6 +17,7 @@ RUN_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
USE_GMAKE= YES
USE_LIBTOOL= YES
+USE_PERL5= yes
CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
--datadir=${PREFIX}/share/sgml/openjade
INSTALLS_SHLIB= yes
diff --git a/textproc/rotix/Makefile b/textproc/rotix/Makefile
index 87893fd6b9c4..bb129fb9bcd0 100644
--- a/textproc/rotix/Makefile
+++ b/textproc/rotix/Makefile
@@ -18,12 +18,13 @@ LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
USE_GMAKE= yes
HAS_CONFIGURE= yes
+USE_REINPLACE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${PREFIX}/man --i18n=1
MAN1= rotix.1
post-patch:
- @${PERL} -pi -e 's,%%CFLAGS%%,${CFLAGS},; s,%%LOCALBASE%%,${LOCALBASE},;' \
+ @${REINPLACE_CMD} -e 's,%%CFLAGS%%,${CFLAGS},; s,%%LOCALBASE%%,${LOCALBASE},;' \
${WRKSRC}/Makefile
.include <bsd.port.mk>