aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-22 12:54:01 +0800
committerclsung <clsung@FreeBSD.org>2006-07-22 12:54:01 +0800
commit0483b5d1b1e4656114e481cf9e37f5edde56d4ff (patch)
tree569139ade8254605180037cce4b075cf920c5f3e /textproc
parent901adc65ea04f72811089e379ab6d245738e551b (diff)
downloadfreebsd-ports-gnome-0483b5d1b1e4656114e481cf9e37f5edde56d4ff.tar.gz
freebsd-ports-gnome-0483b5d1b1e4656114e481cf9e37f5edde56d4ff.tar.zst
freebsd-ports-gnome-0483b5d1b1e4656114e481cf9e37f5edde56d4ff.zip
Add p5-Lingua-EN-NamedEntity 1.7, basic Named Entity Extraction
algorithm. PR: ports/100675 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Lingua-EN-NamedEntity/Makefile33
-rw-r--r--textproc/p5-Lingua-EN-NamedEntity/distinfo3
-rw-r--r--textproc/p5-Lingua-EN-NamedEntity/pkg-descr17
-rw-r--r--textproc/p5-Lingua-EN-NamedEntity/pkg-plist10
5 files changed, 64 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 8cc8a2e7cd06..324c2680c8f0 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -349,6 +349,7 @@
SUBDIR += p5-Lingua-EN-MatchNames
SUBDIR += p5-Lingua-EN-NameCase
SUBDIR += p5-Lingua-EN-NameParse
+ SUBDIR += p5-Lingua-EN-NamedEntity
SUBDIR += p5-Lingua-EN-Nickname
SUBDIR += p5-Lingua-EN-Numbers
SUBDIR += p5-Lingua-EN-Numbers-Easy
diff --git a/textproc/p5-Lingua-EN-NamedEntity/Makefile b/textproc/p5-Lingua-EN-NamedEntity/Makefile
new file mode 100644
index 000000000000..5f7aea3adc42
--- /dev/null
+++ b/textproc/p5-Lingua-EN-NamedEntity/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Lingua-EN-NamedEntity
+# Date created: 2006-07-21
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Lingua-EN-NamedEntity
+PORTVERSION= 1.7
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Lingua
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Basic Named Entity Extraction algorithm
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/Lingua/Stem/En.pm:${PORTSDIR}/textproc/p5-Lingua-Stem \
+ ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Lingua::EN::NamedEntity.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Lingua-EN-NamedEntity/distinfo b/textproc/p5-Lingua-EN-NamedEntity/distinfo
new file mode 100644
index 000000000000..d889d263ba5c
--- /dev/null
+++ b/textproc/p5-Lingua-EN-NamedEntity/distinfo
@@ -0,0 +1,3 @@
+MD5 (Lingua-EN-NamedEntity-1.7.tar.gz) = 47cb8958c96e6d3d0394d8740d5617e0
+SHA256 (Lingua-EN-NamedEntity-1.7.tar.gz) = 9f561b59d5a2bd983abaefdd4d5081a40af2d0801ffa60c95a9df836aacf5a04
+SIZE (Lingua-EN-NamedEntity-1.7.tar.gz) = 21176
diff --git a/textproc/p5-Lingua-EN-NamedEntity/pkg-descr b/textproc/p5-Lingua-EN-NamedEntity/pkg-descr
new file mode 100644
index 000000000000..91cf59e77650
--- /dev/null
+++ b/textproc/p5-Lingua-EN-NamedEntity/pkg-descr
@@ -0,0 +1,17 @@
+"Named entities" is the NLP jargon for proper nouns which
+represent people, places, organisations, and so on.
+
+This module provides a very simple way of extracting these from a text.
+If we run the "extract_entities" routine on a piece of news coverage of
+recent UK political events, we should expect to see it return a list of
+hash references looking like this:
+
+{ entity => 'Mr Howard', class => 'person', scores => { ... }, },
+{ entity => 'Ministry of Defence', class => 'organisation', ... },
+{ entity => 'Oxfordshire', class => 'place', ... },
+
+The additional "scores" hash reference in there breaks down the various
+possible classes for this entity in an open-ended scale.
+
+
+WWW: http://search.cpan.org/dist/Lingua-EN-NamedEntity/
diff --git a/textproc/p5-Lingua-EN-NamedEntity/pkg-plist b/textproc/p5-Lingua-EN-NamedEntity/pkg-plist
new file mode 100644
index 000000000000..18ea64f7c70d
--- /dev/null
+++ b/textproc/p5-Lingua-EN-NamedEntity/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Lingua/EN/NamedEntity.pm
+%%SITE_PERL%%/Lingua/EN/NamedEntity/forename
+%%SITE_PERL%%/Lingua/EN/NamedEntity/wordlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Lingua/EN/NamedEntity/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Lingua/EN/NamedEntity
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Lingua/EN
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Lingua
+@dirrmtry %%SITE_PERL%%/Lingua/EN/NamedEntity
+@dirrmtry %%SITE_PERL%%/Lingua/EN
+@dirrmtry %%SITE_PERL%%/Lingua