aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2002-01-01 00:10:42 +0800
committerkuriyama <kuriyama@FreeBSD.org>2002-01-01 00:10:42 +0800
commit05458a7660b2d7cf840c86cd6594232201f224d0 (patch)
tree81f53acfa5cabbdb5c74952bc096356ca6ebf294 /textproc
parente961887b3fd16cd0a94e022c9e1c33740268f7a4 (diff)
downloadfreebsd-ports-gnome-05458a7660b2d7cf840c86cd6594232201f224d0.tar.gz
freebsd-ports-gnome-05458a7660b2d7cf840c86cd6594232201f224d0.tar.zst
freebsd-ports-gnome-05458a7660b2d7cf840c86cd6594232201f224d0.zip
Use mkcatalog to link to catalog chain.
Submitted by: Kimura Fuyuki <fuyuki@mj.0038.net> PR: ports/33342 # This is my first commit of 2002 (JST) year!
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xhtml/Makefile9
-rw-r--r--textproc/xhtml/pkg-plist2
2 files changed, 11 insertions, 0 deletions
diff --git a/textproc/xhtml/Makefile b/textproc/xhtml/Makefile
index fa4fe4c15e22..bec544269d23 100644
--- a/textproc/xhtml/Makefile
+++ b/textproc/xhtml/Makefile
@@ -7,12 +7,16 @@
PORTNAME= xhtml
PORTVERSION= 1.0
+PORTRIVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://www.w3.org/TR/xhtml1/
DISTNAME= xhtml1
MAINTAINER= kuriyama@FreeBSD.org
+BUILD_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
+RUN_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
+
USE_ZIP= YES
NO_MTREE= YES
NO_BUILD= YES
@@ -23,6 +27,8 @@ DTDDIR= ${INSTDIR}/dtd/xhtml
DTDFILES= xhtml-lat1.ent xhtml-special.ent xhtml-symbol.ent \
xhtml.soc xhtml1-frameset.dtd xhtml1-strict.dtd \
xhtml1-transitional.dtd xhtml1.dcl
+MKCATALOG= ${PREFIX}/sbin/mkcatalog
+PLIST_SUB= MKCATALOG=${MKCATALOG}
pre-install:
@[ -d ${DTDDIR} ] || ${MKDIR} ${DTDDIR}
@@ -30,4 +36,7 @@ pre-install:
do-install:
@(cd ${WRKSRC}/DTD; ${INSTALL_DATA} ${DTDFILES} ${DTDDIR})
+post-install:
+ @${MKCATALOG} -c ${INSTDIR}/catalog -q install dtd/xhtml xhtml.soc
+
.include <bsd.port.mk>
diff --git a/textproc/xhtml/pkg-plist b/textproc/xhtml/pkg-plist
index d47e2b9a3392..67fb4be31eb6 100644
--- a/textproc/xhtml/pkg-plist
+++ b/textproc/xhtml/pkg-plist
@@ -1,7 +1,9 @@
share/xml/dtd/xhtml/xhtml-lat1.ent
share/xml/dtd/xhtml/xhtml-special.ent
share/xml/dtd/xhtml/xhtml-symbol.ent
+@unexec %%MKCATALOG%% -c %D/share/xml/catalog -q deinstall dtd/xhtml xhtml.soc
share/xml/dtd/xhtml/xhtml.soc
+@exec %%MKCATALOG%% -c %D/share/xml/catalog -q install dtd/xhtml xhtml.soc
share/xml/dtd/xhtml/xhtml1-frameset.dtd
share/xml/dtd/xhtml/xhtml1-strict.dtd
share/xml/dtd/xhtml/xhtml1-transitional.dtd