aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-23 04:06:14 +0800
committermakc <makc@FreeBSD.org>2013-03-23 04:06:14 +0800
commit071186fd6d22f1abd16554cae92bf26af9d1cb4e (patch)
treeb368198f913179c06dafd19ac72527fcf9836f6d /textproc
parenteda1ae8e7cf50659cf0b55fefdcae532e6ad0405 (diff)
downloadfreebsd-ports-gnome-071186fd6d22f1abd16554cae92bf26af9d1cb4e.tar.gz
freebsd-ports-gnome-071186fd6d22f1abd16554cae92bf26af9d1cb4e.tar.zst
freebsd-ports-gnome-071186fd6d22f1abd16554cae92bf26af9d1cb4e.zip
- convert USE_CMAKE to USES
- while here clean up some ports from CMAKE_VERBOSE, which is intended for users Approved by: portmgr (miwi)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/clucene/Makefile2
-rw-r--r--textproc/ctpp2/Makefile2
-rw-r--r--textproc/dikt/Makefile2
-rw-r--r--textproc/ebook-tools/Makefile2
-rw-r--r--textproc/fcitx-m17n/Makefile2
-rw-r--r--textproc/ibus-qt/Makefile2
-rw-r--r--textproc/kdiff3/Makefile2
-rw-r--r--textproc/lemmatizer2/Makefile2
-rw-r--r--textproc/libkolabxml/Makefile2
-rw-r--r--textproc/sigil/Makefile2
-rw-r--r--textproc/simplexml/Makefile2
-rw-r--r--textproc/soprano/Makefile2
-rw-r--r--textproc/wbxml2/Makefile2
-rw-r--r--textproc/wv2/Makefile2
-rw-r--r--textproc/zorba/Makefile3
15 files changed, 15 insertions, 16 deletions
diff --git a/textproc/clucene/Makefile b/textproc/clucene/Makefile
index b7c311d0052a..7508a57c2058 100644
--- a/textproc/clucene/Makefile
+++ b/textproc/clucene/Makefile
@@ -15,7 +15,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= ${LOCALBASE}/lib/libboost_regex.a:${PORTSDIR}/devel/boost-libs
-USE_CMAKE= yes
+USES= cmake
USE_ICONV= yes
USE_LDCONFIG= yes
diff --git a/textproc/ctpp2/Makefile b/textproc/ctpp2/Makefile
index 1c5d5c35aaa3..7093142d5789 100644
--- a/textproc/ctpp2/Makefile
+++ b/textproc/ctpp2/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://ctpp.havoc.ru/download/
MAINTAINER= reki@reki.ru
COMMENT= C++ library to use templates in C/C++ projects, version 2
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
USE_GETTEXT= yes
USE_ICONV= yes
diff --git a/textproc/dikt/Makefile b/textproc/dikt/Makefile
index 3082e508b53c..f219d54de9e0 100644
--- a/textproc/dikt/Makefile
+++ b/textproc/dikt/Makefile
@@ -18,7 +18,7 @@ USE_XZ= yes
USE_KDE4= kdelibs kdeprefix kdehier automoc4
USE_QT4= corelib gui network svg xml \
qmake_build moc_build rcc_build uic_build
-USE_CMAKE= yes
+USES= cmake
PLIST_FILES= bin/dikt \
share/applications/kde4/dikt.desktop \
diff --git a/textproc/ebook-tools/Makefile b/textproc/ebook-tools/Makefile
index 675708a4f148..62fb7b98da77 100644
--- a/textproc/ebook-tools/Makefile
+++ b/textproc/ebook-tools/Makefile
@@ -11,7 +11,7 @@ COMMENT= Accesses and converts various ebook file formats
LIB_DEPENDS= zip:${PORTSDIR}/archivers/libzip
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
USE_GNOME= libxml2
diff --git a/textproc/fcitx-m17n/Makefile b/textproc/fcitx-m17n/Makefile
index 9be53d281bc6..e242b9470c1e 100644
--- a/textproc/fcitx-m17n/Makefile
+++ b/textproc/fcitx-m17n/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= fcitx-config:${PORTSDIR}/chinese/fcitx \
USE_XZ= yes
USE_GETTEXT= yes
-USE_CMAKE= yes
+USES= cmake
USE_GNOME= intltool
.include <bsd.port.mk>
diff --git a/textproc/ibus-qt/Makefile b/textproc/ibus-qt/Makefile
index 6b6e0c881dd8..b8300d83d4a3 100644
--- a/textproc/ibus-qt/Makefile
+++ b/textproc/ibus-qt/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ibus-1.0.pc:${PORTSDIR}/textproc/ibu
${LOCALBASE}/bin/icu-config:${PORTSDIR}/devel/icu
USE_QT4= gui dbus moc_build qmake_build moc_build uic_build rcc_build
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DDOCDIR=${PREFIX}/share/doc/ibus-qt
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/textproc/kdiff3/Makefile b/textproc/kdiff3/Makefile
index 93da7eb647e2..9032a91a52b0 100644
--- a/textproc/kdiff3/Makefile
+++ b/textproc/kdiff3/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= brucec@FreeBSD.org
COMMENT= A KDE4 graphical frontend for diff
USE_KDE4= kdelibs libkonq kdeprefix kdehier automoc4
-USE_CMAKE= yes
+USES= cmake
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
diff --git a/textproc/lemmatizer2/Makefile b/textproc/lemmatizer2/Makefile
index bf50ca0e5f5b..b0b5ac1b9546 100644
--- a/textproc/lemmatizer2/Makefile
+++ b/textproc/lemmatizer2/Makefile
@@ -21,7 +21,7 @@ COMMENT= Russian / German / English lemmatizer library
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
-USE_CMAKE= yes
+USES= cmake
DB_DIR?= /var/db/lemmatizer
diff --git a/textproc/libkolabxml/Makefile b/textproc/libkolabxml/Makefile
index 70d6ccd94775..454cc0c431f4 100644
--- a/textproc/libkolabxml/Makefile
+++ b/textproc/libkolabxml/Makefile
@@ -27,7 +27,7 @@ CMAKE_ARGS= -DBUILD_TESTS:BOOL=OFF \
-DPHP_BINDINGS:BOOL=OFF \
-DPYTHON_BINDINGS:BOOL=OFF
MAKE_JOBS_SAFE= yes
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/textproc/sigil/Makefile b/textproc/sigil/Makefile
index 414d53569a1e..6ac951308fc9 100644
--- a/textproc/sigil/Makefile
+++ b/textproc/sigil/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
LICENCE= GPLv3
USE_ZIP= yes
-USE_CMAKE= yes
+USES= cmake
USE_DOS2UNIX= CMakeLists.txt DirEnumerator.cpp ZipFile_stl.cpp ZipPlatform_lnx.cpp
NO_WRKSUBDIR= yes
USE_QT4= qmake gui svg webkit xml moc uic rcc imageformats linguist
diff --git a/textproc/simplexml/Makefile b/textproc/simplexml/Makefile
index a01f86f224a8..ce4410b223da 100644
--- a/textproc/simplexml/Makefile
+++ b/textproc/simplexml/Makefile
@@ -17,7 +17,7 @@ COMMENT= C++ XML parser library
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
-USE_CMAKE= yes
+USES= cmake
USE_ICONV= yes
USE_LDCONFIG= yes
diff --git a/textproc/soprano/Makefile b/textproc/soprano/Makefile
index ceb9b9158e8f..5dc6d3bf9749 100644
--- a/textproc/soprano/Makefile
+++ b/textproc/soprano/Makefile
@@ -17,7 +17,7 @@ USE_QT4= corelib dbus qtestlib network \
qmake_build moc_build uic_build rcc_build
USE_PKGCONFIG= both
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS+= -DSOPRANO_DISABLE_CLUCENE_INDEX=yes \
-DSOPRANO_DISABLE_SESAME2_BACKEND=yes
MAKE_JOBS_SAFE= yes
diff --git a/textproc/wbxml2/Makefile b/textproc/wbxml2/Makefile
index 5985ce826d48..7db9e0e01337 100644
--- a/textproc/wbxml2/Makefile
+++ b/textproc/wbxml2/Makefile
@@ -23,7 +23,7 @@ BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
CMAKE_SOURCE_PATH= ..
USE_LDCONFIG= yes
diff --git a/textproc/wv2/Makefile b/textproc/wv2/Makefile
index c54ce30361c7..adde29e3e8b6 100644
--- a/textproc/wv2/Makefile
+++ b/textproc/wv2/Makefile
@@ -17,7 +17,7 @@ COMMENT= A library providing routines to access Microsoft Word files
USE_GNOME= libgsf
USE_ICONV= yes
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/textproc/zorba/Makefile b/textproc/zorba/Makefile
index 6fc42d15953b..778f2e852cdb 100644
--- a/textproc/zorba/Makefile
+++ b/textproc/zorba/Makefile
@@ -31,10 +31,9 @@ CONFLICTS= xqilla-[0-9]*
USE_GNOME= libxml2 libxslt
USE_ICONV= yes
USE_LDCONFIG= yes
-USE_CMAKE= yes
+USES= cmake:outsource
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CMAKE_OUTSOURCE=yes
CMAKE_ARGS= -DCMAKE_REQUIRED_FLAGS:STRING="-I${LOCALBASE}/include -L${LOCALBASE}/lib"
DOCSDIR= ${PREFIX}/share/doc/${PKGNAME}