aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2003-06-01 17:54:17 +0800
committerolgeni <olgeni@FreeBSD.org>2003-06-01 17:54:17 +0800
commit0aa65e5467c3399cad13295d8e3fb9d49c852ccc (patch)
tree78d0f4dc21d7334405dcf18116b75d1169008a72 /textproc
parentbd705e05f37c6bf5b29bca3cb4b856aceaccb905 (diff)
downloadfreebsd-ports-gnome-0aa65e5467c3399cad13295d8e3fb9d49c852ccc.tar.gz
freebsd-ports-gnome-0aa65e5467c3399cad13295d8e3fb9d49c852ccc.tar.zst
freebsd-ports-gnome-0aa65e5467c3399cad13295d8e3fb9d49c852ccc.zip
Rename inc/ to include/ to follow OTP library naming conventions.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xmerl/Makefile21
-rw-r--r--textproc/xmerl/files/patch-src_Makefile14
-rw-r--r--textproc/xmerl/pkg-plist6
3 files changed, 34 insertions, 7 deletions
diff --git a/textproc/xmerl/Makefile b/textproc/xmerl/Makefile
index 1a70819cddc3..d0fb1a309c13 100644
--- a/textproc/xmerl/Makefile
+++ b/textproc/xmerl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xmerl
PORTVERSION= 0.18
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sowap
@@ -21,16 +22,28 @@ USE_GMAKE= yes
XMERL_DOCS= README.html changes.txt xpath-grammar.txt xslt-example.dtd xslt-example.xls
+post-extract:
+ @${MV} ${WRKSRC}/inc ${WRKSRC}/include
+
+post-patch:
+ @${RM} ${WRKSRC}/src/*.orig
+
do-install:
@${MKDIR} ${DOCSDIR}
@for FILE in ${XMERL_DOCS}; do \
${INSTALL_DATA} ${WRKSRC}/$${FILE} ${DOCSDIR}; \
done
+
@${MKDIR} ${PREFIX}/lib/erlang/lib/xmerl
- @${CP} -r ${WRKSRC}/ebin ${PREFIX}/lib/erlang/lib/xmerl
- @${CP} -r ${WRKSRC}/inc ${PREFIX}/lib/erlang/lib/xmerl
- @${CP} -r ${WRKSRC}/priv ${PREFIX}/lib/erlang/lib/xmerl
- @${CP} -r ${WRKSRC}/src ${PREFIX}/lib/erlang/lib/xmerl
+
+ @for FILE in ebin include priv src; do \
+ ${MKDIR} ${PREFIX}/lib/erlang/lib/xmerl/$${FILE}; \
+ ${CP} -r ${WRKSRC}/$${FILE}/* \
+ ${PREFIX}/lib/erlang/lib/xmerl/$${FILE}; \
+ ${CHMOD} ${SHAREMODE} \
+ ${PREFIX}/lib/erlang/lib/xmerl/$${FILE}/*; \
+ done
+
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/lib/erlang/lib/xmerl
.include <bsd.port.mk>
diff --git a/textproc/xmerl/files/patch-src_Makefile b/textproc/xmerl/files/patch-src_Makefile
new file mode 100644
index 000000000000..d58816083c4e
--- /dev/null
+++ b/textproc/xmerl/files/patch-src_Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/Makefile.orig Fri May 30 20:54:21 2003
++++ src/Makefile Fri May 30 20:54:26 2003
+@@ -61,7 +61,7 @@
+ # FLAGS
+ # ----------------------------------------------------
+ ERL_FLAGS += -W
+-ERL_COMPILE_FLAGS += $(DEBUG) -I ../inc
++ERL_COMPILE_FLAGS += $(DEBUG) -I ../include
+
+
+ # ----------------------------------------------------
diff --git a/textproc/xmerl/pkg-plist b/textproc/xmerl/pkg-plist
index 7c14f9796b14..e39533bb2bd6 100644
--- a/textproc/xmerl/pkg-plist
+++ b/textproc/xmerl/pkg-plist
@@ -14,8 +14,8 @@ lib/erlang/lib/xmerl/ebin/xmerl_xpath.beam
lib/erlang/lib/xmerl/ebin/xmerl_xpath_parse.beam
lib/erlang/lib/xmerl/ebin/xmerl_xpath_pred.beam
lib/erlang/lib/xmerl/ebin/xmerl_xpath_scan.beam
-lib/erlang/lib/xmerl/inc/xmerl.hrl
-lib/erlang/lib/xmerl/inc/xmerl_xlink.hrl
+lib/erlang/lib/xmerl/include/xmerl.hrl
+lib/erlang/lib/xmerl/include/xmerl_xlink.hrl
lib/erlang/lib/xmerl/priv/testdata/a_and_c.xml
lib/erlang/lib/xmerl/priv/testdata/all_well.xml
lib/erlang/lib/xmerl/priv/testdata/femdygnsprognos.xml
@@ -59,6 +59,6 @@ lib/erlang/lib/xmerl/src/xmerl_xpath_scan.erl
@dirrm lib/erlang/lib/xmerl/src
@dirrm lib/erlang/lib/xmerl/priv/testdata
@dirrm lib/erlang/lib/xmerl/priv
-@dirrm lib/erlang/lib/xmerl/inc
+@dirrm lib/erlang/lib/xmerl/include
@dirrm lib/erlang/lib/xmerl/ebin
@dirrm lib/erlang/lib/xmerl