aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-04-26 18:08:55 +0800
committersobomax <sobomax@FreeBSD.org>2002-04-26 18:08:55 +0800
commit0af49f7755362e8fc9a16be6a9a416b4c1129249 (patch)
tree8a552639d3c315b53c068cd8813494f81f62c9af /textproc
parent0db2b6288d1d440bc0c6e2413a0e52f3f7c57925 (diff)
downloadfreebsd-ports-gnome-0af49f7755362e8fc9a16be6a9a416b4c1129249.tar.gz
freebsd-ports-gnome-0af49f7755362e8fc9a16be6a9a416b4c1129249.tar.zst
freebsd-ports-gnome-0af49f7755362e8fc9a16be6a9a416b4c1129249.zip
Use USE_LIBTOOL.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libxslt/Makefile2
-rw-r--r--textproc/libxslt/files/patch-configure13
-rw-r--r--textproc/libxslt/files/patch-ltmain.sh45
3 files changed, 14 insertions, 46 deletions
diff --git a/textproc/libxslt/Makefile b/textproc/libxslt/Makefile
index 00ba1621ec69..f5d263a3d9f1 100644
--- a/textproc/libxslt/Makefile
+++ b/textproc/libxslt/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
USE_BZIP2= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
diff --git a/textproc/libxslt/files/patch-configure b/textproc/libxslt/files/patch-configure
new file mode 100644
index 000000000000..7b6b036578e7
--- /dev/null
+++ b/textproc/libxslt/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure 2002/04/26 09:54:14 1.1
++++ configure 2002/04/26 09:54:23
+@@ -5341,6 +5341,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/textproc/libxslt/files/patch-ltmain.sh b/textproc/libxslt/files/patch-ltmain.sh
deleted file mode 100644
index 91713d2306f8..000000000000
--- a/textproc/libxslt/files/patch-ltmain.sh
+++ /dev/null
@@ -1,45 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh.orig Wed Jan 23 11:38:40 2002
-+++ ltmain.sh Sun Feb 3 01:44:17 2002
-@@ -1037,8 +1037,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -2412,6 +2420,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4179,10 +4190,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"