aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-03-25 00:47:07 +0800
committerSteve Wills <swills@FreeBSD.org>2014-03-25 00:47:07 +0800
commit0b9b3fb78a22c6aabc1af05356724806ae9bc901 (patch)
treec1cc02c4b915dca37178256fb6a8c12af9b6aa90 /textproc
parentc3ee88c9fc5af846283d123d2a637be11529ebf5 (diff)
downloadfreebsd-ports-gnome-0b9b3fb78a22c6aabc1af05356724806ae9bc901.tar.gz
freebsd-ports-gnome-0b9b3fb78a22c6aabc1af05356724806ae9bc901.tar.zst
freebsd-ports-gnome-0b9b3fb78a22c6aabc1af05356724806ae9bc901.zip
This is a small package containing a Sphinx theme named "Cloud",
along with some related Sphinx extensions. To see an example of the theme in action, check out it's documentation. WWW: https://pypi.python.org/pypi/cloud_sptheme/ PR: ports/187893 Submitted by: Horia Racoviceanu <horia@racoviceanu.com>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-cloud_sptheme/Makefile53
-rw-r--r--textproc/py-cloud_sptheme/distinfo2
-rw-r--r--textproc/py-cloud_sptheme/pkg-descr5
4 files changed, 61 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 349f2c846825..d3f2ab5d8656 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1129,6 +1129,7 @@
SUBDIR += py-asv
SUBDIR += py-charade
SUBDIR += py-chardet
+ SUBDIR += py-cloud_sptheme
SUBDIR += py-creole
SUBDIR += py-docutils
SUBDIR += py-dsv
diff --git a/textproc/py-cloud_sptheme/Makefile b/textproc/py-cloud_sptheme/Makefile
new file mode 100644
index 000000000000..f10cda12a5f7
--- /dev/null
+++ b/textproc/py-cloud_sptheme/Makefile
@@ -0,0 +1,53 @@
+# Created by: Horia Racoviceanu <horia@racoviceanu.com>
+# $FreeBSD$
+
+PORTNAME= cloud_sptheme
+PORTVERSION= 1.6
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DIST_SUBDIR= python
+
+MAINTAINER= horia@racoviceanu.com
+COMMENT= Sphinx theme
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:${PORTSDIR}/textproc/py-sphinx
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST= yes
+PYDISTUTILS_BUILDARGS= build_sphinx -E
+
+PORTDOCS= *
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= README CHANGES
+
+DOCSDIR2= ${DOCSDIR}/html
+DOCSRCDIR2= ${DOCSRCDIR1}/build/sphinx/html
+DOC_FILES2= ${DOC_FILES3} *.js
+
+DOCSDIR3= ${DOCSDIR2}/lib
+DOCSRCDIR3= ${DOCSRCDIR2}/lib
+DOC_FILES3= *.html
+
+DOCSDIR4= ${DOCSDIR2}/_static
+DOCSRCDIR4= ${DOCSRCDIR2}/_static
+DOC_FILES4= *.css *.gif *.js *.png *.svg
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR3} ${STAGEDIR}${DOCSDIR4}
+ ${INSTALL_DATA} ${DOC_FILES3:S|^|${DOCSRCDIR3}/|} ${STAGEDIR}${DOCSDIR3}
+ ${INSTALL_DATA} ${DOC_FILES4:S|^|${DOCSRCDIR4}/|} ${STAGEDIR}${DOCSDIR4}
+
+.include <bsd.port.mk>
diff --git a/textproc/py-cloud_sptheme/distinfo b/textproc/py-cloud_sptheme/distinfo
new file mode 100644
index 000000000000..efe60b04744c
--- /dev/null
+++ b/textproc/py-cloud_sptheme/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python/cloud_sptheme-1.6.tar.gz) = 658e8cf1479155faded4d88abd9dea8698b19baf2276bc8a25d51202a7bdce35
+SIZE (python/cloud_sptheme-1.6.tar.gz) = 412913
diff --git a/textproc/py-cloud_sptheme/pkg-descr b/textproc/py-cloud_sptheme/pkg-descr
new file mode 100644
index 000000000000..a2fdadc1ea0d
--- /dev/null
+++ b/textproc/py-cloud_sptheme/pkg-descr
@@ -0,0 +1,5 @@
+This is a small package containing a Sphinx theme named "Cloud",
+along with some related Sphinx extensions. To see an example
+of the theme in action, check out it's documentation.
+
+WWW: https://pypi.python.org/pypi/cloud_sptheme/