aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-09-22 13:30:31 +0800
committerlinimon <linimon@FreeBSD.org>2018-09-22 13:30:31 +0800
commit12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5 (patch)
treeee1202c5a5464562474562e70212261185323b7d /textproc
parent82b2604cbc93a294ed39ce8da691d406c1342992 (diff)
downloadfreebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.tar.gz
freebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.tar.zst
freebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.zip
Fix build on gcc-based archs by updating USES.
Tested on powerpc64 and amd64 (for no regression). While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/multimarkdown/Makefile4
-rw-r--r--textproc/regex2dfa/Makefile2
-rw-r--r--textproc/tinyxml2/Makefile2
3 files changed, 3 insertions, 5 deletions
diff --git a/textproc/multimarkdown/Makefile b/textproc/multimarkdown/Makefile
index 1a25578d0291..d887ae47b1de 100644
--- a/textproc/multimarkdown/Makefile
+++ b/textproc/multimarkdown/Makefile
@@ -13,11 +13,9 @@ LICENSE= BSD3CLAUSE MIT GPLv2+ ZLIB
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BROKEN_powerpc64= fails to compile: Sources/libMultiMarkdown/file.h:116: redefinition of typedef 'DString'
-
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= cmake localbase:ldflags
+USES= cmake compiler:c11 localbase:ldflags
USE_GITHUB= yes
GH_ACCOUNT= fletcher
GH_PROJECT= MultiMarkdown-6
diff --git a/textproc/regex2dfa/Makefile b/textproc/regex2dfa/Makefile
index f1619e72c893..b9d823a24603 100644
--- a/textproc/regex2dfa/Makefile
+++ b/textproc/regex2dfa/Makefile
@@ -10,7 +10,7 @@ COMMENT= Command-line utility that converts regular expressions to DFA
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake libtool
+USES= compiler:c++11-lang gmake libtool
USE_GITHUB= yes
GH_ACCOUNT= kpdyer
diff --git a/textproc/tinyxml2/Makefile b/textproc/tinyxml2/Makefile
index 5db571630fe5..8f5896a204c3 100644
--- a/textproc/tinyxml2/Makefile
+++ b/textproc/tinyxml2/Makefile
@@ -15,8 +15,8 @@ OPTIONS_DEFINE= EXAMPLES
CMAKE_OFF= BUILD_TESTS
CMAKE_ON= BUILD_SHARED_LIBS BUILD_STATIC_LIBS
+USES= cmake compiler:c++11-lang dos2unix pathfix
USE_LDCONFIG= yes
-USES= cmake dos2unix pathfix
PLIST_SUB= PORTVERSION=${PORTVERSION}
PORTEXAMPLES= *