aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2002-05-27 17:52:42 +0800
committerskv <skv@FreeBSD.org>2002-05-27 17:52:42 +0800
commit1acbd1373c75426998f9d135ed846e3531069d62 (patch)
tree156a8c3311eee532e2ddb68c2629d63fbe930ff3 /textproc
parent1361006975a7df36848f6ba689756605f11a052b (diff)
downloadfreebsd-ports-gnome-1acbd1373c75426998f9d135ed846e3531069d62.tar.gz
freebsd-ports-gnome-1acbd1373c75426998f9d135ed846e3531069d62.tar.zst
freebsd-ports-gnome-1acbd1373c75426998f9d135ed846e3531069d62.zip
Add p5-XML-Filter-Reindent 0.03,
reformats whitespace for pretty printing XML.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-Filter-Reindent/Makefile25
-rw-r--r--textproc/p5-XML-Filter-Reindent/distinfo1
-rw-r--r--textproc/p5-XML-Filter-Reindent/pkg-comment1
-rw-r--r--textproc/p5-XML-Filter-Reindent/pkg-descr8
-rw-r--r--textproc/p5-XML-Filter-Reindent/pkg-plist7
6 files changed, 43 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 8ff644cf75a4..eb8194324c71 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -189,6 +189,7 @@
SUBDIR += p5-XML-Filter-Base
SUBDIR += p5-XML-Filter-BufferText
SUBDIR += p5-XML-Filter-DetectWS
+ SUBDIR += p5-XML-Filter-Reindent
SUBDIR += p5-XML-Filter-SAXT
SUBDIR += p5-XML-Filter-XInclude
SUBDIR += p5-XML-Filter-XSLT
diff --git a/textproc/p5-XML-Filter-Reindent/Makefile b/textproc/p5-XML-Filter-Reindent/Makefile
new file mode 100644
index 000000000000..ff1175280543
--- /dev/null
+++ b/textproc/p5-XML-Filter-Reindent/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: XML::Filter::Reindent
+# Date created: 13 Mar 2002
+# Whom: Sergey Skvortsov <skv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Filter-Reindent
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/Filter/DetectWS.pm:${PORTSDIR}/textproc/p5-XML-Filter-DetectWS
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Filter::Reindent.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Filter-Reindent/distinfo b/textproc/p5-XML-Filter-Reindent/distinfo
new file mode 100644
index 000000000000..f4df0572a5e2
--- /dev/null
+++ b/textproc/p5-XML-Filter-Reindent/distinfo
@@ -0,0 +1 @@
+MD5 (XML-Filter-Reindent-0.03.tar.gz) = e3283c7e4cf5da68c1ffb17a454f58c6
diff --git a/textproc/p5-XML-Filter-Reindent/pkg-comment b/textproc/p5-XML-Filter-Reindent/pkg-comment
new file mode 100644
index 000000000000..e7e10352ad52
--- /dev/null
+++ b/textproc/p5-XML-Filter-Reindent/pkg-comment
@@ -0,0 +1 @@
+Reformats whitespace for pretty printing XML
diff --git a/textproc/p5-XML-Filter-Reindent/pkg-descr b/textproc/p5-XML-Filter-Reindent/pkg-descr
new file mode 100644
index 000000000000..86f2ca2fc347
--- /dev/null
+++ b/textproc/p5-XML-Filter-Reindent/pkg-descr
@@ -0,0 +1,8 @@
+XML::Filter::Reindent can be used as a PerlSAX filter to reformat an XML
+document before sending it to a PerlSAX handler that prints it (like
+XML::Handler::Composer.)
+
+WWW: http://search.cpan.org/search?dist=XML-Filter-Reindent
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/textproc/p5-XML-Filter-Reindent/pkg-plist b/textproc/p5-XML-Filter-Reindent/pkg-plist
new file mode 100644
index 000000000000..5104bb7aa45e
--- /dev/null
+++ b/textproc/p5-XML-Filter-Reindent/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Filter/Reindent/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/Filter/Reindent.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Filter/Reindent
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML/Filter 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Filter 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true